Loading ...
Sorry, an error occurred while loading the content.

Bug? in Polish v:lang and menu

Expand Messages
  • Mikolaj Machowski
    Hello, I discovered strange thing in 6.2 Cream version of Vim. ... Polish_Poland.852 instead of Polish_Poland.1250 which breaks sourcing of menu with proper
    Message 1 of 5 , Aug 2, 2003
    • 0 Attachment
      Hello,

      I discovered strange thing in 6.2 Cream version of Vim.
      :echo v:lang on Polish Windows returns
      Polish_Poland.852 instead of Polish_Poland.1250 which breaks sourcing of
      menu with proper encoding.

      But I am not sure it this is regular Vim problem or something was broken
      with patches applied by Creamers. I don't want to download whole
      distribution. Could someone with Polish version of Windows confirm that
      or give me chance to download only binaries?

      m.
      --
      LaTeX + Vim = http://vim-latex.sourceforge.net/
      Vim-list(s) Users Map: (last change 27 May)
      http://skawina.eu.org/mikolaj/vimlist
      Are You There?
    • Steve Hall
      On Sat, 2003-08-02 at 16:24, Mikolaj Machowski wrote: Hello, ... The Zip, binary-only packages are on the same page. The 6.2.57 we currently offer has only
      Message 2 of 5 , Aug 2, 2003
      • 0 Attachment
        On Sat, 2003-08-02 at 16:24, Mikolaj Machowski wrote:
        Hello,
        >
        > I discovered strange thing in 6.2 Cream version of Vim. :echo v:lang
        > on Polish Windows returns Polish_Poland.852 instead of
        > Polish_Poland.1250 which breaks sourcing of menu with proper
        > encoding.
        >
        > But I am not sure it this is regular Vim problem or something was
        > broken with patches applied by Creamers. I don't want to download
        > whole distribution. Could someone with Polish version of Windows
        > confirm that or give me chance to download only binaries?

        The Zip, binary-only packages are on the same page. The 6.2.57 we
        currently offer has only official patches applied, plus the feature
        ruby/dyn. Runtimes were current as of 2003-07-31. You did get our
        straight Vim binaries (gvim-6-2-57.exe) and not Vim with Cream
        (gvim-6-2-57-cream-0-23.exe), right? :)


        --
        Steve Hall [ digitect@... ]
      • Mikolaj Machowski
        ... I took gvim-6-2-57.zip OK. Thus it makes official Vim bug. Here is quick fix for that. But it should be done on Vim code level. Problem can affect other
        Message 3 of 5 , Aug 2, 2003
        • 0 Attachment
          On Sat, Aug 02, 2003 at 05:39:00PM -0400, Steve Hall wrote:
          > On Sat, 2003-08-02 at 16:24, Mikolaj Machowski wrote:
          > Hello,
          > >
          > > I discovered strange thing in 6.2 Cream version of Vim. :echo v:lang
          > > on Polish Windows returns Polish_Poland.852 instead of
          > > Polish_Poland.1250 which breaks sourcing of menu with proper
          > > encoding.
          > >
          > > But I am not sure it this is regular Vim problem or something was
          > > broken with patches applied by Creamers. I don't want to download
          > > whole distribution. Could someone with Polish version of Windows
          > > confirm that or give me chance to download only binaries?
          > The Zip, binary-only packages are on the same page. The 6.2.57 we
          > currently offer has only official patches applied, plus the feature
          > ruby/dyn. Runtimes were current as of 2003-07-31. You did get our
          > straight Vim binaries (gvim-6-2-57.exe) and not Vim with Cream
          > (gvim-6-2-57-cream-0-23.exe), right? :)

          I took gvim-6-2-57.zip
          OK. Thus it makes "official" Vim bug.
          Here is quick fix for that. But it should be done on Vim code level.
          Problem can affect other Windows style encodings.

          m.

          --- vim62/runtime/menu.vim 2003-05-04 22:58:58.000000000 +0200
          +++ /mnt/win_f/vim62/menu.vim 2003-08-02 18:43:44.000000000 +0200
          @@ -40,6 +40,9 @@
          " Remove "@euro", otherwise "LC_ALL=de_DE@euro gvim" will show English menus
          let s:lang = substitute(s:lang, "@euro", "", "")
          menutrans clear
          + if s:lang =~ "polish"
          + let s:lang = "polish_poland.1250"
          + endif
          exe "runtime! lang/menu_" . s:lang . ".vim"

          if !exists("did_menu_trans")
        • Bram Moolenaar
          ... I would guess your problem is not caused by Vim, because Vim doesn t make up this string. It comes from your environment. Thus somehow you have selected
          Message 4 of 5 , Aug 3, 2003
          • 0 Attachment
            Mikolaj Machowski wrote:

            > On Sat, Aug 02, 2003 at 05:39:00PM -0400, Steve Hall wrote:
            > > On Sat, 2003-08-02 at 16:24, Mikolaj Machowski wrote:
            > > Hello,
            > > >
            > > > I discovered strange thing in 6.2 Cream version of Vim. :echo v:lang
            > > > on Polish Windows returns Polish_Poland.852 instead of
            > > > Polish_Poland.1250 which breaks sourcing of menu with proper
            > > > encoding.
            > > >
            > > > But I am not sure it this is regular Vim problem or something was
            > > > broken with patches applied by Creamers. I don't want to download
            > > > whole distribution. Could someone with Polish version of Windows
            > > > confirm that or give me chance to download only binaries?
            > > The Zip, binary-only packages are on the same page. The 6.2.57 we
            > > currently offer has only official patches applied, plus the feature
            > > ruby/dyn. Runtimes were current as of 2003-07-31. You did get our
            > > straight Vim binaries (gvim-6-2-57.exe) and not Vim with Cream
            > > (gvim-6-2-57-cream-0-23.exe), right? :)
            >
            > I took gvim-6-2-57.zip
            > OK. Thus it makes "official" Vim bug.
            > Here is quick fix for that. But it should be done on Vim code level.
            > Problem can affect other Windows style encodings.
            >
            > m.
            >
            > --- vim62/runtime/menu.vim 2003-05-04 22:58:58.000000000 +0200
            > +++ /mnt/win_f/vim62/menu.vim 2003-08-02 18:43:44.000000000 +0200
            > @@ -40,6 +40,9 @@
            > " Remove "@euro", otherwise "LC_ALL=de_DE@euro gvim" will show English menus
            > let s:lang = substitute(s:lang, "@euro", "", "")
            > menutrans clear
            > + if s:lang =~ "polish"
            > + let s:lang = "polish_poland.1250"
            > + endif
            > exe "runtime! lang/menu_" . s:lang . ".vim"
            >
            > if !exists("did_menu_trans")

            I would guess your problem is not caused by Vim, because Vim doesn't
            make up this string. It comes from your environment. Thus somehow you
            have selected codepage 852 in your Windows settings.

            If you want to overrule the language that Vim uses you can set
            'encoding' to "cp1250" and use the ":language" command to set the
            locale.

            --
            Due knot trussed yore spell chequer two fined awl miss steaks.

            /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
            /// Creator of Vim - Vi IMproved -- http://www.Vim.org \\\
            \\\ Project leader for A-A-P -- http://www.A-A-P.org ///
            \\\ Help AIDS victims, buy here: http://ICCF-Holland.org/click1.html ///
          • Mikolaj Machowski
            ... But with 6.1 v:lang returns properly string Polish_Poland.1250 m. -- LaTeX + Vim = http://vim-latex.sourceforge.net/ Vim-list(s) Users Map: (last change 27
            Message 5 of 5 , Aug 3, 2003
            • 0 Attachment
              On Sun, Aug 03, 2003 at 12:53:31PM +0200, Bram Moolenaar wrote:
              > > I took gvim-6-2-57.zip
              > > OK. Thus it makes "official" Vim bug.
              > > Here is quick fix for that. But it should be done on Vim code level.
              > > Problem can affect other Windows style encodings.
              > >
              > > m.
              > >
              > > --- vim62/runtime/menu.vim 2003-05-04 22:58:58.000000000 +0200
              > > +++ /mnt/win_f/vim62/menu.vim 2003-08-02 18:43:44.000000000 +0200
              > > @@ -40,6 +40,9 @@
              > > " Remove "@euro", otherwise "LC_ALL=de_DE@euro gvim" will show English menus
              > > let s:lang = substitute(s:lang, "@euro", "", "")
              > > menutrans clear
              > > + if s:lang =~ "polish"
              > > + let s:lang = "polish_poland.1250"
              > > + endif
              > > exe "runtime! lang/menu_" . s:lang . ".vim"
              > >
              > > if !exists("did_menu_trans")
              > I would guess your problem is not caused by Vim, because Vim doesn't
              > make up this string. It comes from your environment. Thus somehow you
              > have selected codepage 852 in your Windows settings.
              > If you want to overrule the language that Vim uses you can set
              > 'encoding' to "cp1250" and use the ":language" command to set the
              > locale.

              But with 6.1 v:lang returns properly string Polish_Poland.1250

              m.
              --
              LaTeX + Vim = http://vim-latex.sourceforge.net/
              Vim-list(s) Users Map: (last change 27 May)
              http://skawina.eu.org/mikolaj/vimlist
              Are You There?
            Your message has been successfully submitted and would be delivered to recipients shortly.