Loading ...
Sorry, an error occurred while loading the content.

Re: Vim GTK+ 2 patches

Expand Messages
  • Daniel Elstner
    Hey Marcelo, ... Oh yes. I found it out the hard way as well :-) ... Ah, silly oversight. Thanks. ... Thanks again. I put this into src/proto.h where the
    Message 1 of 1 , Mar 4, 2003
    View Source
    • 0 Attachment
      Hey Marcelo,

      On Die, 2003-03-04 at 11:23, Marcelo E. Magallon wrote:
      > Hi Daniel,
      >
      > I sent a mail to vim-dev regarding this, but it's not in the archives,
      > so I guess it didn't show up. I'm not subscribed to vim-dev, and it
      > seems mail from non-subscribers are silently dropped.

      Oh yes. I found it out the hard way as well :-)

      > Attached are following patches:
      >
      > 98skip_gtk2:
      >
      > skip checks for GTK2 if configuring without a GUI, one-liner.

      Ah, silly oversight. Thanks.

      > 99gdk_hack
      >
      > horrible hack to get vim to compile if compiling without a GUI.
      > There's probably a much better way to do this. The problem is
      > mbyte.proto needs GdkKeyEvent.

      Thanks again. I put this into src/proto.h where the other "horrible
      hacks" are. (It seems to be the canonical Vim way to do this, 'cuz the
      proto files are supposed to be autogenerated.)

      > 99gui_not_in_use
      >
      > A vim compile *with* a GTK+ 2 GUI will complain more or less
      > continously because it tries to change the window title using GTK+
      > calls if t_ts is not set. It's extremely annoying. Maybe the check
      > has to be moved upwards in the function call stack, but to me it
      > seemed natural to place it here.

      Whoa, that's gross. Thanks for reporting this -- I'd never have
      noticed. I had to unset 't_ts' and redirect stderr to a file to make
      the error messages visible :)

      I put the check into os_unix.c (mch_settitle) and reenabled
      set_x11_title() which can apparently be used in the terminal as well.
      I had disabled it entirely if compiling for GTK+ but that was apparently
      a mistake. Thanks for making me fix this!

      Here's the new patch with all of your fixes included:

      http://regexxer.sourceforge.net/vim/vim-gtk2-20030304.patch.gz

      > Greetings and thanks for the great work,

      Cheers.

      Greetings and much thanks for the fixups,
      --Daniel
    Your message has been successfully submitted and would be delivered to recipients shortly.