Loading ...
Sorry, an error occurred while loading the content.

Re: in xterm

Expand Messages
  • Andrew Pimlott
    ... My main source of information was http://www.mit.edu/afs/athena/user/d/a/daveg/Info/backtab-howto.txt ... I just assumed there was one and you would know
    Message 1 of 3 , Feb 5, 2003
    • 0 Attachment
      On Wed, Feb 05, 2003 at 10:04:22PM +0100, Bram Moolenaar wrote:
      >
      > Andrew Pimlott wrote:
      >
      > > <S-Tab> (shift-tab) doesn't work propertly on my vim 6.1 in an xterm
      > > (on Debian GNU/Linux testing). I did some searching and found that
      > > my xterm and terminfo (it is terminfo capability kcbt or key_btab)
      > > support this, but vim (compiled with +terminfo) doesn't. I'm trying
      > > to figure out the right way to fix this.
      >
      > Where can you find documentation about which termcap/terminfo entry is
      > used for Shift-Tab? Where is documented that xterm sends \033[Z for
      > Shift-Tab?

      My main source of information was

      http://www.mit.edu/afs/athena/user/d/a/daveg/Info/backtab-howto.txt

      > I wonder if these are Debian or Linux extensions instead of general
      > standards. I am not aware of an official standard for termcap/terminfo
      > entries.

      I just assumed there was one and you would know where to find it.
      :-)

      > > 2. Even when compiled for terminfo, vim only really uses the
      > > termcap API, and so only has access via terminfo to keys with
      > > termcap codes (which <S-Tab> has not).
      >
      > I thought that every terminfo entry had an equivalent termcap name.

      I don't really know anything about termcap or terminfo. Here's what
      I did: I type ":set termcap" in vim to see all the special
      characters that work (in xterm), but don't have any t_ code next to
      them. Then, I ran "infocmp xterm" and looked for the sequences for
      those special characters. I found most of them in the infocmp
      output. Eg,

      terminfo vim
      kf17 <S-F5>
      kf13 <S-xF1>
      kLFT <C-Left>
      kcbt <S-Tab>

      I inferred that terminfo, being newer, had some codes that were
      never added to termcap. I also noticed that the termcap codes (for
      characters that had them) bore no obvious relation to the terminfo
      codes. Eg,

      termcap terminfo vim
      F1 kf11 <F11>
      kN knp <PageDown>
      kd kcud1 <Down>

      Well, I also just noticed that some sequences for which vim has an
      entry are not in the infocmp:

      termcap terminfo vim
      #2 ??? <S-Home>
      @7 ??? <End>

      All FWIW.

      > > 3. t_ options are only available for termcap codes.
      >
      > Yes, you don't need them for key codes.

      I'm not sure I understand. I mean that it would be nice to have
      some option I could have set to make <S-Tab> work, without
      recompling.

      Andrew
    Your message has been successfully submitted and would be delivered to recipients shortly.