Loading ...
Sorry, an error occurred while loading the content.

Re: problem compiling latest GTK+ 2 patch

Expand Messages
  • Daniel Elstner
    ... [...] OK, this one is strange. I found a little mistake in a sed expression but it has been there for ages. Also there was a pair of double quotes that
    Message 1 of 8 , Feb 3, 2003
    • 0 Attachment
      On Die, 2003-02-04 at 02:07, Travis Hume wrote:
      > I do have libgnomeui-2.0 dev stuff installed:

      [...]

      OK, this one is strange. I found a little mistake in a sed expression
      but it has been there for ages. Also there was a pair of double quotes
      that could cause trouble if the expanded variable contained spaces. So
      basically just guessing around; I'm lost here.

      Please try the slightly adapted patch:

      http://regexxer.sourceforge.net/vim/vim-gtk2-20030204.patch

      Make sure to apply against an absolutely clean tree. If this fails
      again, please send me the output of ./configure, the version number of
      pkg-config, and tell me about anything else that could be even just
      remotely related to this problem :)

      clueless,
      --Daniel
    • Daniel Elstner
      ... I received it, but indeed not via the list :) ... Thanks for reporting this. I wasn t aware of the problem because I only tested disabling the toolbar
      Message 2 of 8 , Feb 4, 2003
      • 0 Attachment
        On Die, 2003-02-04 at 19:52, travis_hume wrote:
        > I'm not sure if my response made it to the list, so ... the latest
        > patch seems to have fixed my problems compiling.

        I received it, but indeed not via the list :)

        > Aside from problems turning off the toolbar, it works great.

        Thanks for reporting this. I wasn't aware of the problem because I only
        tested disabling the toolbar after startup, but not in ~/.gvimrc.
        BonoboDockLayout seems to force a show after restoring the item
        placement. I hacked around that now:

        http://regexxer.sourceforge.net/vim/vim-gtk2-20030205.patch

        This patch also goes one step further in removing cruft and disabled the
        +xfontset feature at compile time if GTK+ 2 is used. Also, all the code
        dealing with guifontset, guifontwide, and switching between the various
        styled fonts for highlighting is now enclosed by #ifndef HAVE_GTK2.

        Happy testing,
        --Daniel
      • Travis Hume
        I applied the latest patch (20030205) to a clean vim cvs tree and had some problems. I ve attached the error I m seeing and the config.log file. ... -- Travis
        Message 3 of 8 , Feb 6, 2003
        • 0 Attachment
          I applied the latest patch (20030205) to a clean vim cvs tree and had
          some problems. I've attached the error I'm seeing and the config.log file.

          Daniel Elstner wrote:

          >Looks like I got your address wrong. Here's the mail it again:
          >
          >On Die, 2003-02-04 at 19:52, travis_hume wrote:
          >
          >
          >>I'm not sure if my response made it to the list, so ... the latest
          >>patch seems to have fixed my problems compiling.
          >>
          >>
          >
          >I received it, but indeed not via the list :)
          >
          >
          >
          >>Aside from problems turning off the toolbar, it works great.
          >>
          >>
          >
          >Thanks for reporting this. I wasn't aware of the problem because I only
          >tested disabling the toolbar after startup, but not in ~/.gvimrc.
          >BonoboDockLayout seems to force a show after restoring the item
          >placement. I hacked around that now:
          >
          > http://regexxer.sourceforge.net/vim/vim-gtk2-20030205.patch
          >
          >This patch also goes one step further in removing cruft and disabled the
          >+xfontset feature at compile time if GTK+ 2 is used. Also, all the code
          >dealing with guifontset, guifontwide, and switching between the various
          >styled fonts for highlighting is now enclosed by #ifndef HAVE_GTK2.
          >
          >Happy testing,
          >--Daniel
          >
          >
          >

          --
          Travis Hume
          Software Engineer
          Tenzing Communications Inc.
          travis.hume@...
        • Daniel Elstner
          ... Ooops. That s because I m a dimwit. Gotta add -std=c89 to my CFLAGS... Here s the fixed patch:
          Message 4 of 8 , Feb 6, 2003
          • 0 Attachment
            On Don, 2003-02-06 at 17:59, Travis Hume wrote:
            > I applied the latest patch (20030205) to a clean vim cvs tree and had
            > some problems. I've attached the error I'm seeing and the config.log file.

            Ooops. That's because I'm a dimwit. Gotta add -std=c89 to my CFLAGS...

            Here's the fixed patch:

            http://regexxer.sourceforge.net/vim/vim-gtk2-20030206.patch

            --Daniel
          • Travis Hume
            That did the trick. Toolbars are no longer present for me. Thanks. ... -- Travis Hume Software Engineer Tenzing Communications Inc. travis.hume@tenzing.com
            Message 5 of 8 , Feb 6, 2003
            • 0 Attachment
              That did the trick. Toolbars are no longer present for me. Thanks.

              Daniel Elstner wrote:

              >On Don, 2003-02-06 at 17:59, Travis Hume wrote:
              >
              >
              >>I applied the latest patch (20030205) to a clean vim cvs tree and had
              >>some problems. I've attached the error I'm seeing and the config.log file.
              >>
              >>
              >
              >Ooops. That's because I'm a dimwit. Gotta add -std=c89 to my CFLAGS...
              >
              >Here's the fixed patch:
              >
              > http://regexxer.sourceforge.net/vim/vim-gtk2-20030206.patch
              >
              >--Daniel
              >
              >
              >

              --
              Travis Hume
              Software Engineer
              Tenzing Communications Inc.
              travis.hume@...
            Your message has been successfully submitted and would be delivered to recipients shortly.