Loading ...
Sorry, an error occurred while loading the content.
 

Re: problem compiling latest GTK+ 2 patch

Expand Messages
  • Travis Hume
    I do have libgnomeui-2.0 dev stuff installed: gnome-base/libgnomeui-2.1.90 /tmp: pkg-config --cflags libgnomeui-2.0 -DORBIT2=1 -pthread
    Message 1 of 8 , Feb 3, 2003
      I do have libgnomeui-2.0 dev stuff installed:

      gnome-base/libgnomeui-2.1.90

      /tmp: pkg-config --cflags libgnomeui-2.0
      -DORBIT2=1 -pthread -I/usr/include/libgnomeui-2.0
      -I/usr/include/libgnome-2.0 -I/usr/include/libgnomecanvas-2.0
      -I/usr/include/gtk-2.0 -I/usr/include/libart-2.0 -I/usr/include/gconf/2
      -I/usr/include/libbonoboui-2.0 -I/usr/include/glib-2.0
      -I/usr/lib/glib-2.0/include -I/usr/include/orbit-2.0
      -I/usr/include/libbonobo-2.0 -I/usr/include/gnome-vfs-2.0
      -I/usr/lib/gnome-vfs-2.0/include -I/usr/include/linc-1.0
      -I/usr/include/bonobo-activation-2.0 -I/usr/include/pango-1.0
      -I/usr/include/freetype2 -I/usr/lib/gtk-2.0/include
      -I/usr/include/atk-1.0 -I/usr/X11R6/include -I/usr/include/libxml2

      /tmp: pkg-config --libs libgnomeui-2.0
      -pthread -Wl,--export-dynamic -L/usr/X11R6/lib -lgnomeui-2 -lSM -lICE
      -lbonoboui-2 -lxml2 -lz -lgnomecanvas-2 -lgnome-2 -lart_lgpl_2
      -lpangoft2-1.0 -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0
      -lpangoxft-1.0 -lpangox-1.0 -lpango-1.0 -lbonobo-2 -lgconf-2
      -lgnomevfs-2 -lbonobo-activation -lORBit-2 -lm -llinc -lgmodule-2.0 -ldl
      -lgobject-2.0
      -lgthread-2.0 -lglib-2.0

      The last time I built with the same options:

      ./configure --with-features=big --enable-gtk2-check --enable-gnome-check
      --enable-pythoninterp

      Daniel Elstner wrote:

      >On Die, 2003-02-04 at 01:11, Travis Hume wrote:
      >
      >
      >>I've attached the gcc error(s) after applying the latest GTK+2 patch to
      >>a cleanly checked out vim source tree.
      >>
      >>
      >
      >OK, looks like configure pulled GTK+ 2 plus GNOME 1 stuff for some
      >reason. I guess you don't have libgnomeui-2.0 development packages
      >installed; although it should have bailed out with an error message.
      >
      >Could you send me config.log please?
      >
      >
      >
      >>The last patch built perfectly.
      >>
      >>
      >
      >Which ./configure flags did you use last time?
      >
      >Thanks,
      >--Daniel
      >
      >
      >

      --
      Travis Hume
      Software Engineer
      Tenzing Communications Inc.
      travis.hume@...
    • Daniel Elstner
      ... [...] OK, this one is strange. I found a little mistake in a sed expression but it has been there for ages. Also there was a pair of double quotes that
      Message 2 of 8 , Feb 3, 2003
        On Die, 2003-02-04 at 02:07, Travis Hume wrote:
        > I do have libgnomeui-2.0 dev stuff installed:

        [...]

        OK, this one is strange. I found a little mistake in a sed expression
        but it has been there for ages. Also there was a pair of double quotes
        that could cause trouble if the expanded variable contained spaces. So
        basically just guessing around; I'm lost here.

        Please try the slightly adapted patch:

        http://regexxer.sourceforge.net/vim/vim-gtk2-20030204.patch

        Make sure to apply against an absolutely clean tree. If this fails
        again, please send me the output of ./configure, the version number of
        pkg-config, and tell me about anything else that could be even just
        remotely related to this problem :)

        clueless,
        --Daniel
      • Daniel Elstner
        ... I received it, but indeed not via the list :) ... Thanks for reporting this. I wasn t aware of the problem because I only tested disabling the toolbar
        Message 3 of 8 , Feb 4, 2003
          On Die, 2003-02-04 at 19:52, travis_hume wrote:
          > I'm not sure if my response made it to the list, so ... the latest
          > patch seems to have fixed my problems compiling.

          I received it, but indeed not via the list :)

          > Aside from problems turning off the toolbar, it works great.

          Thanks for reporting this. I wasn't aware of the problem because I only
          tested disabling the toolbar after startup, but not in ~/.gvimrc.
          BonoboDockLayout seems to force a show after restoring the item
          placement. I hacked around that now:

          http://regexxer.sourceforge.net/vim/vim-gtk2-20030205.patch

          This patch also goes one step further in removing cruft and disabled the
          +xfontset feature at compile time if GTK+ 2 is used. Also, all the code
          dealing with guifontset, guifontwide, and switching between the various
          styled fonts for highlighting is now enclosed by #ifndef HAVE_GTK2.

          Happy testing,
          --Daniel
        • Travis Hume
          I applied the latest patch (20030205) to a clean vim cvs tree and had some problems. I ve attached the error I m seeing and the config.log file. ... -- Travis
          Message 4 of 8 , Feb 6, 2003
            I applied the latest patch (20030205) to a clean vim cvs tree and had
            some problems. I've attached the error I'm seeing and the config.log file.

            Daniel Elstner wrote:

            >Looks like I got your address wrong. Here's the mail it again:
            >
            >On Die, 2003-02-04 at 19:52, travis_hume wrote:
            >
            >
            >>I'm not sure if my response made it to the list, so ... the latest
            >>patch seems to have fixed my problems compiling.
            >>
            >>
            >
            >I received it, but indeed not via the list :)
            >
            >
            >
            >>Aside from problems turning off the toolbar, it works great.
            >>
            >>
            >
            >Thanks for reporting this. I wasn't aware of the problem because I only
            >tested disabling the toolbar after startup, but not in ~/.gvimrc.
            >BonoboDockLayout seems to force a show after restoring the item
            >placement. I hacked around that now:
            >
            > http://regexxer.sourceforge.net/vim/vim-gtk2-20030205.patch
            >
            >This patch also goes one step further in removing cruft and disabled the
            >+xfontset feature at compile time if GTK+ 2 is used. Also, all the code
            >dealing with guifontset, guifontwide, and switching between the various
            >styled fonts for highlighting is now enclosed by #ifndef HAVE_GTK2.
            >
            >Happy testing,
            >--Daniel
            >
            >
            >

            --
            Travis Hume
            Software Engineer
            Tenzing Communications Inc.
            travis.hume@...
          • Daniel Elstner
            ... Ooops. That s because I m a dimwit. Gotta add -std=c89 to my CFLAGS... Here s the fixed patch:
            Message 5 of 8 , Feb 6, 2003
              On Don, 2003-02-06 at 17:59, Travis Hume wrote:
              > I applied the latest patch (20030205) to a clean vim cvs tree and had
              > some problems. I've attached the error I'm seeing and the config.log file.

              Ooops. That's because I'm a dimwit. Gotta add -std=c89 to my CFLAGS...

              Here's the fixed patch:

              http://regexxer.sourceforge.net/vim/vim-gtk2-20030206.patch

              --Daniel
            • Travis Hume
              That did the trick. Toolbars are no longer present for me. Thanks. ... -- Travis Hume Software Engineer Tenzing Communications Inc. travis.hume@tenzing.com
              Message 6 of 8 , Feb 6, 2003
                That did the trick. Toolbars are no longer present for me. Thanks.

                Daniel Elstner wrote:

                >On Don, 2003-02-06 at 17:59, Travis Hume wrote:
                >
                >
                >>I applied the latest patch (20030205) to a clean vim cvs tree and had
                >>some problems. I've attached the error I'm seeing and the config.log file.
                >>
                >>
                >
                >Ooops. That's because I'm a dimwit. Gotta add -std=c89 to my CFLAGS...
                >
                >Here's the fixed patch:
                >
                > http://regexxer.sourceforge.net/vim/vim-gtk2-20030206.patch
                >
                >--Daniel
                >
                >
                >

                --
                Travis Hume
                Software Engineer
                Tenzing Communications Inc.
                travis.hume@...
              Your message has been successfully submitted and would be delivered to recipients shortly.