Loading ...
Sorry, an error occurred while loading the content.
 

Re: Problems with utf8 encoding

Expand Messages
  • Piet Delport
    ... Looks fine so far. ... What telnet/SSH terminal emulator are you using, and have you set it up to expect UTF-8 data? I get exactly the behaviour you
    Message 1 of 3 , Dec 6, 2002
      On Thu, 05 Dec 2002 at 21:58:57 -0800, Srinath Avadhanula wrote:
      >
      > Of late, I have been trying to get latex-suite to support utf8 encoding.
      >
      > I have however noticed what seems to be an inconsistency in the way utf8
      > characters display in vim/win2k and the way they display in
      > vim/linux/cygwin.
      >
      > The problem is very simple to replicate:
      >
      > 1. vim -u NONE -U NONE
      > 2. :set encoding=utf8
      > 3. type in the following sequence of characters:
      > i<CTRL-k><< (for linux)
      > i<CTRL-q><< (for windows)

      Looks fine so far.

      > Now in windows, that displays a single cell character which looks like
      > <<. However, in linux this displays as 2 characters «
      > (<captial A hat><«>).
      >
      > Is this something which can be fixed by a setting?
      >
      > Thanks,
      >
      > PS: I am using vim6.1 on all platforms. The linux platform was
      > Linux sc8-pr-shell1.sourceforge.net 2.4.18-grsec-1.9.4
      > This is the shell provided to sourceforge.net users.

      What telnet/SSH terminal emulator are you using, and have you set it up
      to expect UTF-8 data?

      I get exactly the behaviour you describe above when i set Vim's encoding
      to UTF-8, but leave my SSH client (PuTTY on Win2k) expecting ISO-8859-1
      encoded data (the default on PuTTY). Telling PuTTY to interpret
      incoming data as UTF-8 solved the problem.

      --
      Piet Delport
      Today's subliminal thought is:
    • Srinath Avadhanula
      ... Aah! I didn t think about this. Thanks! I will take a look at this again. I looked at the options for the secure shell client I use and didn t find any
      Message 2 of 3 , Dec 6, 2002
        On Fri, 6 Dec 2002, Piet Delport wrote:

        > What telnet/SSH terminal emulator are you using, and have you set it up
        > to expect UTF-8 data?
        >
        > I get exactly the behaviour you describe above when i set Vim's encoding
        > to UTF-8, but leave my SSH client (PuTTY on Win2k) expecting ISO-8859-1
        > encoded data (the default on PuTTY). Telling PuTTY to interpret
        > incoming data as UTF-8 solved the problem.

        Aah! I didn't think about this. Thanks! I will take a look at this
        again. I looked at the options for the secure shell client I use and
        didn't find any settings affecting the terminal encoding...

        However, I notice the same effect on cygwin/vim. I am not sure what kind
        of problem there is in that combination... I guess the best thing to do
        is to try it on a real linux box.

        --
        Srinath Avadhanula
        Dec 6 3:51pm
        "The porcupine with the sharpest quills gets stuck on a tree more
        often."
      Your message has been successfully submitted and would be delivered to recipients shortly.