Loading ...
Sorry, an error occurred while loading the content.
 

Re: Undo levels lost after :make

Expand Messages
  • Bram Moolenaar
    ... Setting the hidden options should do it. :make isn t really different from other commands when it comes to losing the undo info. -- ... /// Bram
    Message 1 of 2 , Oct 2, 2002
      Milan Vancura wrote:

      > I have found a little problem with :make or :cn. After that cursor is
      > moved to the line of the first error/warning. If the error was in
      > another file than you have edited before, the file in current window
      > is automaticaly changed. You can still go back via ctrl-O, but all
      > undo levels are lost. This is bad because the time you need undo is
      > mostly when some error occurs :-)
      >
      > I don't want to stop use these quickfix features, they are very good and
      > comfortable. So my idea of solution:
      >
      > 1) look if the file with the next error is opened in another window. If so,
      > change the window instead of changing buffer in the current window.
      >
      > 2) If the buffer in the current window must be changed, save the previous
      > buffer. What about mark this buffer as 'hidden'? Does it solve the
      > problem?
      >
      > I hope this problem is solutable without adding any new special
      > modes/features to vim.

      Setting the 'hidden' options should do it.

      ":make" isn't really different from other commands when it comes to
      losing the undo info.

      --
      From "know your smileys":
      :-* A big kiss!

      /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
      /// Creator of Vim - Vi IMproved -- http://www.vim.org \\\
      \\\ Project leader for A-A-P -- http://www.a-a-p.org ///
      \\\ Lord Of The Rings helps Uganda - http://iccf-holland.org/lotr.html ///
    Your message has been successfully submitted and would be delivered to recipients shortly.