Loading ...
Sorry, an error occurred while loading the content.

Fw: iminsert on Windows

Expand Messages
  • MURAOKA Taro
    He wrote extra informations about this to me that he use these mappings: inoremap g inoremap g This unexpected IM activation is
    Message 1 of 1 , Oct 1, 2002
    • 0 Attachment
      He wrote extra informations about this to me that he use these mappings:

      inoremap <Down> <C-O>g<Down>
      inoremap <Up> <C-O>g<Up>

      This unexpected IM activation is caused by i_<C-O> in these mappings.
      When input i_<C-O> to vim, ins_esc() is called and it call
      im_save_status(). But im_save_status() doesn't save any values when
      KeyTyped is FALSE: in the mapping. So 'iminsert' will have old value.

      I wrote 3 type patches for fixing this. Each and all can fix this
      problem, but I can't decide which one is the best (without side effects
      and logically correct) solution. Please check attached patches.

      Thanks.
      ----
      MURAOKA Taro <koron@...>


      Hiroshi Iwatani wrote to vim@...:
      > In the writing mode, after you have used the input method
      > more than once, up and down arrow keys keep playing the role
      > of the <im-invoking-key> as if someone has assigned the
      > extra key mapping.
      >
      > This phenomenon never occurs on another Windows applications
      > including other editors which I, a mild Vim addict, now dislike.
      >
      > Setting iminsert=0 in the _vimrc file has no effect on this
      > problem. Quite annoying if you want to continue inputting
      > plain ASCII chars over multiple lines.
      >
      > Could someone help?
      > --
      > Hiroshi Iwatani
    Your message has been successfully submitted and would be delivered to recipients shortly.