Loading ...
Sorry, an error occurred while loading the content.
 

Re: sjis encoding

Expand Messages
  • Hiroshi Iwatani
    MURAOKA san Thanks for your info. I ve found that another method, seemingly a simple conversion method, does work. ... It is usable, though not much
    Message 1 of 5 , May 3, 2002
      MURAOKA san

      Thanks for your info.

      I've found that another method, seemingly a simple conversion
      method, does work.

      :edit ++enc=sjis /mnt/windows/foo.txt
      ...
      :write ++enc=sjis /mnt/windows/foo.txt

      It is usable, though not much impressive.
      A script would be a little bit more convenient:

      #!/bin/sh
      qkc -eu $1
      gvim $1
      qkc -sm $1

      It might be that I'm only seeking some nice 'implemental sugar'
      for an easy/automatic encoding handling. Above method and your
      recommended one, both methods require too many typing on command
      lines!

      For example, could you add an [Encodings] menu or sub-menu
      for a next 6.x release?

      MURAOKA Taro wrote:
      > What distribution of linux do you use? If you use standard Japanese
      > distribution (have iconv library that support sjis encoding) and you
      > could edit text files in euc-jp encoding, try below settings:
      >
      > :set encoding=japan
      > :set fileencodings=iso-2022-jp,sjis,cp932
      >
      > Regards.
      > ----
      > MURAOKA Taro <koron@...>
      >
      > # I can answer most of Japanese specific questions.
      > # Of cource in Japanese. ;-)
      >
      >
      >
      >>On our Linux paltform, sometimes we'd like to view and edit Japanese
      >>texts documents prepared in the DOS/Windows environment.
      >>
      >> :set encoding=sjis
      >> :set fileencoding=sjis
      >>
      >>These commands do not bring the expected effects, in fact, any
      >>visible effects other than a nonsensical gVim screen.
      >>
      >>How could we change the encoding from the default locale?
      >>
      >
      >
      >
    • MURAOKA Taro
      ... Why don t you write those lines in your $HOME/.vimrc? Vim has enough capability in automatic encode handling by using fileencodings option. ... MURAOKA
      Message 2 of 5 , May 3, 2002
        > Above method and your recommended one, both methods require too many
        > typing on command lines!

        Why don't you write those lines in your $HOME/.vimrc? Vim has enough
        capability in automatic encode handling by using 'fileencodings'
        option.
        ----
        MURAOKA Taro <koron@...>
      Your message has been successfully submitted and would be delivered to recipients shortly.