Loading ...
Sorry, an error occurred while loading the content.

[mb,syn] mb-char in first line of syntaxed buffer

Expand Messages
  • Muraoka Taro
    In syntax enabled buffer, multibyte characters in first line sometimes cause crash. I have made small patch against this problem. Please check attached one.
    Message 1 of 5 , Jan 3, 2002
    • 0 Attachment
      In syntax enabled buffer, multibyte characters in first line sometimes
      cause crash. I have made small patch against this problem. Please check
      attached one.
      ----
      Muraoka Taro <koron@...>
    • Bram Moolenaar
      ... It looks like this would mean regrepeat() did something wrong. Can you give a reproducable example of when the crash happens? -- Computers are not
      Message 2 of 5 , Jan 3, 2002
      • 0 Attachment
        Muraoka Taro wrote:

        > In syntax enabled buffer, multibyte characters in first line sometimes
        > cause crash. I have made small patch against this problem. Please check
        > attached one.

        It looks like this would mean regrepeat() did something wrong. Can you
        give a reproducable example of when the crash happens?

        --
        Computers are not intelligent. They only think they are.

        /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
        ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
        \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
      • Muraoka Taro
        Sample files are attached. 1. Open attached file crash_sample_1.c. 2. :syntax on, and :set ft=c enc=japan. (Require multibyte encoding) 3. Insert some alphabet
        Message 3 of 5 , Jan 3, 2002
        • 0 Attachment
          Sample files are attached.

          1. Open attached file crash_sample_1.c.
          2. :syntax on, and :set ft=c enc=japan.
          (Require multibyte encoding)
          3. Insert some alphabet at top of first line.
          (Type Ia)
          4. Now crash.
          5. Try same on crash_sample_2.c, it also crash.
          (It's not depend on a specified multi-byte character)
          ----
          Muraoka Taro <koron@...>


          > Muraoka Taro wrote:
          >
          > > In syntax enabled buffer, multibyte characters in first line sometimes
          > > cause crash. I have made small patch against this problem. Please check
          > > attached one.
          >
          > It looks like this would mean regrepeat() did something wrong. Can you
          > give a reproducable example of when the crash happens?
        • Bram Moolenaar
          ... Tried it, but it doesn t crash for me... -- MORTICIAN: What? CUSTOMER: Nothing -- here s your nine pence. DEAD PERSON: I m not dead! MORTICIAN:
          Message 4 of 5 , Jan 3, 2002
          • 0 Attachment
            Muraoka Taro wrote:

            > Sample files are attached.
            >
            > 1. Open attached file crash_sample_1.c.
            > 2. :syntax on, and :set ft=c enc=japan.
            > (Require multibyte encoding)
            > 3. Insert some alphabet at top of first line.
            > (Type Ia)
            > 4. Now crash.
            > 5. Try same on crash_sample_2.c, it also crash.
            > (It's not depend on a specified multi-byte character)

            Tried it, but it doesn't crash for me...

            --
            MORTICIAN: What?
            CUSTOMER: Nothing -- here's your nine pence.
            DEAD PERSON: I'm not dead!
            MORTICIAN: Here -- he says he's not dead!
            CUSTOMER: Yes, he is.
            DEAD PERSON: I'm not!
            The Quest for the Holy Grail (Monty Python)

            /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
            ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
            \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
          • Muraoka Taro
            I had tested it on only MS-Windows version, and it crash. Now I tested it on OSX and Linux, these did not. Hmm... that s strange. ... Muraoka Taro
            Message 5 of 5 , Jan 3, 2002
            • 0 Attachment
              I had tested it on only MS-Windows version, and it crash.
              Now I tested it on OSX and Linux, these did not.
              Hmm... that's strange.
              ----
              Muraoka Taro <koron@...>


              > Tried it, but it doesn't crash for me...
            Your message has been successfully submitted and would be delivered to recipients shortly.