Loading ...
Sorry, an error occurred while loading the content.
 

Help a couple of weird issues using vim-6.0.93

Expand Messages
  • Jordan Breeding
    I am having two issues (one very strange) which are keeping me from using vim-6.0 instead of vim-5.8. The current version I am experiencing problems with is a
    Message 1 of 2 , Dec 4, 2001
      I am having two issues (one very strange) which are keeping me from
      using vim-6.0 instead of vim-5.8.

      The current version I am experiencing problems with is a copy of
      vim-6.0-8.src.rpm (from RedHat rawhide) which I compiled myself, which
      is actually vim-6.0.93.

      The first problem is this: If I start vim with a long command line such
      as this:

      ./vim /tmp/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaabbbbbbbbbbbbbbbbbbbbbbbbb

      and then exit with :wq! I get this:

      310 root@ledzep /usr/src/redhat/BUILD/vim60/src > bbbbbbbbbbbbbbbbb" 0L,
      0C written

      The old version of vim I used to use vim-5.8 would only display the
      "....." XXL,YYC written message if doing a :w or :w! but either wouldn't
      show the message or would clear the screen AFTER the message when doing
      a :wq!. I would like to help in whatever way possible to get rid of
      this bug as it is quite annoying and keeping me from upgrading to
      vim-6.0.93.

      The second problem I have is that I compile vim with very few options
      but do use commandline, statusline, ruler so that I can use the ruler
      while editing documents. Here is an example of what vim-5.8's ruler
      looked like (at least the RedHat version):

      "vim.h" 1637L, 52546C 1,1
      Top

      and here is what vim-6.0.93's ruler looks like (again at least the
      RedHat version):

      "vim.h" 1637L, 52546C

      Does anyone know of a way to fix this in the source or even know of a
      rulerformat= statement that would give me back the vim-5.8 style ruler?

      Thanks to anyone who can help me try and fix these issues.

      Jordan Breeding
    • John Kearney
      Message 2 of 2 , Dec 5, 2001
        * Jordan Breeding <ledzep37@...> [011205 06:11]:
        > I am having two issues (one very strange) which are keeping me from
        > using vim-6.0 instead of vim-5.8.
        >
        > The current version I am experiencing problems with is a copy of
        > vim-6.0-8.src.rpm (from RedHat rawhide) which I compiled myself, which
        > is actually vim-6.0.93.
        >
        > The first problem is this: If I start vim with a long command line such
        > as this:
        >
        > ./vim /tmp/aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaabbbbbbbbbbbbbbbbbbbbbbbbb
        >
        > and then exit with :wq! I get this:
        >
        > 310 root@ledzep /usr/src/redhat/BUILD/vim60/src > bbbbbbbbbbbbbbbbb" 0L,
        > 0C written
        >
        > The old version of vim I used to use vim-5.8 would only display the
        > "....." XXL,YYC written message if doing a :w or :w! but either wouldn't
        > show the message or would clear the screen AFTER the message when doing
        > a :wq!. I would like to help in whatever way possible to get rid of
        > this bug as it is quite annoying and keeping me from upgrading to
        > vim-6.0.93.
        >
        > The second problem I have is that I compile vim with very few options
        > but do use commandline, statusline, ruler so that I can use the ruler
        > while editing documents. Here is an example of what vim-5.8's ruler
        > looked like (at least the RedHat version):
        >
        > "vim.h" 1637L, 52546C 1,1
        > Top
        >
        > and here is what vim-6.0.93's ruler looks like (again at least the
        > RedHat version):
        >
        > "vim.h" 1637L, 52546C
        >
        > Does anyone know of a way to fix this in the source or even know of a
        > rulerformat= statement that would give me back the vim-5.8 style ruler?

        :h statusline

        >
        > Thanks to anyone who can help me try and fix these issues.
        >
        > Jordan Breeding
        >
      Your message has been successfully submitted and would be delivered to recipients shortly.