Loading ...
Sorry, an error occurred while loading the content.

patch 6.0.46 breaks --disable-gui --without-x

Expand Messages
  • David Lebel
    Starting with patch 6.0.046, vim fails to compile when --disable-gui --without-x are specified at the configure stage. making objects CC= /usr/bin/gcc -Iproto
    Message 1 of 6 , Nov 1, 2001
    • 0 Attachment
      Starting with patch 6.0.046, vim fails to compile when --disable-gui
      --without-x are specified at the configure stage.


      making objects
      CC="/usr/bin/gcc -Iproto -DHAVE_CONFIG_H -I/usr/local/include -O2 -O2 -march=i686 " srcdir=. sh ./osdef.sh
      /usr/bin/gcc -c -I. -Iproto -DHAVE_CONFIG_H -I/usr/local/include -O2 -O2 -march=i686 -o objects/buffer.o buffer.c
      In file included from vim.h:1321,
      from buffer.c:29:
      structs.h:76: X11/Intrinsic.h: No such file or directory
      *** Error code 1

      Ciao,
      ...David

      --
      // david lebel <lebel@{lebel.org,nobiaze.com,openbsd.org}> //
      // http://www.lebel.org/ http://www.nobiaze.com/ //
      // pgp: 3633 6999 D47E 73ED 099F 4341 08A4 8E48 EF56 61D1 //
    • HALIM,SALMAN (HP-NewJersey,ex2)
      for what it s worth, windows (2000), not having the configure stuff to worry about, compiles just fine all the way through. salman. ... From: David Lebel
      Message 2 of 6 , Nov 1, 2001
      • 0 Attachment
        for what it's worth, windows (2000), not having the configure stuff to worry
        about, compiles just fine all the way through.

        salman.

        -----Original Message-----
        From: David Lebel [mailto:lebel@...]
        Sent: Thursday, November 01, 2001 12:28 PM
        To: vim-dev@...
        Subject: patch 6.0.46 breaks --disable-gui --without-x


        Starting with patch 6.0.046, vim fails to compile when --disable-gui
        --without-x are specified at the configure stage.


        making objects
        CC="/usr/bin/gcc -Iproto -DHAVE_CONFIG_H -I/usr/local/include -O2 -O2
        -march=i686 " srcdir=. sh ./osdef.sh
        /usr/bin/gcc -c -I. -Iproto -DHAVE_CONFIG_H -I/usr/local/include -O2 -O2
        -march=i686 -o objects/buffer.o buffer.c
        In file included from vim.h:1321,
        from buffer.c:29:
        structs.h:76: X11/Intrinsic.h: No such file or directory
        *** Error code 1

        Ciao,
        ...David

        --
        // david lebel <lebel@{lebel.org,nobiaze.com,openbsd.org}> //
        // http://www.lebel.org/ http://www.nobiaze.com/ //
        // pgp: 3633 6999 D47E 73ED 099F 4341 08A4 8E48 EF56 61D1 //
      • Bram Moolenaar
        ... Try adding patch 6.0.052. The you may need to do make reconfig , so that the configure cache is cleared. -- ... /// Bram Moolenaar -- Bram@moolenaar.net
        Message 3 of 6 , Nov 1, 2001
        • 0 Attachment
          David Lebel wrote:

          > Starting with patch 6.0.046, vim fails to compile when --disable-gui
          > --without-x are specified at the configure stage.

          Try adding patch 6.0.052. The you may need to do "make reconfig", so
          that the configure cache is cleared.

          --
          Why i like vim:
          > I like VIM because, when I ask a question in this newsgroup, I get a
          > one-line answer. With xemacs, I get a 1Kb lisp script with bugs in it ;-)

          /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
          ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
          \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
        • Ali Akcaagac
          ... works fine for me (TM) also with all patches after this. -- Name....: Ali Akcaagac Status..: Student Of Computer & Economic Science E-Mail..:
          Message 4 of 6 , Nov 1, 2001
          • 0 Attachment
            On 2001.11.01 19:44:49 +0100 "HALIM,SALMAN (HP-NewJersey,ex2)" wrote:
            > Starting with patch 6.0.046, vim fails to compile when --disable-gui
            > --without-x are specified at the configure stage.

            works fine for me (TM) also with all patches after this.

            --
            Name....: Ali Akcaagac
            Status..: Student Of Computer & Economic Science
            E-Mail..: mailto:ali.akcaagac@...-wilhelmshaven.de
            WWW.....: http://www.fh-wilhelmshaven.de/~akcaagaa
          • David Lebel
            ... There is no cache because the build happens in a virgin directory. I notice though that when the build begins, a configure is redone: === Building for
            Message 5 of 6 , Nov 1, 2001
            • 0 Attachment
              Quoting Bram Moolenaar (Bram@...):
              > > Starting with patch 6.0.046, vim fails to compile when --disable-gui
              > > --without-x are specified at the configure stage.
              >
              > Try adding patch 6.0.052. The you may need to do "make reconfig", so
              > that the configure cache is cleared.

              There is no cache because the build happens in a virgin directory. I
              notice though that when the build begins, a configure is redone:

              ===> Building for vim-6.0.45-no_x11
              if test ! -f configure.save; then mv configure configure.save; fi
              autoconf
              sed -e 's+\./config.log+auto/config.log+' configure > auto/configure
              chmod 755 auto/configure
              mv -f configure.save configure
              rm -f auto/config.status auto/config.cache
              GUI_INC_LOC="" GUI_LIB_LOC="" CC="/usr/bin/gcc"
              CPPFLAGS="-I/usr/local/include" CFLAGS="-O2 -O2 -march=i686"
              LDFLAGS="-L/usr/local/lib" srcdir="." ./configure

              but then, the configure doesn't seem to pass the parameters that was
              given the first time around.

              Ciao,
              ...David

              --
              // david lebel <lebel@{lebel.org,nobiaze.com,openbsd.org}> //
              // http://www.lebel.org/ http://www.nobiaze.com/ //
              // pgp: 3633 6999 D47E 73ED 099F 4341 08A4 8E48 EF56 61D1 //
            • Bram Moolenaar
              ... When autoconf is used to produce a new auto/configure, the Makefile deletes the cache, since it s probably outdated now. Then configure is run again, but
              Message 6 of 6 , Nov 1, 2001
              • 0 Attachment
                David Lebel wrote:

                > Quoting Bram Moolenaar (Bram@...):
                > > > Starting with patch 6.0.046, vim fails to compile when --disable-gui
                > > > --without-x are specified at the configure stage.
                > >
                > > Try adding patch 6.0.052. The you may need to do "make reconfig", so
                > > that the configure cache is cleared.
                >
                > There is no cache because the build happens in a virgin directory. I
                > notice though that when the build begins, a configure is redone:
                >
                > ===> Building for vim-6.0.45-no_x11
                > if test ! -f configure.save; then mv configure configure.save; fi
                > autoconf
                > sed -e 's+\./config.log+auto/config.log+' configure > auto/configure
                > chmod 755 auto/configure
                > mv -f configure.save configure
                > rm -f auto/config.status auto/config.cache
                > GUI_INC_LOC="" GUI_LIB_LOC="" CC="/usr/bin/gcc"
                > CPPFLAGS="-I/usr/local/include" CFLAGS="-O2 -O2 -march=i686"
                > LDFLAGS="-L/usr/local/lib" srcdir="." ./configure
                >
                > but then, the configure doesn't seem to pass the parameters that was
                > given the first time around.

                When autoconf is used to produce a new auto/configure, the Makefile
                deletes the cache, since it's probably outdated now.

                Then configure is run again, but only using the arguments that are
                specified in the Makefile. That works fine for me. If you want to give
                other arguments you need to abort this and run configure separately.

                --
                ARTHUR: Be quiet! I order you to shut up.
                OLD WOMAN: Order, eh -- who does he think he is?
                ARTHUR: I am your king!
                OLD WOMAN: Well, I didn't vote for you.
                "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

                /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
                ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
                \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
              Your message has been successfully submitted and would be delivered to recipients shortly.