Loading ...
Sorry, an error occurred while loading the content.

Re: problem with patch 6.0.046

Expand Messages
  • Bram Moolenaar
    ... Did you have a problem including the patch or did you have problems compiling Vim after including the patch? If it s the last, then include patch 6.0.052.
    Message 1 of 8 , Nov 1, 2001
    • 0 Attachment
      Benji Fisher wrote:

      > Vim-Dev guys and gals:
      >
      > I tried to apply a bunch of patches yesterday, and one of the patches
      > failed. I think it was 6.0.046. The problem was with the "configure"
      > file, I think. Has anyone else had trouble?

      Did you have a problem including the patch or did you have problems
      compiling Vim after including the patch? If it's the last, then include
      patch 6.0.052.

      --
      Clothes make the man. Naked people have little or no influence on society.
      -- Mark Twain (Samuel Clemens) (1835-1910)

      /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
      ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
      \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
    • Bram Moolenaar
      ... Strange, there is nothing really special about this patch. But I can guess one potential problem: It patches the file src/auto/configure , while a
      Message 2 of 8 , Nov 1, 2001
      • 0 Attachment
        Benji Fisher wrote:

        > > > Vim-Dev guys and gals:
        > > >
        > > > I tried to apply a bunch of patches yesterday, and one of the patches
        > > > failed. I think it was 6.0.046. The problem was with the "configure"
        > > > file, I think. Has anyone else had trouble?
        > >
        > > Did you have a problem including the patch or did you have problems
        > > compiling Vim after including the patch? If it's the last, then include
        > > patch 6.0.052.
        >
        > The problem was in applying the patch, not compiling. I even tried a
        > clean rm -r vim60, unpack the .tar.gz files, and apply all the patches in
        > sequence. This was on Mac OS X, but I was just working in a shell, so
        > I doubt that this matters. The patch program is the GNU version.

        Strange, there is nothing really special about this patch. But I can
        guess one potential problem: It patches the file "src/auto/configure",
        while a "configure" file also appears in the "src" and the top
        directory. Perhaps it attempted to change the wrong file? Try using
        "patch -p".

        --
        FIRST SOLDIER: So they wouldn't be able to bring a coconut back anyway.
        SECOND SOLDIER: Wait a minute! Suppose two swallows carried it together?
        FIRST SOLDIER: No, they'd have to have it on a line.
        "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

        /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
        ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
        \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
      • Benji Fisher
        ... OK, I have looked into the problem. First, I made a mistake when I identified the problem patch: it was 6.0.003, the other patch that affects the
        Message 3 of 8 , Nov 1, 2001
        • 0 Attachment
          On Thursday, November 1, 2001, at 09:36 AM, Bram Moolenaar wrote:

          >
          > Benji Fisher wrote:
          >>>> [snip]

          > Strange, there is nothing really special about this patch. But I can
          > guess one potential problem: It patches the file "src/auto/configure",
          > while a "configure" file also appears in the "src" and the top
          > directory. Perhaps it attempted to change the wrong file? Try using
          > "patch -p".

          OK, I have looked into the problem. First, I made a mistake when I
          identified the problem patch: it was 6.0.003, the other patch that
          affects the configure files. Second, the problem does seem to be with
          patching the wrong file. I split the patch into three pieces, applied
          the separately, and got it to work by specifying the file to be patched.

          First possibility: I am using the -p option incorrectly. (I am
          new to patch, after all.) The patch starts off

          *** ../vim60.1/src/auto/configure Mon Sep 10 11:39:17 2001
          --- src/auto/configure Thu Sep 27 22:20:19 2001

          so I go to my vim60/ directory and do

          % patch -p2 << ../patches/6.0.003

          If I read man patch correctly, that should work. Am I confused?

          Second possibility: there is something wrong with my patch program.

          % patch --version
          patch 2.5.4
          [...]

          Is this an old version?

          Thanks for the help.

          --Benji Fisher
        • Dan Sharp
          ... You want to use -p0 instead of -p2 . The patch is trying to patch, relative to the current directory (vim60 in your case), src/auto/configure. The -p2
          Message 4 of 8 , Nov 1, 2001
          • 0 Attachment
            >From: Benji Fisher <fisherbb@...>
            >
            >*** ../vim60.1/src/auto/configure Mon Sep 10 11:39:17 2001
            >--- src/auto/configure Thu Sep 27 22:20:19 2001
            >
            >so I go to my vim60/ directory and do
            >
            >% patch -p2 << ../patches/6.0.003

            You want to use -p0 instead of -p2 . The patch is trying to patch, relative
            to the current directory (vim60 in your case), src/auto/configure. The -p2
            means "strip off the first two directories of the file to patch" so the
            src/auto is being removed and it is trying to patch configure in the current
            directory. -p0 means "don't remove any directories" and will correctly
            patch src/auto/configure.

            Dan Sharp

            _________________________________________________________________
            Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp
          • Benji Fisher
            ... Thanks, it works now. My mistake was thinking that -p2 applied to the *** line and not the --- line. --Benji Fisher
            Message 5 of 8 , Nov 1, 2001
            • 0 Attachment
              On Thursday, November 1, 2001, at 11:04 AM, Dan Sharp wrote:

              >> From: Benji Fisher <fisherbb@...>
              >>
              >> *** ../vim60.1/src/auto/configure Mon Sep 10 11:39:17 2001
              >> --- src/auto/configure Thu Sep 27 22:20:19 2001
              >>
              >> so I go to my vim60/ directory and do
              >>
              >> % patch -p2 << ../patches/6.0.003
              >
              > You want to use -p0 instead of -p2 . The patch is trying to patch,
              > relative to the current directory (vim60 in your case),
              > src/auto/configure. The -p2 means "strip off the first two directories
              > of the file to patch" so the src/auto is being removed and it is trying
              > to patch configure in the current directory. -p0 means "don't remove
              > any directories" and will correctly patch src/auto/configure.

              Thanks, it works now. My mistake was thinking that -p2 applied to
              the *** line and not the --- line.

              --Benji Fisher
            • Benji Fisher
              ... The problem was in applying the patch, not compiling. I even tried a clean rm -r vim60, unpack the .tar.gz files, and apply all the patches in sequence.
              Message 6 of 8 , Nov 1, 2001
              • 0 Attachment
                Bram Moolenaar wrote:
                >
                > Benji Fisher wrote:
                >
                > > Vim-Dev guys and gals:
                > >
                > > I tried to apply a bunch of patches yesterday, and one of the patches
                > > failed. I think it was 6.0.046. The problem was with the "configure"
                > > file, I think. Has anyone else had trouble?
                >
                > Did you have a problem including the patch or did you have problems
                > compiling Vim after including the patch? If it's the last, then include
                > patch 6.0.052.

                The problem was in applying the patch, not compiling. I even tried a
                clean rm -r vim60, unpack the .tar.gz files, and apply all the patches in
                sequence. This was on Mac OS X, but I was just working in a shell, so I doubt
                that this matters. The patch program is the GNU version.

                --Benji Fisher
              Your message has been successfully submitted and would be delivered to recipients shortly.