Loading ...
Sorry, an error occurred while loading the content.

!xxd problems.

Expand Messages
  • Robert Webb
    When I do :1,$!xxd in 6.0 on w2k, rather than filtering the whole file through xxd, the following happens: - A DOS window appears, but minimized only, so
    Message 1 of 6 , Oct 2, 2001
    • 0 Attachment
      When I do ":1,$!xxd" in 6.0 on w2k, rather than filtering the whole file
      through xxd, the following happens:

      - A DOS window appears, but minimized only, so that I hardly notice it.
      - I click on the DOS icon in the tackbar to see what's in the window.
      - Window says:

      -s E:\WINNT\system32\cmd.exe /c xxd <E:\Temp\VIi84.tmp >E:\Temp\VIo85.tmp
      2>&1
      1 returned
      Hit any key to close this window...

      Note that the first line starts with "-s" for some reason.

      - I hit return to dismiss the DOS window.
      - The vim window no longer has focus so I have to click in it first.
      - Vim says:

      shell returned 1
      91 lines filtered
      Hit ENTER of type command to continue

      - I hit return and my buffer contains:

      '-s' is not recognized as an internal or external command,
      operable program or batch file.

      Anyone know what's wrong?
      Thanks,
      Rob.

      --

      Robert Webb <RobertW@...>,
      Want to make polyhedra?
      See <http://stella.isinteresting.com>
      or <http://home.connexus.net.au/~robandfi/Stella.html>
    • Vince Negri
      ... For some reason vimrun_path is empty. Is vimrun.exe where vim can find it? The -s is coming from this line: sprintf((char *)newcmd, %s%s%s %s %s ,
      Message 2 of 6 , Oct 3, 2001
      • 0 Attachment
        > Note that the first line starts with "-s" for some reason.

        For some reason vimrun_path is empty. Is vimrun.exe
        where vim can find it?

        The -s is coming from this line:

        sprintf((char *)newcmd, "%s%s%s %s %s",
        vimrun_path,
        (msg_silent != 0 || (options & SHELL_DOOUT))
        ? "-s " : "",
        p_sh, p_shcf, cmd);



        --
        Vince Negri (vnegri@...)
        Application Solutions Ltd. Tel:+44(0)1273-476608 Fax:+44(0)1273-478888

        Legal Disclaimer: Any views expressed by the sender of this message are
        not necessarily those of Application Solutions Ltd. Information in this
        e-mail may be confidential and is for the use of the intended recipient
        only, no mistake in transmission is intended to waive or compromise such
        privilege. Please advise the sender if you receive this e-mail by mistake.
      • Robert Webb
        ... Something must have changed. I just did a test with vim6.0aw and it worked exactly as expected, but vim6.0 still does as I described before. I m assuming
        Message 3 of 6 , Oct 3, 2001
        • 0 Attachment
          Vince Negri wrote:

          > > Note that the first line starts with "-s" for some reason.
          >
          > For some reason vimrun_path is empty. Is vimrun.exe
          > where vim can find it?
          >
          > The -s is coming from this line:
          >
          > sprintf((char *)newcmd, "%s%s%s %s %s",
          > vimrun_path,
          > (msg_silent != 0 || (options & SHELL_DOOUT))
          > ? "-s " : "",
          > p_sh, p_shcf, cmd);

          Something must have changed. I just did a test with vim6.0aw and it worked
          exactly as expected, but vim6.0 still does as I described before. I'm
          assuming vimrun.exe itself hasn't changed, should I be updating that too?

          Rob.

          --

          Robert Webb <RobertW@...>,
          Want to make polyhedra?
          See <http://stella.isinteresting.com>
          or <http://home.connexus.net.au/~robandfi/Stella.html>
        • Vince Negri
          ... worked ... Something did change. 6.0aw did not use vimrun when running external filters. 6.0 does, to get round various Win98 issues regarding PATH and
          Message 4 of 6 , Oct 3, 2001
          • 0 Attachment
            > Something must have changed. I just did a test with vim6.0aw and it
            worked
            > exactly as expected, but vim6.0 still does as I described before. I'm
            > assuming vimrun.exe itself hasn't changed, should I be updating that too?

            Something did change. 6.0aw did not use vimrun when running
            external filters. 6.0 does, to get round various Win98 issues
            regarding PATH and environment variables. The warning about not
            being able to find vimrun has been removed in 6.0, too - I'm
            not sure when in the beta cycle that change occurred.

            --
            Vince Negri (vnegri@...)
            Application Solutions Ltd. Tel:+44(0)1273-476608 Fax:+44(0)1273-478888

            Legal Disclaimer: Any views expressed by the sender of this message are
            not necessarily those of Application Solutions Ltd. Information in this
            e-mail may be confidential and is for the use of the intended recipient
            only, no mistake in transmission is intended to waive or compromise such
            privilege. Please advise the sender if you receive this e-mail by mistake.
          • Bram Moolenaar
            ... There should be vimrun before that (with a path). ... Somehow vimrun_path has become empty, while s_dont_use_vimrun is FALSE. I don t see how this
            Message 5 of 6 , Oct 19, 2001
            • 0 Attachment
              Robert Webb wrote:

              > When I do ":1,$!xxd" in 6.0 on w2k, rather than filtering the whole file
              > through xxd, the following happens:
              >
              > - A DOS window appears, but minimized only, so that I hardly notice it.
              > - I click on the DOS icon in the tackbar to see what's in the window.
              > - Window says:
              >
              > -s E:\WINNT\system32\cmd.exe /c xxd <E:\Temp\VIi84.tmp >E:\Temp\VIo85.tmp
              > 2>&1
              > 1 returned
              > Hit any key to close this window...
              >
              > Note that the first line starts with "-s" for some reason.

              There should be "vimrun" before that (with a path).

              > - I hit return to dismiss the DOS window.
              > - The vim window no longer has focus so I have to click in it first.
              > - Vim says:
              >
              > shell returned 1
              > 91 lines filtered
              > Hit ENTER of type command to continue
              >
              > - I hit return and my buffer contains:
              >
              > '-s' is not recognized as an internal or external command,
              > operable program or batch file.

              Somehow "vimrun_path" has become empty, while "s_dont_use_vimrun" is
              FALSE. I don't see how this can happen. This is done in mch_init() in
              os_win32.c. Could you perhaps try to find out what happens for you?

              There was a change quite late in the 6.0 development to use vimrun also
              for filtering. This fixed problems with passing environment variables
              to the executed command. Perhaps previously external commands didn't
              work for you anyway, and now filter commands also stopped working?

              --
              hundred-and-one symptoms of being an internet addict:
              110. You actually volunteer to become your employer's webmaster.

              /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
              ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
              \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
            • Robert Webb
              ... I have fixed this now by compiling the vimrun that came with vim6.0, whereas I had been using an older version, assuming it hadn t changed. Maybe the old
              Message 6 of 6 , Oct 21, 2001
              • 0 Attachment
                > > When I do ":1,$!xxd" in 6.0 on w2k, rather than filtering the whole file
                > > through xxd, the following happens:
                > >
                > > - A DOS window appears, but minimized only, so that I hardly notice it.
                > > - I click on the DOS icon in the tackbar to see what's in the window.
                > > - Window says:
                > >
                > > -s E:\WINNT\system32\cmd.exe /c xxd <E:\Temp\VIi84.tmp
                > >E:\Temp\VIo85.tmp
                > > 2>&1
                > > 1 returned
                > > Hit any key to close this window...
                > >
                > > Note that the first line starts with "-s" for some reason.
                >
                > There should be "vimrun" before that (with a path).

                I have fixed this now by compiling the vimrun that came with vim6.0, whereas
                I had been using an older version, assuming it hadn't changed. Maybe the
                old version didn't understand the -s flag? Anyway, the old vimrun was
                certainly in my path, and replacing that with the new one solved the
                problem.

                Rob.

                --

                Robert Webb <RobertW@...>,
                Want to make polyhedra?
                See <http://stella.isinteresting.com>
                or <http://home.connexus.net.au/~robandfi/Stella.html>
              Your message has been successfully submitted and would be delivered to recipients shortly.