Loading ...
Sorry, an error occurred while loading the content.
 

Session scrolls screen

Expand Messages
  • Robert Webb
    With 6.0, when I reload a session using gvim -c so file.vim I now get two messages and a scroll, then I have to hit return. This never used to happen,
    Message 1 of 3 , Oct 1, 2001
      With 6.0, when I reload a session using 'gvim -c "so file.vim"' I now get
      two messages and a scroll, then I have to hit return. This never used to
      happen, always used to open all the windows without the need to hit Return.

      Eg, now I get:

      "registry.cpp" [RO] 384L, 10160C
      "Bugs.txt" 368L, 16887C
      Hit ENTER or type command to continue

      or:

      "famousdoc.cpp" 8463L, 241414C
      "famousdoc.cpp" 8463 lines --14%-- ((1) of 4)
      Hit ENTER or type command to continue

      Seems to happen when you have more than one window open on some files. Both
      of the above cases had several windows open, with only one file open in two
      windows. I tried another case where there were three windows open on one
      file and it gave three file messages (rather than the two in the above
      examples). If each file only appears in one window then you don't have to
      hit return.

      Is there a fix for this?

      Thanks,
      Rob.

      --

      Robert Webb <RobertW@...>,
      Want to make polyhedra?
      See <http://stella.isinteresting.com>
      or <http://home.connexus.net.au/~robandfi/Stella.html>
    • Bram Moolenaar
      ... It doesn t happen for me. Check out your shortmess option value. Hmm, even this doesn t give me the hit-enter prompt: vim -u NONE -S file.vim Where
      Message 2 of 3 , Oct 19, 2001
        Robert Webb wrote:

        > With 6.0, when I reload a session using 'gvim -c "so file.vim"' I now get
        > two messages and a scroll, then I have to hit return. This never used to
        > happen, always used to open all the windows without the need to hit Return.
        >
        > Eg, now I get:
        >
        > "registry.cpp" [RO] 384L, 10160C
        > "Bugs.txt" 368L, 16887C
        > Hit ENTER or type command to continue
        >
        > or:
        >
        > "famousdoc.cpp" 8463L, 241414C
        > "famousdoc.cpp" 8463 lines --14%-- ((1) of 4)
        > Hit ENTER or type command to continue
        >
        > Seems to happen when you have more than one window open on some files. Both
        > of the above cases had several windows open, with only one file open in two
        > windows. I tried another case where there were three windows open on one
        > file and it gave three file messages (rather than the two in the above
        > examples). If each file only appears in one window then you don't have to
        > hit return.
        >
        > Is there a fix for this?

        It doesn't happen for me. Check out your 'shortmess' option value.
        Hmm, even this doesn't give me the hit-enter prompt:

        vim -u NONE -S file.vim

        Where file.vim is a session with two windows, ":messages" shows three
        messages.

        --
        hundred-and-one symptoms of being an internet addict:
        111. You and your friends get together regularly on IRC, even though
        all of you live in the same city.

        /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
        ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
        \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
      • Robert Webb
        ... Actually, I notice my shortmess is always set to the default, even though I set it in my _vimrc. I had this: set shortmess=mrxnfit But the value when I
        Message 3 of 3 , Oct 21, 2001
          Bram replied:

          > Robert Webb wrote:
          >
          > > With 6.0, when I reload a session using 'gvim -c "so file.vim"' I
          > > now get two messages and a scroll, then I have to hit return.
          > > This never used to happen, always used to open all the windows
          > > without the need to hit Return.
          > >
          > > Eg, now I get:
          > >
          > > "registry.cpp" [RO] 384L, 10160C "Bugs.txt" 368L, 16887C Hit
          > > ENTER or type command to continue
          > >
          > > or:
          > >
          > > "famousdoc.cpp" 8463L, 241414C "famousdoc.cpp" 8463 lines --14%--
          > > ((1) of 4) Hit ENTER or type command to continue
          > >
          > > Seems to happen when you have more than one window open on some
          > > files. Both of the above cases had several windows open, with
          > > only one file open in two windows. I tried another case where
          > > there were three windows open on one file and it gave three file
          > > messages (rather than the two in the above examples). If each
          > > file only appears in one window then you don't have to hit return.
          > >
          > > Is there a fix for this?
          >
          > It doesn't happen for me. Check out your 'shortmess' option value.

          Actually, I notice my shortmess is always set to the default, even
          though I set it in my _vimrc. I had this:

          set shortmess=mrxnfit

          But the value when I run vim is the default instead (whether or not I
          start from an old vim session). I also tried using
          "set shortmess+=mr" but that also left the value unchanged from the
          default.

          Anyway, I have tracked down the screen-scrolling to something very
          bizarre! It depends on whether my 'suffixes' setting has ".h" in it!
          No idea why. With an empty _vimrc, the old session opens fine without
          scrolling the screen. But if I put a single line in my _vimrc, saying
          the following for example:

          set suffixes=.bak,~,.o,.info,.swp,.obj

          Then I do get the scroll when reopening the old vim sessions (this is
          just the default with ".h" removed). If I put ".h" back in, then
          there's no scrolling again!

          Let me know if you still can't reproduce this.

          Thanks,
          Rob.

          --

          Robert Webb <RobertW@...>,
          Want to make polyhedra?
          See <http://stella.isinteresting.com>
          or <http://home.connexus.net.au/~robandfi/Stella.html>
        Your message has been successfully submitted and would be delivered to recipients shortly.