Loading ...
Sorry, an error occurred while loading the content.

Re: Seg Fault on :filetype

Expand Messages
  • Jon Miner
    ... OK, with CFLAGS=-g or CFLAGS=O everything works fine. With CFLAGS=O2, everything falls apart.. hmm. I don t have GDB installed on this machine, so I
    Message 1 of 6 , Oct 1, 2001
    • 0 Attachment
      * Jon Miner (miner@...) [011001 11:42]:
      > > > Is there a configure command I can use to turn off optimizing, or should
      > > > I just muck with the CFLAGS?
      > >
      > > You can edit src/Makefile to change CFLAGS. Or set it in the
      > > environment.
      >
      > Will-do, as soon as I get a moment.

      OK, with CFLAGS=-g or CFLAGS=O everything works fine. With CFLAGS=O2,
      everything falls apart.. hmm. I don't have GDB installed on this
      machine, so I can't really test further..

      jon

      --
      .Jonathan J. Miner------------------Division of Information Technology.
      |miner@... University Of Wisconsin - Madison|
      |608/262.9655 Room 3149 Computer Science|
      `---------------------------------------------------------------------'

      If this were Ada, I suppose we'd just constant fold 1/0 into

      die "Illegal division by zero"
      -- Larry Wall in <199711100226.SAA12549@...>
      (232)
    • Bram Moolenaar
      ... I suggest you look in the gcc bug reports for something that could be related to this problem (works OK with -O does not work with -O2 ). This is very
      Message 2 of 6 , Oct 19, 2001
      • 0 Attachment
        Jon Miner wrote:

        > * Jon Miner (miner@...) [011001 11:42]:
        > > > > Is there a configure command I can use to turn off optimizing, or should
        > > > > I just muck with the CFLAGS?
        > > >
        > > > You can edit src/Makefile to change CFLAGS. Or set it in the
        > > > environment.
        > >
        > > Will-do, as soon as I get a moment.
        >
        > OK, with CFLAGS=-g or CFLAGS=O everything works fine. With CFLAGS=O2,
        > everything falls apart.. hmm. I don't have GDB installed on this
        > machine, so I can't really test further..

        I suggest you look in the gcc bug reports for something that could be
        related to this problem (works OK with "-O" does not work with "-O2").
        This is very likely a gcc problem and not a Vim problem. If nothing can
        be found you could try to narrow down the problem and send a bug report
        to the gcc list. That will be a bit of work.

        --
        Contrary to popular belief, Unix is user friendly.
        It just happens to be selective about who it makes friends with.
        -- Dave Parnas

        /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
        ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
        \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
      Your message has been successfully submitted and would be delivered to recipients shortly.