Loading ...
Sorry, an error occurred while loading the content.
 

Build with --enable-perlinterp broken (vim 6.0av, perl 5.004_04)

Expand Messages
  • Richard Curnow
    Maybe something has been changed around the perl interface, and assumes a newer version of perl? I get the errors below when compiling auto/if_perl.c gcc -c
    Message 1 of 4 , Sep 10, 2001
      Maybe something has been changed around the perl interface, and assumes a newer
      version of perl? I get the errors below when compiling auto/if_perl.c

      gcc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_GTK -I/u/curnowr/farm/include/gtk-1.2 -I/u/curnowr/pd/glib/1.2.10-1/include/glib-1.2 -I/u/curnowr/pd/glib/1.2.10-1/lib/glib/include -I/pd/X11R6/include -O2 -mv8 -I/pd/X11R6/include -I/usr/local/include -I/pd/perl/5.004_04/lib/sun4-solaris/5.00404/CORE -o objects/if_perl.o auto/if_perl.c
      if_perl.xs: In function `newWINrv':
      if_perl.xs:456: structure has no member named `perl_private'
      if_perl.xs:456: structure has no member named `perl_private'
      if_perl.xs:456: structure has no member named `perl_private'
      if_perl.xs:456: structure has no member named `perl_private'
      if_perl.xs:456: structure has no member named `perl_private'
      if_perl.xs: In function `newBUFrv':
      if_perl.xs:457: structure has no member named `perl_private'
      if_perl.xs:457: structure has no member named `perl_private'
      if_perl.xs:457: structure has no member named `perl_private'
      if_perl.xs:457: structure has no member named `perl_private'
      if_perl.xs:457: structure has no member named `perl_private'
      if_perl.xs: In function `perl_win_free':
      if_perl.xs:467: structure has no member named `perl_private'
      if_perl.xs:468: structure has no member named `perl_private'
      if_perl.xs: In function `perl_buf_free':
      if_perl.xs:476: structure has no member named `perl_private'
      if_perl.xs:477: structure has no member named `perl_private'
      if_perl.xs: In function `XS_VIWIN_DESTROY':
      if_perl.xs:890: structure has no member named `perl_private'
      if_perl.xs: In function `XS_VIBUF_DESTROY':
      if_perl.xs:954: structure has no member named `perl_private'
      *** Error code 1
      make: Fatal error: Command failed for target `objects/if_perl.o'
      Current working directory /home/afra/users/curnowr/build/vim60av/src
      *** Error code 1
      make: Fatal error: Command failed for target `first'

      I configure via this (zsh) shell function:

      configure_vim () {
      local here=$(basename $(pwd))
      local where=$(echo $here | sed 's/^.*\(.\)$/6.0a\1-1/;')
      echo $where
      CC=gcc CFLAGS="-O2 -mv8" ./configure --with-compiledby="Richard Curnow <curnowr@...>" --enable-gui=gtk --with-gtk-prefix=/u/curnowr/farm --x-includes=/pd/X11R6/include --x-libraries=/pd/X11R6/lib --prefix=/u/curnowr/OSS/$SYSTEM/vim/$where --with-features=big --enable-perlinterp
      }

      Version 6.0au compiled & worked fine (modulo the bugs fixed in 6.0av of course
      :-)), with exactly the same configuration process.


      --
      Richard Curnow---by day : SuperH Core Architecture at STMicroelectronics
      curnowr@...---------www.superh.com-------------www.st.com----
      and by night >>---richard.curnow@...---http://go.to/richard.curnow/---
    • Bram Moolenaar
      ... [...] ... The if_perl.xs file didn t change. I can t guess what change would break it for you. Please try to find out what is different. ... Recieved ?
      Message 2 of 4 , Sep 10, 2001
        Richard Curnow wrote:

        > Maybe something has been changed around the perl interface, and
        > assumes a newer version of perl? I get the errors below when
        > compiling auto/if_perl.c
        [...]
        > Version 6.0au compiled & worked fine (modulo the bugs fixed in 6.0av of course
        > :-)), with exactly the same configuration process.

        The if_perl.xs file didn't change. I can't guess what change would break
        it for you. Please try to find out what is different.

        Looking at your mail header:
        > Recieved: from Richard.Curnow@... by popov with local (Exim 3.03 #5)
        > id 15gP8S-0004FK-00; Mon, 10 Sep 2001 12:21:52 +0100

        "Recieved"? Better run a spell checker on your mail program! :-)

        --
        hundred-and-one symptoms of being an internet addict:
        40. You tell the cab driver you live at
        http://123.elm.street/house/bluetrim.html
        41. You actually try that 123.elm.street address.

        /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
        ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
        \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
      • Richard Curnow
        OK. I think the problem might in fact relate to the file timestamps that result from applying the 6.0au- 6.0av patch to the 6.0au tarball. The first time I
        Message 3 of 4 , Sep 10, 2001
          OK. I think the problem might in fact relate to the file timestamps that
          result from applying the 6.0au->6.0av patch to the 6.0au tarball. The first
          time I did

          configure (options as per my last mail)
          make

          and I noticed that there seemed to be a 2nd configure done (i.e. all the usual
          autoconf lines went scrolling by after I'd typed make). So for some reason,
          make felt it needed to do configure again. Then, the --enable-perlinterp
          wouldn't have been specified to that 2nd configure, which would result in
          generated header files being out of step with which sources were compiled &
          linked? Could something like that be possible?

          After your mail, I did "make distclean" and started over. The console messages
          from this build looked (superficially) the same as I've seen on previous
          builds. 6.0av is now installed and working fine. :version shows +perl.

          The only other factor is that I used solaris /usr/ccs/bin/make the 1st time,
          but remembered to use GNU make the 2nd time. I doubt this is relevant, though.

          So, problem solved.
          Thanks
          Richard

          On Mon, Sep 10, 2001 at 04:16:07PM +0200, bram@... wrote:
          >
          > Richard Curnow wrote:
          >
          > > Maybe something has been changed around the perl interface, and
          > > assumes a newer version of perl? I get the errors below when
          > > compiling auto/if_perl.c
          > [...]
          > > Version 6.0au compiled & worked fine (modulo the bugs fixed in 6.0av of course
          > >:-)), with exactly the same configuration process.
          >
          > The if_perl.xs file didn't change. I can't guess what change would break
          > it for you. Please try to find out what is different.
          >
          > Looking at your mail header:
          > > Recieved: from Richard.Curnow@... by popov with local (Exim 3.03 #5)
          > > id 15gP8S-0004FK-00; Mon, 10 Sep 2001 12:21:52 +0100
          >
          > "Recieved"? Better run a spell checker on your mail program! :-)
          >

          I'm afraid the blame for that rests with the site's IT department. Out of my
          control I'm afraid! I guess I _could_ tell them.

          --
          Richard Curnow---by day : SuperH Core Architecture at STMicroelectronics
          curnowr@...---------www.superh.com-------------www.st.com----
          and by night >>---richard.curnow@...---http://go.to/richard.curnow/---
        • Bram Moolenaar
          ... This might be caused by a change to configure.in. make will then update the configure script and run it again. Actually, when this happens it should
          Message 4 of 4 , Sep 10, 2001
            Richard Curnow wrote:

            > OK. I think the problem might in fact relate to the file timestamps that
            > result from applying the 6.0au->6.0av patch to the 6.0au tarball. The first
            > time I did
            >
            > configure (options as per my last mail)
            > make
            >
            > and I noticed that there seemed to be a 2nd configure done (i.e. all
            > the usual autoconf lines went scrolling by after I'd typed make). So
            > for some reason, make felt it needed to do configure again.
            > Then, the --enable-perlinterp
            > wouldn't have been specified to that 2nd configure, which would result in
            > generated header files being out of step with which sources were compiled &
            > linked? Could something like that be possible?

            This might be caused by a change to configure.in. "make" will then
            update the configure script and run it again. Actually, when this
            happens it should delete the configure cache, since it causes problems.
            I'll make a patch for this.

            > The only other factor is that I used solaris /usr/ccs/bin/make the 1st
            > time, but remembered to use GNU make the 2nd time. I doubt this is
            > relevant, though.

            I don't think the version of make really matters, the Vim Makefile is
            very portable.


            *** ../../vim-6.0av/src/Makefile Sun Sep 9 23:48:53 2001
            --- Makefile Mon Sep 10 19:01:42 2001
            ***************
            *** 1352,1357 ****
            --- 1352,1358 ----
            sed -e 's+\./config.log+auto/config.log+' configure > auto/configure
            chmod 755 auto/configure
            mv -f configure.save configure
            + -rm -f auto/config.status auto/config.cache

            # Re-execute this Makefile to include the new auto/config.mk produced by
            # configure Only used when typing "make" with a fresh auto/config.mk.

            --
            hundred-and-one symptoms of being an internet addict:
            51. You put a pillow case over your laptop so your lover doesn't see it while
            you are pretending to catch your breath.

            /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
            ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
            \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
          Your message has been successfully submitted and would be delivered to recipients shortly.