Loading ...
Sorry, an error occurred while loading the content.
 

:silent exec and screen refresh

Expand Messages
  • Tomas Zellerin
    Hello, Is it a bug that the screen is not refreshed after ... ? is needed after it. (terminal version, vim 6.0au, on xterm console) The problem does not
    Message 1 of 7 , Sep 7, 2001
      Hello,
      Is it a bug that the screen is not refreshed after
      :silent exec "!echo a"
      ? <C-L> is needed after it.
      (terminal version, vim 6.0au, on xterm console)
      The problem does not appear in gui gtk version.

      Regards

      Tomas Zellerin
    • Bram Moolenaar
      Tomas - ... No, this is not a bug. When you use an external command with :silent Vim expects the command to be silent. If it isn t, you should take care of
      Message 2 of 7 , Sep 7, 2001
        Tomas -

        > Is it a bug that the screen is not refreshed after
        > :silent exec "!echo a"
        > ? <C-L> is needed after it.
        > (terminal version, vim 6.0au, on xterm console)
        > The problem does not appear in gui gtk version.

        No, this is not a bug. When you use an external command with ":silent"
        Vim expects the command to be silent. If it isn't, you should take care
        of the redraw yourself.

        - Bram

        --
        login: yes
        password: I don't know, please tell me
        password is incorrect
        login: yes
        password: incorrect

        /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
        ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
        \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
      • Tomas Zellerin
        ... Hello, No, this should not be the issue. Okay, I have probably stripped the example to too simple. My real problem is with (quite silent, I would say) ...
        Message 3 of 7 , Sep 7, 2001
          On Fri, Sep 07, 2001 at 03:37:42PM +0200, Bram Moolenaar wrote:
          >
          > Tomas -
          >
          > > Is it a bug that the screen is not refreshed after
          > > :silent exec "!echo a"
          > > ? <C-L> is needed after it.
          > > (terminal version, vim 6.0au, on xterm console)
          > > The problem does not appear in gui gtk version.
          >
          > No, this is not a bug. When you use an external command with ":silent"
          > Vim expects the command to be silent. If it isn't, you should take care
          > of the redraw yourself.
          >
          Hello,
          No, this should not be the issue. Okay, I have probably stripped the
          example to too simple. My real problem is with (quite silent, I would say)
          :silent exec "!echo text >> /tmp/fifo"
          but even any "silent" shell command (false, true, ...) will clear the screen
          completely, e.g.
          :silent exec "!false"

          Regards

          Tomas Zellerin
        • Helmut 'Kolbi' Kolb
          Hi Bram! ... I have the same problem -- with the latest two versions of vim. Before (the latest version was 6.0x), when i did a :silent! make -k , i didn t
          Message 4 of 7 , Sep 7, 2001
            Hi Bram!

            On Fri, 07 Sep 2001, Bram Moolenaar wrote:
            > > Is it a bug that the screen is not refreshed after
            > > :silent exec "!echo a"
            > > ? <C-L> is needed after it.
            > > (terminal version, vim 6.0au, on xterm console)
            > > The problem does not appear in gui gtk version.
            > No, this is not a bug. When you use an external command with ":silent"
            > Vim expects the command to be silent. If it isn't, you should take care
            > of the redraw yourself.

            I have the same problem -- with the latest two versions of vim.

            Before (the latest version was 6.0x), when i did a ":silent! make -k", i
            didn't get any output -- was this a bug?

            But Bram, you are right. The messages i get are "echo"s from inside the
            Makefile...

            Yours
            --
            Don't blame me, I voted Republican.
            you ask why? here it's now Friday, September 07, 2001 15:42!
            ------------------------------------------------------------------------
            Helmut 'Kolbi' Kolb - = < > = - http://www.0x13.org
          • Bram Moolenaar
            ... Both the examples you give work fine for me. I can t guess why it would have side effects for you. -- hundred-and-one symptoms of being an internet
            Message 5 of 7 , Sep 7, 2001
              Tomas Zellerin wrote:

              > > > Is it a bug that the screen is not refreshed after
              > > > :silent exec "!echo a"
              > > > ? <C-L> is needed after it.
              > > > (terminal version, vim 6.0au, on xterm console)
              > > > The problem does not appear in gui gtk version.
              > >
              > > No, this is not a bug. When you use an external command with ":silent"
              > > Vim expects the command to be silent. If it isn't, you should take care
              > > of the redraw yourself.
              > >
              > Hello,
              > No, this should not be the issue. Okay, I have probably stripped the
              > example to too simple. My real problem is with (quite silent, I would say)
              > :silent exec "!echo text >> /tmp/fifo"
              > but even any "silent" shell command (false, true, ...) will clear the
              > screen completely, e.g.
              > :silent exec "!false"

              Both the examples you give work fine for me. I can't guess why it would
              have side effects for you.

              --
              hundred-and-one symptoms of being an internet addict:
              17. You turn on your intercom when leaving the room so you can hear if new
              e-mail arrives.

              /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
              ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
              \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
            • David Mankin
              ... My guess is that you have a clear command in some shell command file, Tomas. Look in your .login, .logout, .bashrc, .bash_profile, .profile, .cshrc, and
              Message 6 of 7 , Sep 7, 2001
                > Tomas Zellerin wrote:
                >
                > > > > Is it a bug that the screen is not refreshed after
                > > > > :silent exec "!echo a"
                > > > > ? <C-L> is needed after it.
                > > > > (terminal version, vim 6.0au, on xterm console)
                > > > > The problem does not appear in gui gtk version.
                > > >
                > > > No, this is not a bug. When you use an external command with ":silent"
                > > > Vim expects the command to be silent. If it isn't, you should take care
                > > > of the redraw yourself.
                > > >
                > > Hello,
                > > No, this should not be the issue. Okay, I have probably stripped the
                > > example to too simple. My real problem is with (quite silent, I would say)
                > > :silent exec "!echo text >> /tmp/fifo"
                > > but even any "silent" shell command (false, true, ...) will clear the
                > > screen completely, e.g.
                > > :silent exec "!false"
                >
                > Both the examples you give work fine for me. I can't guess why it would
                > have side effects for you.


                My guess is that you have a "clear" command in some shell command file,
                Tomas. Look in your .login, .logout, .bashrc, .bash_profile, .profile,
                .cshrc, and .tcshrc files for something that will clear the screen. Since
                !echo probably runs a shell, any of those shell control files could be
                clearing the screen before or after the command.

                Hope that helps,
                -David Mankin
              • Tomas Zellerin
                ... Hmm, just for record, it does not help. The only clear I have is in my bash_logout, and it is called only after login shell. And its deletion does not
                Message 7 of 7 , Sep 10, 2001
                  On Fri, Sep 07, 2001 at 04:29:49PM -0700, David Mankin wrote:
                  > > Tomas Zellerin wrote:
                  > >
                  > > > > > Is it a bug that the screen is not refreshed after
                  > > > > > :silent exec "!echo a"
                  > > > > > ? <C-L> is needed after it.
                  > > > > > (terminal version, vim 6.0au, on xterm console)
                  > > > > > The problem does not appear in gui gtk version.
                  > > > >
                  >
                  > My guess is that you have a "clear" command in some shell command file,
                  > Tomas. Look in your .login, .logout, .bashrc, .bash_profile, .profile,
                  > .cshrc, and .tcshrc files for something that will clear the screen. Since
                  > !echo probably runs a shell, any of those shell control files could be
                  > clearing the screen before or after the command.
                  >

                  Hmm, just for record, it does not help. The only clear I have is in my
                  bash_logout, and it is called only after login shell. And its deletion
                  does not help, too. Okay, maybe I have some problem with
                  xterm/termcap/whatever, if its onle me who can see it, it would be probably me -
                  and I can workaround that particular case better way.

                  Thanks for advices
                  Tomas
                Your message has been successfully submitted and would be delivered to recipients shortly.