Loading ...
Sorry, an error occurred while loading the content.
 

RE: Vim version 6.0au BETA available

Expand Messages
  • Robert Webb
    ... Ha! Let s hope we don t make it to zinc! Rob. -- Robert Webb , Want to make polyhedra? See
    Message 1 of 18 , Sep 2, 2001
      > This is the "golden" BETA for Vim 6.0.

      Ha! Let's hope we don't make it to zinc!

      Rob.

      --

      Robert Webb <RobertW@...>,
      Want to make polyhedra?
      See <http://stella.isinteresting.com>
    • Zdenek Sekera
      ... And the next is -platinum- maybe?? :-) ... This doesn t say much details, but as a data point the color printing from vim (not gvim) still doesn t
      Message 2 of 18 , Sep 3, 2001
        Bram Moolenaar wrote:
        >
        > This is the "golden" BETA for Vim 6.0.
        >

        And the next is -platinum- maybe?? :-)

        ...
        > PostScript printing:
        > - Made "duplex" work. (Mike Williams)

        This doesn't say much details, but as a data point the 'color' printing
        from 'vim' (not gvim) still doesn't work, b&w and lots of underlining
        is produced, maybe Mike is still working on it.

        Also popt should have duplex:off as the default, would be safer.

        ---Zdenek
      • Mike Williams
        ... I think this is no more than try and make it more bullet proof. As per your printer, there are situations that are out of the control of the PS and it
        Message 3 of 18 , Sep 3, 2001
          On 3 Sep 2001, at 12:00, Zdenek Sekera wrote:

          > > PostScript printing:
          > > - Made "duplex" work. (Mike Williams)
          >
          > This doesn't say much details,

          I think this is no more than try and make it more bullet proof. As
          per your printer, there are situations that are out of the control of
          the PS and it just wont work at all. :(

          > but as a data point the 'color' printing
          > from 'vim' (not gvim) still doesn't work, b&w and lots of underlining
          > is produced, maybe Mike is still working on it.

          You are gonna hate this, but 'it works for me'. More detail and I
          would be happy to look into. This may be a function of Windows
          console version not being able to switch to a gui version like Unix
          vim can. The way the code builds may be different which is causing
          the problem. Just a thought.

          TTFN

          Mike
          --
          Did you really expect mere truth to sway my opinion?
        • Bram Moolenaar
          ... Platinum is pt , hopefully we have a release before that! We did pass silver unnoticed... ... It does work for me. The colors are a bit strange though.
          Message 4 of 18 , Sep 3, 2001
            Zdenek Sekera wrote:

            > Bram Moolenaar wrote:
            > >
            > > This is the "golden" BETA for Vim 6.0.
            > >
            >
            > And the next is -platinum- maybe?? :-)

            Platinum is "pt", hopefully we have a release before that!
            We did pass silver unnoticed...

            > ...
            > > PostScript printing:
            > > - Made "duplex" work. (Mike Williams)
            >
            > This doesn't say much details, but as a data point the 'color' printing
            > from 'vim' (not gvim) still doesn't work, b&w and lots of underlining
            > is produced, maybe Mike is still working on it.

            It does work for me. The colors are a bit strange though.

            > Also popt should have duplex:off as the default, would be safer.

            I'm trying to save some trees... Printers that can't duplex will
            automatically fall back to simplex. At least, that's what is supposed
            to happen.

            --
            TALL KNIGHT: We are now no longer the Knights Who Say Ni!
            ONE KNIGHT: Ni!
            OTHERS: Sh!
            ONE KNIGHT: (whispers) Sorry.
            "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

            /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
            ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
            \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
          • Zdenek Sekera
            ... Very useful. ... Actually no, with duplex:off it works, so it s a beauty, I just know now I must *not* to forget it to set it. If that was made default,
            Message 5 of 18 , Sep 3, 2001
              Mike Williams wrote:
              >
              > On 3 Sep 2001, at 12:00, Zdenek Sekera wrote:
              >
              > > > PostScript printing:
              > > > - Made "duplex" work. (Mike Williams)
              > >
              > > This doesn't say much details,
              >
              > I think this is no more than try and make it more bullet proof.

              Very useful.

              > As
              > per your printer, there are situations that are out of the control of
              > the PS and it just wont work at all. :(
              >

              Actually no, with duplex:off it works, so it's a beauty, I just know
              now I must *not* to forget it to set it.
              If that was made default, more printers would work out of box (even mine
              :-).

              > > but as a data point the 'color' printing
              > > from 'vim' (not gvim) still doesn't work, b&w and lots of underlining
              > > is produced, maybe Mike is still working on it.
              >
              > You are gonna hate this, but 'it works for me'.

              Not really, only jealous :-)

              > More detail and I
              > would be happy to look into.

              Coming, see below.

              > This may be a function of Windows
              > console version not being able to switch to a gui version like Unix
              > vim can. The way the code builds may be different which is causing
              > the problem. Just a thought.

              No, I am on Irix (that's SGI unix).

              Here are the details. In short: if t_Co= blank/nothing , my display
              is still in colors but the printout comes out B&W.
              It's more of my setup problem than postscript generation I think.

              Maybe more details are useful, just in case any of (Irix?) users can
              shed some light on this (I am actually chasing that problem for maybe
              2 years now without any success at all).

              Facts:
              I am using Irix (currently 6.5.13, highest) with Xfree xterm (the latest
              version) *not* the SGI released xterm, because this one is B&W only. For
              Irix insiders: I am not using winterm (xwsh) because I don't really like
              colors it gives me and I find it less configurable than Xfree86 xterm.

              I get the best display colors when I run SGI released terminfo with
              Xfree86 xterm (so, *not* the terminfo released with Xfree xterm).
              Colors are bright and text on vim display is very readable IMHO.
              To me it's *beautiful* :-)
              The SGI terminfo has no color settings and, indeed, to get those
              beautiful colors I have to have t_Co= blank !!!!

              That worked automatically and beautifully before the Xfree xterm
              included
              OPT_TCAP_QUERY, since then vim interrogates at the beginning the
              xterm for actual termcap color codes and also obtains t_Co from xterm
              (see term.c:~4980 and afterwards).

              I have my xterm compiled with support for 88 colors (now) but I 'set
              t_Co='
              in .vimrc. However, since vim interrogates xterm asynchronously, the
              final
              value of t_Co depends on who got there last: .vimrc reading or the
              xterm query.

              So my starts either with t_Co='' colors or t_Co=88 colors (that I don't
              like
              that much).

              BUT: if t_Co has a value, the :ha will print in colors
              if t_Co has no value (is empty/blank) printout will comeout in B&W
              with number of things underlined

              What's hard for me to understand (and I have no clue) is why do I get
              colors on my display for t_Co='' but the generated postscript is B&W.
              This may be an academical question since I think I *should have* t_Co
              defined when colors are to be present but the fact is the best colors
              I get with t_Co=''...hmmmm...

              Would anyone on this have an idea what's going on here?

              ---Zdenek
            • Mike Williams
              ... Empirically it does not. Zdenek has a printer that if you try to turn duplex mode on it aborts the job. There seems to be no way to detect and cope with
              Message 6 of 18 , Sep 3, 2001
                On 3 Sep 2001, at 13:55, Bram Moolenaar wrote:

                > > Also popt should have duplex:off as the default, would be safer.
                >
                > I'm trying to save some trees... Printers that can't duplex will
                > automatically fall back to simplex. At least, that's what is supposed
                > to happen.

                Empirically it does not. Zdenek has a printer that if you try to
                turn duplex mode on it aborts the job. There seems to be no way to
                detect and cope with this from PS, at least not using any standard
                way.

                TTFN

                Mike
                --
                The shortest distance between two points is under repair.
              • Zdenek Sekera
                Bram Moolenaar wrote: ... Se my other mail on that. ... I think you really do save trees, see this: I have a printer (can t be all that exceptional) that is
                Message 7 of 18 , Sep 3, 2001
                  Bram Moolenaar wrote:
                  ...
                  > > This doesn't say much details, but as a data point the 'color' printing
                  > > from 'vim' (not gvim) still doesn't work, b&w and lots of underlining
                  > > is produced, maybe Mike is still working on it.
                  >
                  > It does work for me. The colors are a bit strange though.
                  >

                  Se my other mail on that.

                  > > Also popt should have duplex:off as the default, would be safer.
                  >
                  > I'm trying to save some trees... Printers that can't duplex will
                  > automatically fall back to simplex. At least, that's what is supposed
                  > to happen.

                  I think you really do save trees, see this:
                  I have a printer (can't be all that exceptional) that is simplex
                  but the driver is screwed up and if the PS file contains a 'duplex:on'
                  equivalent setting (ask Mike), it will silently ignore my file.
                  That's even betterway of saving trees, but not my nerves :-).
                  Bottom line: if a printer doesn't handle and option, it is *very*
                  hard to findout what's going on (not a vim problem), we went through
                  that with Mike. duplex:off should work for all printers and if one
                  wants to try duplex:on, just set it: if you get no output you know
                  you shouldn't have done that. This is easier than getting nothing
                  and trying to guess why. Apparently all that postscript printing
                  is a real science :-).

                  ---Zdenek
                • Matt Dunford
                  ... I m having a small problem w/ what s generated in src/proto. Here s my error: % uname -a SunOS io 5.5.1 Generic_103640-24 sun4m sparc SUNW,SPARCstation-5
                  Message 8 of 18 , Sep 3, 2001
                    On Sun, Sep 02, 2001 at 08:23:57PM +0200, Bram Moolenaar wrote:
                    >
                    > This is the "golden" BETA for Vim 6.0.
                    >
                    > Again mostly bug fixes. I expect the 6.0 release in just a few weeks now.
                    > Please try to find every bug, documentation mistake, omission, etc.
                    >
                    > I noticed that a few people didn't report problems, assuming someone else
                    > would do that. Well, if you still see a problem now, apparently nobody
                    > reported it yet, so you better do that _now_!

                    I'm having a small problem w/ what's generated in src/proto. Here's my
                    error:

                    %> uname -a
                    SunOS io 5.5.1 Generic_103640-24 sun4m sparc SUNW,SPARCstation-5
                    %> CFLAGS="-g -pipe" ./configure --without-x --disable-gui && make
                    ...
                    gcc -c -I. -Iproto -DHAVE_CONFIG_H -I/usr/local/include -g -pipe -o objects/ex_docmd.o ex_docmd.c
                    ex_docmd.c: In function `ex_autocmd':
                    ex_docmd.c:3464: too many arguments to function `do_augroup'
                    make: *** [objects/ex_docmd.o] Error 1

                    The prototype for do_augroup in proto/fileio.pro is:
                    void do_augroup __ARGS((char_u *arg));
                    which is wrong.

                    I would like to debug this problem, but I really don't know where to
                    start. Any advice would be much appreciated.

                    PS: This also occured in 6.0at but with different functions (I forget which
                    ones).

                    --
                    - Matt Dunford <> zoot@... ..
                    -. www.zotikos.com -- o,;-

                    "Public speaking is very easy."
                    -- Vice President Dan Quayle to reporters in 10/88
                    --
                  • Bram Moolenaar
                    ... That is not the prototype in the file. You are using an older version of the file. Did you have problems unpacking the archive? -- Why isn t there
                    Message 9 of 18 , Sep 3, 2001
                      Matt Dunford wrote:

                      > I'm having a small problem w/ what's generated in src/proto. Here's my
                      > error:
                      >
                      > %> uname -a
                      > SunOS io 5.5.1 Generic_103640-24 sun4m sparc SUNW,SPARCstation-5
                      > %> CFLAGS="-g -pipe" ./configure --without-x --disable-gui && make
                      > ...
                      > gcc -c -I. -Iproto -DHAVE_CONFIG_H -I/usr/local/include -g -pipe -o objects/ex_docmd.o ex_docmd.c
                      > ex_docmd.c: In function `ex_autocmd':
                      > ex_docmd.c:3464: too many arguments to function `do_augroup'
                      > make: *** [objects/ex_docmd.o] Error 1
                      >
                      > The prototype for do_augroup in proto/fileio.pro is:
                      > void do_augroup __ARGS((char_u *arg));
                      > which is wrong.

                      That is not the prototype in the file. You are using an older version
                      of the file. Did you have problems unpacking the archive?

                      --
                      Why isn't there mouse-flavored cat food?

                      /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
                      ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
                      \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
                    • Bram Moolenaar
                      ... We already came to the conclusion that your printer is broken (doesn t do what PostScript specifies). I hesitate to support broken printers. Especially
                      Message 10 of 18 , Sep 3, 2001
                        Zdenek Sekera wrote:

                        > > > Also popt should have duplex:off as the default, would be safer.
                        > >
                        > > I'm trying to save some trees... Printers that can't duplex will
                        > > automatically fall back to simplex. At least, that's what is supposed
                        > > to happen.
                        >
                        > I think you really do save trees, see this:
                        > I have a printer (can't be all that exceptional) that is simplex
                        > but the driver is screwed up and if the PS file contains a 'duplex:on'
                        > equivalent setting (ask Mike), it will silently ignore my file.
                        > That's even betterway of saving trees, but not my nerves :-).
                        > Bottom line: if a printer doesn't handle and option, it is *very*
                        > hard to findout what's going on (not a vim problem), we went through
                        > that with Mike. duplex:off should work for all printers and if one
                        > wants to try duplex:on, just set it: if you get no output you know
                        > you shouldn't have done that. This is easier than getting nothing
                        > and trying to guess why. Apparently all that postscript printing
                        > is a real science :-).

                        We already came to the conclusion that your printer is broken (doesn't
                        do what PostScript specifies). I hesitate to support broken printers.
                        Especially because you are the only one that ran into this problem.

                        --
                        Lose weight, NEVER Diet again with
                        The "Invisible Weight Loss Patch"
                        (spam e-mail)

                        /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
                        ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
                        \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
                      • Bram Moolenaar
                        ... I don t see how you can get syntax colors while t_Co is empty. Perhaps the bold/italic/underline attributes are displayed as colors for you (that s how it
                        Message 11 of 18 , Sep 3, 2001
                          Zdenek Sekera wrote:

                          > What's hard for me to understand (and I have no clue) is why do I get
                          > colors on my display for t_Co='' but the generated postscript is B&W.
                          > This may be an academical question since I think I *should have* t_Co
                          > defined when colors are to be present but the fact is the best colors
                          > I get with t_Co=''...hmmmm...
                          >
                          > Would anyone on this have an idea what's going on here?

                          I don't see how you can get syntax colors while t_Co is empty. Perhaps
                          the bold/italic/underline attributes are displayed as colors for you
                          (that's how it works on the Amiga)?

                          --
                          ROBIN: The what?
                          ARTHUR: The Holy Hand Grenade of Antioch. 'Tis one of the sacred relics
                          Brother Maynard always carries with him.
                          ALL: Yes. Of course.
                          ARTHUR: (shouting) Bring up the Holy Hand Grenade!
                          "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

                          /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
                          ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
                          \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
                        • Mike Williams
                          ... Ok, perhaps I was a bit too free and easy with my accusations of broken - it is certainly an odd-ball from this point of view (setting duplex on that
                          Message 12 of 18 , Sep 3, 2001
                            On 3 Sep 2001, at 18:29, Bram Moolenaar wrote:

                            > We already came to the conclusion that your printer is broken (doesn't
                            > do what PostScript specifies). I hesitate to support broken printers.
                            > Especially because you are the only one that ran into this problem.

                            Ok, perhaps I was a bit too free and easy with my accusations of
                            'broken' - it is certainly an odd-ball from this point of view
                            (setting duplex on that is). Perhaps the local sys-admin knows how
                            to alter this bahaviour, or it may be worth going back to the printer
                            manufacturer to see if there is an upgrade (software or hardware)
                            that removes this undesirable behaviour.

                            TTFN

                            Mike
                            --
                            Got a life, but wasn't sure what to do with it.
                          • Nazri Ramliy
                            On Windows NT 4.0, console version, 6.0au vim -u NONE -U NONE then ... [help.txt displayed, no colors] ... [nothing happens] ... [now it s in color] same thing
                            Message 13 of 18 , Sep 3, 2001
                              On Windows NT 4.0, console version, 6.0au

                              vim -u NONE -U NONE

                              then

                              :help

                              [help.txt displayed, no colors]

                              :syn enable

                              [nothing happens]

                              :syn enable

                              [now it's in color]

                              same thing goes with :syn on, have to do it twice to get the color on.

                              Bug?

                              Regards,
                              Nazri
                            • Matt Dunford
                              ... You re right. The problem is on my end. I m using the cvs d version. But somehow I managed to munge the proto directory, causing the files inside not to
                              Message 14 of 18 , Sep 4, 2001
                                On Mon, Sep 03, 2001 at 06:29:34PM +0200, Bram Moolenaar wrote:
                                >
                                > > I'm having a small problem w/ what's generated in src/proto. Here's my
                                > > error:
                                > >
                                > > [...] *snip*
                                > >
                                > > The prototype for do_augroup in proto/fileio.pro is:
                                > > void do_augroup __ARGS((char_u *arg));
                                > > which is wrong.
                                >
                                > That is not the prototype in the file. You are using an older version
                                > of the file. Did you have problems unpacking the archive?

                                You're right. The problem is on my end. I'm using the cvs'd version.
                                But somehow I managed to munge the proto directory, causing the files
                                inside not to be updated by cvs. All is well now. Sorry about that.

                                --
                                - Matt Dunford <> zoot@... ..
                                -. www.zotikos.com -- o,;-

                                Why I love being a californian:
                                Unlike back home, the guy at 8:30 am at Starbucks wearing
                                the baseball cap and sunglasses who looks like George Clooney IS George
                                Clooney.
                                --
                              • Bram Moolenaar
                                ... Well, at least it is unexpected. What happens is that the $VIMRUNTIME/syntax/syntax.vim script triggers autocommands to get the filetypes detected for
                                Message 15 of 18 , Sep 4, 2001
                                  Nazri Ramliy wrote:

                                  > On Windows NT 4.0, console version, 6.0au
                                  >
                                  > vim -u NONE -U NONE
                                  >
                                  > then
                                  >
                                  > :help
                                  >
                                  > [help.txt displayed, no colors]
                                  >
                                  > :syn enable
                                  >
                                  > [nothing happens]
                                  >
                                  > :syn enable
                                  >
                                  > [now it's in color]
                                  >
                                  > same thing goes with :syn on, have to do it twice to get the color on.
                                  >
                                  > Bug?

                                  Well, at least it is unexpected. What happens is that the
                                  $VIMRUNTIME/syntax/syntax.vim script triggers autocommands to get the
                                  filetypes detected for bufferes that are already open. But since the
                                  help file type isn't detected but set manually, it won't get
                                  highlighting. When doing it a second time the script knows that the
                                  file type doesn't need to be detected, and only sets the 'syntax'
                                  options to 'filetype', which then works.

                                  This patch should fix it:

                                  *** ../vim-6.0au/runtime/syntax/syntax.vim Sun Sep 2 19:28:33 2001
                                  --- runtime/syntax/syntax.vim Tue Sep 4 10:57:08 2001
                                  ***************
                                  *** 35,42 ****

                                  " Execute the syntax autocommands for the each buffer.
                                  " If the filetype wasn't detected yet, do that now.
                                  ! if s:did_ft
                                  ! doautoall syntaxset FileType
                                  ! else
                                  doautoall filetypedetect BufRead
                                  endif
                                  --- 35,43 ----

                                  " Execute the syntax autocommands for the each buffer.
                                  " If the filetype wasn't detected yet, do that now.
                                  ! " Always do the syntaxset autocommands, for buffers where the 'filetype'
                                  ! " already was set manually (e.g., help buffers).
                                  ! doautoall syntaxset FileType
                                  ! if !s:did_ft
                                  doautoall filetypedetect BufRead
                                  endif

                                  --
                                  BEDEVERE: How do you know so much about swallows?
                                  ARTHUR: Well you have to know these things when you're a king, you know.
                                  "Monty Python and the Holy Grail" PYTHON (MONTY) PICTURES LTD

                                  /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
                                  ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
                                  \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
                                • Zdenek Sekera
                                  ... Still true, doesn t work. ... VIM - Vi IMproved 6.0au BETA (2001 Sep 2, compiled Sep 3 2001 14:03:59) Compiled by zs@amati Normal version with X11-Motif
                                  Message 16 of 18 , Sep 4, 2001
                                    Bram Moolenaar wrote:
                                    >
                                    ...
                                    >
                                    > IRIX: Ctrl-keys didn't work when compiled with XIM. (David Harrison)
                                    >
                                    Still true, doesn't work.

                                    :ver
                                    VIM - Vi IMproved 6.0au BETA (2001 Sep 2, compiled Sep 3 2001 14:03:59)
                                    Compiled by zs@amati
                                    Normal version with X11-Motif GUI. Features included (+) or not (-):
                                    +autocmd +balloon_eval +browse +builtin_terms +byte_offset +cindent
                                    +clientserver +clipboard
                                    +cmdline_compl +cmdline_hist +cmdline_info +comments +cryptv +cscope
                                    +dialog_con_gui +diff
                                    +digraphs -ebcdic -emacs_tags +eval +ex_extra +extra_search -farsi
                                    +file_in_path
                                    +find_in_path +folding -footer +fork() -gettext -hangul_input -iconv
                                    +insert_expand
                                    +jumplist -keymap -langmap +libcall +linebreak +lispindent +listcmds
                                    +localmap +menu
                                    +mksession +modify_fname +mouse +mouseshape -mouse_dec -mouse_gpm
                                    -mouse_jsbterm
                                    -mouse_netterm +mouse_xterm -multi_byte +multi_lang -osfiletype
                                    +path_extra -perl
                                    +postscript +printer -python +quickfix -rightleft -ruby +scrollbind
                                    -signs +smartindent
                                    +sniff +statusline -sun_workshop +syntax +tag_binary +tag_old_static
                                    -tag_any_white -tcl
                                    +terminfo +termresponse +textobjects +title +toolbar +user_commands
                                    +vertsplit +virtualedit
                                    +visual +visualextra +viminfo +vreplace +wildignore +wildmenu +windows
                                    +writebackup +X11
                                    +xfontset +xim +xterm_clipboard -xterm_save
                                    ^^^^
                                    system vimrc file: "$VIM/vimrc"
                                    user vimrc file: "$HOME/.vimrc"
                                    user exrc file: "$HOME/.exrc"
                                    system gvimrc file: "$VIM/gvimrc"
                                    user gvimrc file: "$HOME/.gvimrc"
                                    system menu file: "$VIMRUNTIME/menu.vim"
                                    fall-back for $VIM: "/usr/people/zs/share/vim"
                                    Compilation: cc -c -I. -Iproto -DHAVE_CONFIG_H -DFEAT_GUI_MOTIF
                                    -DFUNCPROTO=7 -DNARROWPROTO -
                                    I/usr/include/X11 -n32 -mips3 -OPT:Olimit=0 -g
                                    Linking: cc -L/usr/lib/X11 -n32 -mips3 -ltermlib -L/usr/local/lib -o
                                    vim -lXmu -lXext -lXm
                                    -lXpm -lXt -lX11 -ltermlib
                                  • David Harrison Jr.
                                    ... Actually, that s not the case. It was the lost character after going into insert mode or typing a colon. The CTRL keys still don t work. I m still
                                    Message 17 of 18 , Sep 4, 2001
                                      Bram Moolenaar wrote:

                                      >Fixes
                                      >-----
                                      >
                                      >IRIX: Ctrl-keys didn't work when compiled with XIM. (David Harrison)
                                      >

                                      Actually, that's not the case. It was the "lost character" after going
                                      into insert mode or typing a colon.

                                      The CTRL keys still don't work. I'm still trying to figure out why.

                                      FYI,
                                      David Harrison Jr.
                                    Your message has been successfully submitted and would be delivered to recipients shortly.