Loading ...
Sorry, an error occurred while loading the content.

Re: Vim version 6.0ap BETA available

Expand Messages
  • Michael Piefel
    ... Funny since I have to use Shift twice to enter that smiley. German keyboards are a real disadvantage: This joke would look like ,-9 Kann Umschalttaste
    Message 1 of 24 , Aug 1, 2001
    • 0 Attachment
      > --
      > From "know your smileys":
      > ;-0 Can't find shift key

      Funny since I have to use Shift twice to enter that smiley. German
      keyboards are a real disadvantage: This joke would look like
      ,-9 Kann Umschalttaste nicht finden
      in German, and I guess most people would take a long time to understand
      this...

      Bye,
      Mike

      --
      |=| Michael Piefel piefel@...-berlin.de
      |=| Humboldt-Universit├Ąt zu Berlin http://www.piefel.de
      |=| Tel. (+49 30) 2093 3831
    • Martin Dalecki
      ... Yes please. ... -- - phone: +49 214 8656 283 - job: eVision-Ventures AG, LEV .de (MY OPINIONS ARE MY OWN!) - langs: de_DE.ISO8859-1, en_US,
      Message 2 of 24 , Aug 1, 2001
      • 0 Attachment
        Bram Moolenaar wrote:
        >
        > Martin Dalecki wrote:
        >
        > > Aric Blumer wrote:
        > > >
        > > > On Tue Jul 31 09:42:40 2001 Bohdan Vlasyuk wrote:
        > > > > No, works for me. [1.2.10]
        > > > > . . .
        > > > > Most significant difference -- I don't have GNOME support compiled in.
        > > >
        > > > Thanks, Bohdan.
        > > >
        > > > I recompiled with 'config --without-gnome', and it now works completely
        > > > as expected (including the mouse pointer), so it must have something to
        > > > do with the GNOME support.
        > > >
        > > > For what it's worth, I am using RedHat 7.1, and here are the gnome and
        > > > gtk RPMs that are installed:
        > >
        > > Some bgous moron added support for "native gnome dialogues" in Vim,
        > > without thinking much about the text entry field issue I guess.
        > > I personally as the original authour of the GTK+ port have
        > > great *disrespect* for the whole gnome stuff and don't welcome it
        > > inside Vim at all, in esp. since it doesn't provide any sensible
        > > additional functionality and only makes Vim inherit all the
        > > GNOME problems. Most prominently the /dev/dsp issue to name a one.
        > > And then it makes Vim dependant upon .so.0.0.x libraries for no good
        > > reason.
        >
        > True, adding Gnome support doesn't give that much extra. A few nicer looking
        > icons perhaps. And it does cause trouble. Perhaps I should disable it by
        > default? On the other hand, we would never encounter the Gnome problems then,

        Yes please.

        > they will probably not get fixed.
        >
        > --
        > >From "know your smileys":
        > ;-0 Can't find shift key
        >
        > /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
        > ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
        > \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///

        --
        - phone: +49 214 8656 283
        - job: eVision-Ventures AG, LEV .de (MY OPINIONS ARE MY OWN!)
        - langs: de_DE.ISO8859-1, en_US, pl_PL.ISO8859-2, last ressort:
        ru_RU.KOI8-R
      • Neil Bird
        ... Ah - that ll be my fault then. Sorry! Oh. No it isn t - that s not what I did. Here s what I sent Bram: # ifdef FEAT_GUI_GNOME if (!gtk_socket_id) { /* If
        Message 3 of 24 , Aug 1, 2001
        • 0 Attachment
          Andy Kahn wrote:
          > # ifdef FEAT_GUI_GNOME
          > /* If Gnome is available, use it for the simple button dialog. */
          > if (gtk_socket_id == 0 || textfield == NULL)
          > return gui_gnome_dialog(type, title, message, buttons, def_but);
          > # endif

          Ah - that'll be my fault then. Sorry!

          Oh. No it isn't - that's not what I did. Here's what I sent
          Bram:


          # ifdef FEAT_GUI_GNOME
          if (!gtk_socket_id)
          {
          /* If Gnome is available, use it for the simple button
          dialog. */
          if (textfield == NULL)
          return gui_gnome_dialog(type, title, message,
          buttons, def_but);
          }
          # endif


          Somewhat different. Methinks Bram mis-optimised!

          In that case, you should use '&&' not '||' in the current
          code.

          --
          =================- http://www.thalesgroup.com/ -================
          Neil Bird Principal Engineer |
          work - mailto:neil.bird@... | $> cd /pub
          personal - mailto:neil@... | $> more beer
        • Neil Bird
          ... There s another problem with those gnome dialogues that I ve only just associated with them. You get wads of errors if you use to dismiss them ....
          Message 4 of 24 , Aug 1, 2001
          • 0 Attachment
            Bram Moolenaar wrote:
            > When using confirm() the problem of the mouse pointer being invisible still
            > exists.

            There's another problem with those gnome dialogues that I've
            only just associated with them. You get wads of errors if you
            use <space> to dismiss them .... and that <space> can be misred.

            Try 'vim file', then <Ctrl-Z> suspend it. Then 'gvim file'
            will try to report a lockfile. Basj space to page down the
            lockfile message, and the gui dialogue comes up & immediately
            goes away, leaving a trail of GTK warnings.

            At least it does for me, and IIRC always has.

            --
            =================- http://www.thalesgroup.com/ -================
            Neil Bird Principal Engineer |
            work - mailto:neil.bird@... | $> cd /pub
            personal - mailto:neil@... | $> more beer
          • Andy Kahn
            On Wed, Aug 01, 2001 at 03:04:55PM +0100, Neil Bird wrote: ... What s basj space ? When I hit the spacebar on this dialogue, it successfully selects the
            Message 5 of 24 , Aug 1, 2001
            • 0 Attachment
              On Wed, Aug 01, 2001 at 03:04:55PM +0100, Neil Bird wrote:
              ...
              > There's another problem with those gnome dialogues that I've
              > only just associated with them. You get wads of errors if you
              > use <space> to dismiss them .... and that <space> can be misred.
              >
              > Try 'vim file', then <Ctrl-Z> suspend it. Then 'gvim file'
              > will try to report a lockfile. Basj space to page down the
              > lockfile message, and the gui dialogue comes up & immediately
              > goes away, leaving a trail of GTK warnings.
              >
              > At least it does for me, and IIRC always has.

              What's "basj space"?

              When I hit the spacebar on this dialogue, it successfully selects the
              default selected button, which is the "Quit" button. Gvim then quits
              as expected. Are you doing something different?
              --andy
            • Andy Kahn
              On Wed, Aug 01, 2001 at 10:25:35AM +0200, Martin Dalecki wrote: ... If you dislike gnome so much, then you should probably not have it installed on your
              Message 6 of 24 , Aug 1, 2001
              • 0 Attachment
                On Wed, Aug 01, 2001 at 10:25:35AM +0200, Martin Dalecki wrote:
                ...
                > > icons perhaps. And it does cause trouble. Perhaps I should disable it by
                > > default? On the other hand, we would never encounter the Gnome
                > > problems then,
                >
                > Yes please.

                If you dislike gnome so much, then you should probably not have it
                installed on your system. If this is already the case, I don't see
                why you're making such a big fuss over it.
                --andy
              • Martin Dalecki
                ... Blah blah blah. I have not installed it on my system. But some fucking RPM dependencies don t allow me to deinstall this crap *compleatly* from RedHat 7.1
                Message 7 of 24 , Aug 1, 2001
                • 0 Attachment
                  Andy Kahn wrote:
                  >
                  > On Wed, Aug 01, 2001 at 10:25:35AM +0200, Martin Dalecki wrote:
                  > ...
                  > > > icons perhaps. And it does cause trouble. Perhaps I should disable it by
                  > > > default? On the other hand, we would never encounter the Gnome
                  > > > problems then,
                  > >
                  > > Yes please.
                  >
                  > If you dislike gnome so much, then you should probably not have it
                  > installed on your system. If this is already the case, I don't see
                  > why you're making such a big fuss over it.

                  Blah blah blah. I have not installed it on my system. But some
                  fucking RPM dependencies don't allow me to deinstall this crap
                  *compleatly* from RedHat 7.1
                • Ron Aaron
                  ... FWIW, I completely understand Martin s point of view. I never have installed gnome on purpose, but unless you want a crippled system, you need to install
                  Message 8 of 24 , Aug 1, 2001
                  • 0 Attachment
                    >> If you dislike gnome so much, then you should probably not have it
                    >> installed on your system. If this is already the case, I don't see
                    >> why you're making such a big fuss over it.
                    >
                    >Blah blah blah. I have not installed it on my system. But some
                    >f#$%#$%ng RPM dependencies don't allow me to deinstall this crap
                    >*compleatly* from RedHat 7.1

                    FWIW, I completely understand Martin's point of view. I never have
                    installed gnome on purpose, but unless you want a crippled system, you need
                    to install at least parts of it.

                    Martin, Slackware is a better choice if you want to eliminate unnecessary
                    weight on your Linux system (this is getting way off topic, though...)

                    Ron
                  • Andy Kahn
                    On Wed, Aug 01, 2001 at 07:08:51PM +0200, Martin Dalecki wrote: ... This sounds more like a problem with your Linux installation, and not a problem with vim.
                    Message 9 of 24 , Aug 1, 2001
                    • 0 Attachment
                      On Wed, Aug 01, 2001 at 07:08:51PM +0200, Martin Dalecki wrote:
                      ...
                      > > If you dislike gnome so much, then you should probably not have it
                      > > installed on your system. If this is already the case, I don't see
                      > > why you're making such a big fuss over it.
                      >
                      > Blah blah blah. I have not installed it on my system. But some
                      > fucking RPM dependencies don't allow me to deinstall this crap
                      > *compleatly* from RedHat 7.1

                      This sounds more like a problem with your Linux installation, and not
                      a problem with vim.
                      --andy
                    Your message has been successfully submitted and would be delivered to recipients shortly.