Loading ...
Sorry, an error occurred while loading the content.
 

Re: The syntax has left me...

Expand Messages
  • Bram Moolenaar
    ... I don t know what you mean here. For me the Syntax menus stays there when syntax is switched off. -- From know your smileys : 8-O Omigod!! (done rm
    Message 1 of 4 , Jun 4, 2001
      Adam Seyfarth wrote:

      > I just got vim60ah recently and noticed that when you set the
      > syntax off, the drop-down menu leaves exsistence.

      I don't know what you mean here. For me the Syntax menus stays there when
      syntax is switched off.

      --
      From "know your smileys":
      8-O "Omigod!!" (done "rm -rf *" ?)

      /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
      ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
      \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
    • Bram Moolenaar
      ... Oh, when you don t switch syntax highlighting on, you don t get the Syntax menu. That s intentional. Vim assumes you didn t want syntax highlighting.
      Message 2 of 4 , Jun 4, 2001
        Adam Seyfarth wrote:

        > Well, have you tried STARTING gvim60ah with the syntax off? This
        > would require making a .gvimrc that set it off. I know it happened
        > once. I have a HUGE .gvimrc with lots of functions with tons of
        > if statements. But it never sets the "syntax on". I will keep
        > trying to track that down,but it's hiding from me...

        Oh, when you don't switch syntax highlighting on, you don't get the Syntax
        menu. That's intentional. Vim assumes you didn't want syntax highlighting.

        Perhaps we should add one entry for switching on Syntax highlighting in this
        situation?

        --
        From "know your smileys":
        :.-( Crying

        /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
        ((( Creator of Vim -- http://vim.sf.net -- ftp://ftp.vim.org/pub/vim )))
        \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
      • Aschwin Marsman
        ... I would prefer that, I wanted to show the beauty of vim to a vi hater by showing the syntax highlighting, but the syntax menu was available on the WIN32
        Message 3 of 4 , Jun 4, 2001
          On Mon, 4 Jun 2001, Bram Moolenaar wrote:

          >
          > Adam Seyfarth wrote:
          >
          > > Well, have you tried STARTING gvim60ah with the syntax off? This
          > > would require making a .gvimrc that set it off. I know it happened
          > > once. I have a HUGE .gvimrc with lots of functions with tons of
          > > if statements. But it never sets the "syntax on". I will keep
          > > trying to track that down,but it's hiding from me...
          >
          > Oh, when you don't switch syntax highlighting on, you don't get the Syntax
          > menu. That's intentional. Vim assumes you didn't want syntax highlighting.
          >
          > Perhaps we should add one entry for switching on Syntax highlighting in this
          > situation?

          I would prefer that, I wanted to show the beauty of vim to a vi hater by
          showing the syntax highlighting, but the syntax menu was available on
          the WIN32 binary. Off course we found the right option quickly in the
          documentation, but a menu entry would be more friendly for newcomers.

          Kind regards,

          Aschwin Marsman

          Aschwin@... Software Engineer. Expertises: Linux (1993), UNIX (1990)
          http://www.marsman.org C (1990), C++ (1994), OO (1994), OSF/Motif (1994), SCM (1995)
        Your message has been successfully submitted and would be delivered to recipients shortly.