Loading ...
Sorry, an error occurred while loading the content.
 

Re: [vimdev] Howto NOT auto insert tabs ?

Expand Messages
  • Dr. Charles E. Campbell
    ... Hmm, that *used* to stop it, at least for me, but no longer with ft==vim files. I haven t bothered to track it down yet... OK, here s why: vim 6.0z has a
    Message 1 of 2 , Apr 3, 2001
      Thus saith Mark Brophy:
      > Actually, I think he means autoindent. I know I get annoyed
      > when pasting a lot of text into vim and everyline appears
      > indented from the previous.
      >
      > :set noai
      >
      > will stop it.
      ---------------------------------------------------------------------

      Hmm, that *used* to stop it, at least for me, but no longer
      with ft==vim files. I haven't bothered to track it down yet...

      OK, here's why: vim 6.0z has a bunch of files which assist
      in indentation in ../vim/vim60z/indent/...

      config.vim html.vim matlab.vim python.vim sh.vim verilog.vim xml.vim
      fortran.vim make.vim perl.vim ruby.vim tcl.vim vim.vim

      Vim.vim here sets indentexpr; try

      :set noai
      :set inde=

      Its one of those cases where the editor is getting "smarter"
      than it used to be.

      --
      Charles E Campbell, Jr, PhD _ __ __
      Goddard Space Flight Center / /_/\_\_/ /
      cec@... /_/ \/_//_/
      PGP public key: http://www.erols.com/astronaut/pgp.html
    • Mark Waggoner
      ... ... works well (at least it used to - I haven t tried it lately) for when you want to paste text in. I m not sure what platform this is
      Message 2 of 2 , Apr 3, 2001
        On Tue, 3 Apr 2001, Dr. Charles E. Campbell wrote:

        > Thus saith Mark Brophy:
        > > Actually, I think he means autoindent. I know I get annoyed
        > > when pasting a lot of text into vim and everyline appears
        > > indented from the previous.
        > >
        > > :set noai
        > >
        > > will stop it.
        > ---------------------------------------------------------------------
        >
        > Hmm, that *used* to stop it, at least for me, but no longer
        > with ft==vim files. I haven't bothered to track it down yet...
        >
        > OK, here's why: vim 6.0z has a bunch of files which assist
        > in indentation in ../vim/vim60z/indent/...
        >
        > config.vim html.vim matlab.vim python.vim sh.vim verilog.vim xml.vim
        > fortran.vim make.vim perl.vim ruby.vim tcl.vim vim.vim
        >
        > Vim.vim here sets indentexpr; try
        >
        > :set noai
        > :set inde=
        >
        > Its one of those cases where the editor is getting "smarter"
        > than it used to be.


        :set paste
        <paste text>
        :set nopaste

        works well (at least it used to - I haven't tried it lately) for when
        you want to paste text in. I'm not sure what platform this is
        referring to, but when running in an xterm window (and you can connect
        to your X server) or when running a gui version of vim, it does a good
        job of pasting "properly" without having to ":set paste" before doing
        so. Console versions running elsewhere are probably not so talented.

        (While looking at :help paste in 60z, I noticed this minor patch
        needed:)

        *** src/vim60z/runtime/doc/options.txt.orig Sat Mar 24 08:41:58 2001
        --- src/vim60z/runtime/doc/options.txt Tue Apr 3 10:31:23 2001
        ***************
        *** 3600,3606 ****
        - 'ruler' is reset
        - 'showmatch' is reset
        - 'formatoptions' is used like it is empty
        ! These options keep there value, but their effect is disabled:
        - 'lisp'
        - 'indentexpr'
        - 'cindent'
        --- 3600,3606 ----
        - 'ruler' is reset
        - 'showmatch' is reset
        - 'formatoptions' is used like it is empty
        ! These options keep their value, but their effect is disabled:
        - 'lisp'
        - 'indentexpr'
        - 'cindent'



        --------------------------------------------------------------------------
        Mark Waggoner waggoner@... (503) 712-3335
        From there to here, from here to there, funny things are everywhere
      Your message has been successfully submitted and would be delivered to recipients shortly.