Loading ...
Sorry, an error occurred while loading the content.

Re: 6.0t breaks crontab -e

Expand Messages
  • Bernhard Rosenkraenzer
    ... Not working on Red Hat Linux 7. ... No special options, no tampering with backupskip, no odd $TMPDIR. This happens only with the minimal version
    Message 1 of 8 , Feb 2 2:31 AM
    • 0 Attachment
      On Tue, 30 Jan 2001, Bram Moolenaar wrote:

      > > Some tools apparently can't deal with the new way of handling file I/O...
      > >
      > > When using vim 6.0t with "crontab -e", crontab holds the fd of the tmp
      > > file, and compares the result of fstat before and after; vi unlinks the
      > > old file and writes a new one.
      >
      > Hmm, I thought I fixed that. And for me it works fine.

      Not working on Red Hat Linux 7.

      > Did you change any of the options? Specifically 'backupskip'. Or is your
      > $TMPDIR not set to /tmp?

      No special options, no tampering with backupskip, no odd $TMPDIR.

      This happens only with the minimal version
      --with-features=tiny --with-x=no \
      --disable-pythoninterp --disable-perlinterp --disable-tclinterp \
      --with-tlib=termcap --enable-gui=no --disable-gpm --exec-prefix=/

      the full-featured version
      --with-features=huge --enable-pythoninterp \
      --enable-perlinterp --disable-tclinterp --with-x=no --enable-gui=no \
      --exec-prefix=/usr --enable-multibyte --enable-fontset

      works great.

      LLaP
      bero
    • Thomas Köhler
      On Fri, Feb 02, 2001 at 11:31:59AM +0100, ... What I always wanted to ask in this respect: Doing a default install of RedHat 6.2, vim-minimal gets installed.
      Message 2 of 8 , Feb 2 2:52 AM
      • 0 Attachment
        On Fri, Feb 02, 2001 at 11:31:59AM +0100,
        Bernhard Rosenkraenzer <bero@...> wrote:
        >
        > On Tue, 30 Jan 2001, Bram Moolenaar wrote:
        >
        > > > Some tools apparently can't deal with the new way of handling file I/O...
        > > >
        > > > When using vim 6.0t with "crontab -e", crontab holds the fd of the tmp
        > > > file, and compares the result of fstat before and after; vi unlinks the
        > > > old file and writes a new one.
        > >
        > > Hmm, I thought I fixed that. And for me it works fine.
        >
        > Not working on Red Hat Linux 7.
        >
        > > Did you change any of the options? Specifically 'backupskip'. Or is your
        > > $TMPDIR not set to /tmp?
        >
        > No special options, no tampering with backupskip, no odd $TMPDIR.
        >
        > This happens only with the minimal version
        > --with-features=tiny --with-x=no \
        > --disable-pythoninterp --disable-perlinterp --disable-tclinterp \
        > --with-tlib=termcap --enable-gui=no --disable-gpm --exec-prefix=/
        >
        > the full-featured version
        > --with-features=huge --enable-pythoninterp \
        > --enable-perlinterp --disable-tclinterp --with-x=no --enable-gui=no \
        > --exec-prefix=/usr --enable-multibyte --enable-fontset
        >
        > works great.

        What I always wanted to ask in this respect: Doing a default install of
        RedHat 6.2, vim-minimal gets installed. Now, I hit "vim" and get
        "command not found", so I enter "vi", and :ver says... "hey, it's vim".
        That's just annoying!

        > LLaP
        > bero

        Ciao,
        Thomas

        --
        Thomas Köhler Email: jean-luc@... | LCARS - Linux
        <>< WWW: http://jeanluc-picard.de | for Computers
        IRC: jeanluc | on All Real
        PGP public key available from Homepage! | Starships
      • Bernhard Rosenkraenzer
        ... I think this is the only sane thing to do - having a /bin/vi that is vim stripped down to be little more than old vi (features=tiny) and a /usr/bin/vim as
        Message 3 of 8 , Feb 2 2:58 AM
        • 0 Attachment
          On Fri, 2 Feb 2001, Thomas Köhler wrote:

          > What I always wanted to ask in this respect: Doing a default install of
          > RedHat 6.2, vim-minimal gets installed. Now, I hit "vim" and get
          > "command not found", so I enter "vi", and :ver says... "hey, it's vim".
          > That's just annoying!

          I think this is the only sane thing to do - having a /bin/vi that is vim
          stripped down to be little more than old vi (features=tiny) and a
          /usr/bin/vim as a fully featured editor (from vim-enhanced) seems sane to
          me.

          I've always been in favor of moving vim-enhanced to the default
          installations, but some <puke>emacs</puke> freaks are blocking that idea.
          :/

          LLaP
          bero
        • Max Ischenko
          ... The bugzilla.redhat.com is the place to said this if you want to be heard. -- An experienced user learns to be pessimistic.
          Message 4 of 8 , Feb 2 3:09 AM
          • 0 Attachment
            Thomas K?hler wrote:

            > > > Did you change any of the options? Specifically 'backupskip'. Or
            > is your
            > > > $TMPDIR not set to /tmp?
            > >
            > > No special options, no tampering with backupskip, no odd $TMPDIR.
            > >
            > > This happens only with the minimal version
            > > --with-features=tiny --with-x=no \
            > > --disable-pythoninterp --disable-perlinterp --disable-tclinterp \
            > > --with-tlib=termcap --enable-gui=no --disable-gpm --exec-prefix=/
            > >
            > > the full-featured version
            > > --with-features=huge --enable-pythoninterp \
            > > --enable-perlinterp --disable-tclinterp --with-x=no --enable-gui=no
            > \
            > > --exec-prefix=/usr --enable-multibyte --enable-fontset
            > >
            > > works great.
            >
            > What I always wanted to ask in this respect: Doing a default install of
            > RedHat 6.2, vim-minimal gets installed. Now, I hit "vim" and get
            > "command not found", so I enter "vi", and :ver says... "hey, it's vim".
            > That's just annoying!

            The bugzilla.redhat.com is the place to said this if you want to be heard.

            --
            An experienced user learns to be pessimistic.
          • Thomas Köhler
            On Fri, Feb 02, 2001 at 11:58:01AM +0100, ... It s sane if there really are both of them. It s not if there s only vi. Why not symlink vim to vi then? And of
            Message 5 of 8 , Feb 2 3:13 AM
            • 0 Attachment
              On Fri, Feb 02, 2001 at 11:58:01AM +0100,
              Bernhard Rosenkraenzer <bero@...> wrote:
              >
              > On Fri, 2 Feb 2001, Thomas Köhler wrote:
              >
              > > What I always wanted to ask in this respect: Doing a default install of
              > > RedHat 6.2, vim-minimal gets installed. Now, I hit "vim" and get
              > > "command not found", so I enter "vi", and :ver says... "hey, it's vim".
              > > That's just annoying!
              >
              > I think this is the only sane thing to do - having a /bin/vi that is vim
              > stripped down to be little more than old vi (features=tiny) and a
              > /usr/bin/vim as a fully featured editor (from vim-enhanced) seems sane to
              > me.

              It's sane if there really are both of them. It's not if there's only vi.
              Why not symlink vim to vi then?

              And of course, you could as well just let vim-minimal conflict with
              vim-enhanced (that's what package management is for), so if you install
              vim-enhanced, vim-minimal gets removed first. vim-minimal contains both
              vi and vim (the later being a symlink to the first), and vim-enhanced
              contains both (vi being the "minimal" version, vim being the enhanced
              one).

              > I've always been in favor of moving vim-enhanced to the default
              > installations, but some <puke>emacs</puke> freaks are blocking that idea.
              > :/

              ~> emacs
              zsh: command not found: emacs

              Of course, this is not a default installation (and, to be honest, it's
              debian-based ;-)

              > LLaP
              > bero

              Ciao,
              Thomas

              --
              Thomas Köhler Email: jean-luc@... | LCARS - Linux
              <>< WWW: http://jeanluc-picard.de | for Computers
              IRC: jeanluc | on All Real
              PGP public key available from Homepage! | Starships
            • Bram Moolenaar
              ... Hmm, only in the tiny version... Ah, backupskip isn t included then. Include this patch, then it should work: ... *************** *** 387,395 ****
              Message 6 of 8 , Feb 2 3:57 AM
              • 0 Attachment
                Bernhard Rosenkraenzer wrote:

                > > > When using vim 6.0t with "crontab -e", crontab holds the fd of the tmp
                > > > file, and compares the result of fstat before and after; vi unlinks the
                > > > old file and writes a new one.
                > >
                > > Hmm, I thought I fixed that. And for me it works fine.
                >
                > Not working on Red Hat Linux 7.
                >
                > > Did you change any of the options? Specifically 'backupskip'. Or is your
                > > $TMPDIR not set to /tmp?
                >
                > No special options, no tampering with backupskip, no odd $TMPDIR.

                Hmm, only in the tiny version... Ah, 'backupskip' isn't included then.

                Include this patch, then it should work:

                *** feature.h~ Tue Jan 30 14:47:58 2001
                --- feature.h Fri Feb 2 12:54:58 2001
                ***************
                *** 387,395 ****
                #endif

                /*
                ! * +wildignore 'wildignore' option
                */
                ! #ifdef FEAT_NORMAL
                # define FEAT_WILDIGN
                #endif

                --- 387,396 ----
                #endif

                /*
                ! * +wildignore 'wildignore' and 'backupskip' options
                ! * Needed for Unix to make "crontab -e" work.
                */
                ! #if defined(FEAT_NORMAL) || defined(UNIX)
                # define FEAT_WILDIGN
                #endif


                --
                hundred-and-one symptoms of being an internet addict:
                125. You begin to wonder how often it REALLY is necessary to get up
                and shower or bathe.

                /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
                ((( Creator of Vim - http://www.vim.org -- ftp://ftp.vim.org/pub/vim )))
                \\\ Help me helping AIDS orphans in Uganda - http://iccf-holland.org ///
              Your message has been successfully submitted and would be delivered to recipients shortly.