Loading ...
Sorry, an error occurred while loading the content.

Re: vim in xterm & mappings

Expand Messages
  • Neil Bird
    ... Ah. Sorry to get you excited, then! I m using the ksh that comes with Sparc/Solaris 2.6. I m trying to see if there s any version number associated with
    Message 1 of 8 , Jan 30, 2001
    • 0 Attachment
      Zdenek Sekera wrote:
      > > [ksh]
      > > $ alias ^[R15~='echo paging down'
      > > $ ^[R15~ jobby
      > > paging down jobby
      >
      > This is really incredible. I was going through Bolsky & Korn ksh book
      > reading
      > on aliases. It clearly says that, basically, all chars must be
      > alphanumeric.
      > So I gave up on that idea, without trying.

      Ah. Sorry to get you excited, then! I'm using the ksh that comes with
      Sparc/Solaris 2.6. I'm trying to see if there's any version number
      associated with it.

      Best I can find is the string "@(#)Version M-11/16/88i".


      For me, though, I simply typed ("<>" for key-presses, not literally):

      alias <C-V><kPgDn>='echo paging down'<return>

      I've not tried it with an 8-bit character, though (as you seem to be
      generating: "~[" == 8-bit version of "<esc>[" ? You weren't actually
      /typing/ "~[" were you?)


      > So, how did you make it work? What's your ksh version? On which hw/sw?
      > If this worked for me it would be an *ideal* solution, of course.

      See above; again, make sure you're typing <C-V> then the key you want to
      map, and not manually entering the character sequence.


      > But it didn't work before...this is what I tried before I sent out my
      > first mail,
      > ...hmmm, yes, found it: I had a plugin script with Xcw(..) (vim version)
      > that
      > defined the map xcw as cmap xcw...that's it! Ohhh, dummy!, I don't feel
      > well right now....:-(

      :-)


      > So it looks like that's the way to go. It's not as pretty as the 'alias'
      > way
      > would have been but maybe one shouldn't ask too much from computers :-)

      Well, as long as you /find/ a working solution. Prettiness can come
      later.


      > But I discovered, as I type, a new problem that I haven't spotted
      > before, though it can't be so new, that's the xterm resource spec.
      >
      > I have my keys definition, something like:
      >
      > *VT100*translations: #override \
      > *VT100*translations: #override \
      >
      > What could it be? I am allowed to have several 'override' sections, am I
      > not?
      > Would you have any idea what am I hitting here?

      I don;t actually know. I know what works, but it's still a bit of a
      black art! I'll check the Xt manual in a bit to see what it says. I've
      only ever used one. It may be a side effect of the way Xt processes a
      resource file - at a [complete] guess, you can have multiple #override
      entries (e.g., from multiple (xrdb -merge' calls), but a single file can
      only have one of each entry. Maybe?


      > So what might be my resource problem now? Damn....
      > Thanks, Neil, for brainstorming!

      'S'OK. I'll look at the ref. manual now ...


      Should we move this off the vim-dev list, now?

      --
      =====================- http://www.thalesgroup.com/ -=====================
      Neil Bird | If this .signature |
      work mailto:neil.bird@... | looks pants, then | $> cd /pub
      personal mailto:neil@... | stop using Outlook! | $> more beer
    Your message has been successfully submitted and would be delivered to recipients shortly.