Loading ...
Sorry, an error occurred while loading the content.

[trying again]: vim60n: is echohl working?

Expand Messages
  • Zdenek Sekera
    Trying again, didn t see any reaction, maybe it got lost in the traffic somewhere the first time. ... Subject: vim60n: is echohl working? Date: Fri, 24 Nov
    Message 1 of 4 , Dec 1, 2000
    • 0 Attachment
      Trying again, didn't see any reaction, maybe it got lost in the traffic
      somewhere the first time.


      -------- Original Message --------
      Subject: vim60n: is echohl working?
      Date: Fri, 24 Nov 2000 12:00:15 +0100
      From: Zdenek Sekera <zs@...>
      Organization: Silicon Graphics
      To: vim-dev <vim-dev@...>

      I tried

      echohl WarningMsg
      echo "something"
      echo None

      this works, the "something" is displayed in a different color.

      However trying anything else (:h highlight-groups) like 'SpecialKey',
      etc...) doesn't make the "something" come out in different color.
      Actually I think nothing else than 'WarningMsg' works.

      Yet by reading :h echohl I have an impression it should.
      What's wrong?

      ---Zdenek
    • Bram Moolenaar
      ... I did see, but for me it works fine. I have no idea why it wouldn t work for you. Would be useful if you at least mention the version of Vim. Also check
      Message 2 of 4 , Dec 1, 2000
      • 0 Attachment
        Zdenek Sekera wrote:

        > Trying again, didn't see any reaction, maybe it got lost in the traffic
        > somewhere the first time.

        I did see, but for me it works fine. I have no idea why it wouldn't work for
        you. Would be useful if you at least mention the version of Vim. Also check
        the output of ":highlight".

        > -------- Original Message --------
        > Subject: vim60n: is echohl working?
        > Date: Fri, 24 Nov 2000 12:00:15 +0100
        > From: Zdenek Sekera <zs@...>
        > Organization: Silicon Graphics
        > To: vim-dev <vim-dev@...>
        >
        > I tried
        >
        > echohl WarningMsg
        > echo "something"
        > echo None
        >
        > this works, the "something" is displayed in a different color.
        >
        > However trying anything else (:h highlight-groups) like 'SpecialKey',
        > etc...) doesn't make the "something" come out in different color.
        > Actually I think nothing else than 'WarningMsg' works.
        >
        > Yet by reading :h echohl I have an impression it should.
        > What's wrong?
        >
        > ---Zdenek

        --
        WOMAN: Well, 'ow did you become king then?
        ARTHUR: The Lady of the Lake, [angels sing] her arm clad in the purest
        shimmering samite, held aloft Excalibur from the bosom of the water
        signifying by Divine Providence that I, Arthur, was to carry
        Excalibur. [singing stops] That is why I am your king!
        The Quest for the Holy Grail (Monty Python)

        /// Bram Moolenaar Bram@... http://www.moolenaar.net \\\
        \\\ Vim: http://www.vim.org ICCF Holland: http://iccf-holland.org ///
      • Vince Negri
        ... Err... he did! Look at the msg subject. :) Vince Negri (vnegri@aslnet.co.uk) Application Solutions Ltd. Tel:+44(0)1273-476608 Fax:+44(0)1273-478888 Legal
        Message 3 of 4 , Dec 1, 2000
        • 0 Attachment
          > Would be useful if you at least mention the version of Vim.

          Err... he did! Look at the msg subject. :)

          Vince Negri (vnegri@...)
          Application Solutions Ltd. Tel:+44(0)1273-476608 Fax:+44(0)1273-478888

          Legal Disclaimer: Any views expressed by the sender of this message are
          not necessarily those of Application Solutions Ltd. Information in this
          e-mail may be confidential and is for the use of the intended recipient
          only, no mistake in transmission is intended to waive or compromise such
          privilege. Please advise the sender if you receive this e-mail by mistake.
        • Zdenek Sekera
          Bram Moolenaar wrote: ... See Subject: ;-( ... Didn t know that s the way to find out what groups I have defined (I never played with highlighting so far ;-().
          Message 4 of 4 , Dec 1, 2000
          • 0 Attachment
            Bram Moolenaar wrote:
            ...
            > I did see, but for me it works fine. I have no idea why it wouldn't work for
            > you. Would be useful if you at least mention the version of Vim.

            See Subject: ;-(

            > Also check
            > the output of ":highlight".

            Didn't know that's the way to find out what groups I have defined (I
            never played
            with highlighting so far ;-(). Looks like those several I picked for
            tests were
            just those that looked all the same, when I check others it works. So it
            does
            work and I was raising inexistent problem. Sorry!

            ---Zdenek
          Your message has been successfully submitted and would be delivered to recipients shortly.