Loading ...
Sorry, an error occurred while loading the content.

Re: setlocal makeprg does not work

Expand Messages
  • Bram Moolenaar
    ... makeprg is a global option. There is no local value for it. You will have to use a BufLeave autocommand too. -- This is the polymorph virus! Follow
    Message 1 of 3 , Nov 29, 2000
    • 0 Attachment
      Johannes Zellner wrote:

      > # vim -u NONE
      > :au BufEnter *.vim setlocal makeprg=bla
      > :sp fred.vim
      > :set makeprg
      > makeprg=bla
      >
      > up to here everything is ok. Now switching back to
      > the initial window (^Wo) and typing
      >
      > :set makeprg
      > makeprg=bla
      >
      > setlocal seems not to work for makeprg, does it ?

      'makeprg' is a global option. There is no local value for it. You will have
      to use a "BufLeave" autocommand too.

      --
      This is the polymorph virus! Follow these instructions carefully:
      1. Send this message to everybody you know.
      2. Format your harddisk.
      Thank you for your cooperation in spreading the most powerful virus ever!

      /// Bram Moolenaar Bram@... http://www.moolenaar.net \\\
      \\\ Vim: http://www.vim.org ICCF Holland: http://iccf-holland.org ///
    Your message has been successfully submitted and would be delivered to recipients shortly.