Loading ...
Sorry, an error occurred while loading the content.

vim57 - installation error

Expand Messages
  • Willie duMaine
    vim57 Windows NT 4.0 During installation, I choose the option to add PATH to autoexec.bat file, and option to add edit with vim right-click popup menu.
    Message 1 of 3 , Aug 1, 2000
    • 0 Attachment
      vim57
      Windows NT 4.0

      During installation, I choose the option to add PATH
      to autoexec.bat file, and option to add "edit with
      vim" right-click popup menu. However, I received an
      error message saying 'gvim.exe' may not be included in
      the path when I used "edit with vim" menu to open a
      file.

      I checked "autoexec.bat" to ensure the PATH setting,
      and noticed the path setting included double
      quotes...i.e. PATH="C:\VIM57". I removed the double
      quotes and rebooted the machine, and it worked fine.

      I have installed version 5.4 before and this wasn't a
      problem. I think this is a bug in the installation
      process.

      Thanks,

      Willie duMaine
      wdumaine@...


      __________________________________________________
      Do You Yahoo!?
      Kick off your party with Yahoo! Invites.
      http://invites.yahoo.com/
    • Michael Geddes
      I m not sure that you should be setting the PATH in autoexec.bat in WinNT. You re better off setting them in ControlPannel|system|environment //. ... From:
      Message 2 of 3 , Aug 2, 2000
      • 0 Attachment
        I'm not sure that you should be setting the PATH in autoexec.bat in WinNT.
        You're better off setting them in ControlPannel|system|environment

        //.

        -----Original Message-----
        From: Willie duMaine [SMTP:wdumaine@...]
        Sent: Wednesday, 2 August 2000 6:32
        To: vim-dev@...
        Subject: vim57 - installation error

        vim57
        Windows NT 4.0

        During installation, I choose the option to add PATH
        to autoexec.bat file, and option to add "edit with
        vim" right-click popup menu. However, I received an
        error message saying 'gvim.exe' may not be included in
        the path when I used "edit with vim" menu to open a
        file.

        I checked "autoexec.bat" to ensure the PATH setting,
        and noticed the path setting included double
        quotes...i.e. PATH="C:\VIM57". I removed the double
        quotes and rebooted the machine, and it worked fine.

        I have installed version 5.4 before and this wasn't a
        problem. I think this is a bug in the installation
        process.

        Thanks,

        Willie duMaine
        wdumaine@...


        __________________________________________________
        Do You Yahoo!?
        Kick off your party with Yahoo! Invites.
        http://invites.yahoo.com/
      • Bram Moolenaar
        ... On other systems the double quotes are required when there is a space in the path name (like Program Files ). Does someone know the rule when the quotes
        Message 3 of 3 , Aug 3, 2000
        • 0 Attachment
          Willie duMaine wrote:

          > vim57
          > Windows NT 4.0
          >
          > During installation, I choose the option to add PATH
          > to autoexec.bat file, and option to add "edit with
          > vim" right-click popup menu. However, I received an
          > error message saying 'gvim.exe' may not be included in
          > the path when I used "edit with vim" menu to open a
          > file.
          >
          > I checked "autoexec.bat" to ensure the PATH setting,
          > and noticed the path setting included double
          > quotes...i.e. PATH="C:\VIM57". I removed the double
          > quotes and rebooted the machine, and it worked fine.

          On other systems the double quotes are required when there is a space in the
          path name (like "Program Files").

          Does someone know the rule when the quotes are to be added and when not?
          Perhaps we can decide what to do based on the version of Windows?

          For NT there should be another way to set the $PATH. But I don't know a
          reliable way to do this from install.exe.

          --
          hundred-and-one symptoms of being an internet addict:
          73. You give your dog used motherboards instead of bones

          /// Bram Moolenaar Bram@... http://www.moolenaar.net \\\
          \\\ Vim: http://www.vim.org ICCF Holland: http://iccf-holland.org ///
        Your message has been successfully submitted and would be delivered to recipients shortly.