Loading ...
Sorry, an error occurred while loading the content.
 

Re: term / ttymouse

Expand Messages
  • Bram Moolenaar
    ... The t_RV entry causes Vim to request the xterm version, and set ttymouse to xterm2 when it replies with a recent version number. Making t_RV empty
    Message 1 of 2 , Jul 25, 2000
      Johannes Zellner wrote:

      > to make the mouse working nicely in my screened rxvt
      > I tried in my ~/.vimrc:
      >
      > if exists('$COLORTERM')
      > set ttymouse=xterm
      > set term=xterm
      > endif
      >
      > and
      >
      > if exists('$COLORTERM')
      > set term=xterm
      > set ttymouse=xterm
      > endif
      >
      > both resulting in `ttymouse=xterm2'.
      > If I do `set ttymouse=xterm' manually it works.
      > Apparently somewhere after sourcing my ~/.vimrc the ttymouse gets
      > set to xterm2.
      >
      > did I make a mistake ?

      The t_RV entry causes Vim to request the xterm version, and set 'ttymouse' to
      "xterm2" when it replies with a recent version number. Making t_RV empty
      after setting 'term' should do it.

      Perhaps Vim should detect that 'ttymouse' was set manually, and not
      automatically set it to "xterm2"? Hmm, then you might have a problem if you
      don't know which xterm you are using, and set it to "xterm" first, expecting
      it to turn into "xterm2" for some xterms.

      --
      hundred-and-one symptoms of being an internet addict:
      9. All your daydreaming is preoccupied with getting a faster connection to the
      net: 28.8...ISDN...cable modem...T1...T3.

      /// Bram Moolenaar Bram@... http://www.moolenaar.net \\\
      \\\ Vim: http://www.vim.org ICCF Holland: http://iccf-holland.org ///
    Your message has been successfully submitted and would be delivered to recipients shortly.