Loading ...
Sorry, an error occurred while loading the content.

bug in vim-5.6.70

Expand Messages
  • Thomas Köhler
    Hi, There s a bug in visual mode. Let s first have a look at the online help (:help linewise): [...] Which motions are linewise, inclusive or exclusive is
    Message 1 of 3 , Apr 28 3:05 PM
    • 0 Attachment
      Hi,
      There's a bug in visual mode. Let's first have a look at the online
      help (:help linewise):
      [...]
      Which motions are linewise, inclusive or exclusive is mentioned below. There
      are however, two general exceptions:
      1. If the motion is exclusive and the end of the motion is in column 1, the
      end of the motion is moved to the end of the previous line and the motion
      becomes inclusive. Example: "}" ends at the first line after a paragraph,
      but "V}" will not include that line.

      Now, this does not work like explained here: V} in fact includes the
      empty line!
      As we all know, a misexplained feature is a bug :-)
      Let's fix one of both: the documentation or vim's behaviour :-)

      (I'd suggest the later: V}d shouldn't behave differently from d} which
      does not include that empty line)

      CU,
      Thomas

      --
      Thomas Köhler Email: jean-luc@... | LCARS - Linux
      <>< WWW: http://jeanluc-picard.de | for Computers
      IRC: jeanluc | on All Real
      PGP public key available from Homepage! | Starships
    • Bram Moolenaar
      ... You re right. This looks like a bug. I m not sure how the selection option applies here. Probably the same text should be select whatever its value
      Message 2 of 3 , Apr 29 4:16 AM
      • 0 Attachment
        Thomas Kohler wrote:

        > There's a bug in visual mode. Let's first have a look at the online
        > help (:help linewise):
        > [...]
        > Which motions are linewise, inclusive or exclusive is mentioned below. There
        > are however, two general exceptions:
        > 1. If the motion is exclusive and the end of the motion is in column 1, the
        > end of the motion is moved to the end of the previous line and the motion
        > becomes inclusive. Example: "}" ends at the first line after a paragraph,
        > but "V}" will not include that line.
        >
        > Now, this does not work like explained here: V} in fact includes the
        > empty line!

        You're right. This looks like a bug. I'm not sure how the 'selection' option
        applies here. Probably the same text should be select whatever its value is.
        When 'selection' is "exclusive" the cursor should end up in the empty line,
        when it's "inclusive" on the end of the previous line.

        --
        hundred-and-one symptoms of being an internet addict:
        176. You lie, even to user-friends, about how long you were online yesterday.

        /-/-- Bram Moolenaar --- Bram@... --- http://www.moolenaar.net --\-\
        \-\-- Vim: http://www.vim.org ---- ICCF Holland: http://www.vim.org/iccf --/-/
      • Thomas Köhler
        On Sat, Apr 29, 2000 at 01:15:27PM +0200, ... Well, I have tried selection=old,inclusive,exclusive and always there s the same behaviour. Doesn t seem to
        Message 3 of 3 , Apr 29 7:28 AM
        • 0 Attachment
          On Sat, Apr 29, 2000 at 01:15:27PM +0200,
          Bram Moolenaar <Bram@...> wrote:
          >
          > Thomas Kohler wrote:
          >
          > > There's a bug in visual mode. Let's first have a look at the online
          > > help (:help linewise):
          > > [...]
          > > Which motions are linewise, inclusive or exclusive is mentioned below. There
          > > are however, two general exceptions:
          > > 1. If the motion is exclusive and the end of the motion is in column 1, the
          > > end of the motion is moved to the end of the previous line and the motion
          > > becomes inclusive. Example: "}" ends at the first line after a paragraph,
          > > but "V}" will not include that line.
          > >
          > > Now, this does not work like explained here: V} in fact includes the
          > > empty line!
          >
          > You're right. This looks like a bug. I'm not sure how the 'selection' option
          > applies here. Probably the same text should be select whatever its value is.
          > When 'selection' is "exclusive" the cursor should end up in the empty line,
          > when it's "inclusive" on the end of the previous line.

          Well, I have tried selection=old,inclusive,exclusive and always there's
          the same behaviour. Doesn't seem to interfere with that...

          CU,
          Thomas

          --
          Thomas Köhler Email: jean-luc@... | LCARS - Linux
          <>< WWW: http://jeanluc-picard.de | for Computers
          IRC: jeanluc | on All Real
          PGP public key available from Homepage! | Starships
        Your message has been successfully submitted and would be delivered to recipients shortly.