Loading ...
Sorry, an error occurred while loading the content.

Re: [vimdev] one bug & two more things

Expand Messages
  • Dr. Charles E. Campbell
    ... Regards, Dr C -- Charles E Campbell, Jr, PhD _ __ __ Goddard Space Flight Center / /_/ _ _/ / cec@NgrOyphSon.gPsfAc.nMasa.gov
    Message 1 of 4 , Mar 6 6:21 AM
    • 0 Attachment
      Thus saith Vince Negri:
      > :set display=lastline
      > for more info,
      > :help display
      > Vince

      I think he meant:

      :he 'display'

      Regards,
      Dr C


      --
      Charles E Campbell, Jr, PhD _ __ __
      Goddard Space Flight Center / /_/\_\_/ /
      cec@... /_/ \/_//_/
      PGP public key: http://www.erols.com/astronaut/pgp.html/
    • Bram Moolenaar
      ... How do you type that á character? It s not on my keyboard, thus I normally enter it as a digraph: CTRL-K a ... With the standard Vi CTRL-D and CTRL-U
      Message 2 of 4 , Mar 18 1:02 PM
      • 0 Attachment
        Toni Gaya wrote:

        > 1) Linux Version. RedHat6.0. I use gvim (release 5.6.11). The problem is
        > that I am from Spanish, and we use accents (i.e. some letters are
        > "special"). Example: I can write an "a" with an accent. And I must get
        > "�", and I get "�a". Gvim falls. (vim -in console- works well). (I think
        > you must change the function you use to read characters from the
        > X-window?) (It affects Spanish version, but it must affect all the
        > languages that use accents).

        How do you type that "�" character? It's not on my keyboard, thus I normally
        enter it as a digraph: CTRL-K 'a

        > 2) Another thing: All versions of vim. I use vim as a word-processor,
        > with the word-wrap option activated. Why the option "scroll" does not
        > work as standard Vi? As you say: "{Vi is a bit different: 'scroll' gives
        > the number of screen lines instead of file lines, makes a difference
        > when lines wrap}". Why not to work as standard Vi?

        With the standard Vi CTRL-D and CTRL-U count file lines, thus scrolling more
        than half a page when lines wrap. With very long lines you may skip over
        lines and not see them. That is fixed in Vim.

        > It is very difficult to follow lines on screen when you use word-wrap option
        > on Vim...

        I don't understand this sentence...

        [from another message:]
        > I use vim with word-wrap option activated. It is very difficult to
        > follow a text if you a using page up, page down. Vim is different to
        > "standard Vi". With "standard Vi" the option 'set scroll=...' gives the
        > number of 'screen' lines to scroll, and with Vim the number of 'file'
        > lines to scroll. Have you never try to follow a text in Vim with
        > different long lines using wordwrap activated? it is "impossible". I
        > think it could be changed as "standard Vi", using the number of screen
        > lines to scroll. Another option could be use another valor option to say
        > to Vim the numbers of -screen- lines of previous page you would want to
        > see when you scroll. Example: If you say it is 2, when you use page-down
        > (or Ctrl-D), you will see the 2 last screen lines of the actual screen,
        > and the follow ones. (it would be better (?) because you could rescale
        > editing window, and it will work equally in all windows size).

        It's the other way around: Vi uses 'scroll' as file lines, Vim uses 'scroll'
        as screen lines. This is not related to wordwrap though. And page-down is
        CTRL-F, not CTRL-D. Please explain your point clearer!

        --
        hundred-and-one symptoms of being an internet addict:
        162. You go outside and look for a brightness knob to turn down the sun.

        /-/-- Bram Moolenaar --- Bram@... --- http://www.moolenaar.net --\-\
        \-\-- Vim: http://www.vim.org ---- ICCF Holland: http://www.vim.org/iccf --/-/
      Your message has been successfully submitted and would be delivered to recipients shortly.