Loading ...
Sorry, an error occurred while loading the content.

Re: a wee c

Expand Messages
  • Jon Miner
    ... [...] Doesn t show up on 5.6.8, 5.6, 5.5, or 5.4 on any of my systems... jon -- .Jonathan J. Miner------------------Division of Information Technology. ...
    Message 1 of 3 , Feb 4, 2000
    • 0 Attachment
      * Allan Kelly (akelly@...) [000204 06:31]:
      > [akelly@qube akelly]$ vim -u NONE -u NONE
      > c[akelly@qube akelly]$ vim --version
      [...]

      Doesn't show up on 5.6.8, 5.6, 5.5, or 5.4 on any of my systems...

      jon

      --
      .Jonathan J. Miner------------------Division of Information Technology.
      |miner@... University Of Wisconsin - Madison|
      |608/262.9655 Room 3149 Computer Science|
      `---------------------------------------------------------------------'

      I don't believe I've ever cuddled my elses.
      -- Larry Wall in <199806221550.IAA07171@...>
    • Allan Kelly
      ... t_RV is the culprit. ... That did it. Thanks very much, this was driving me mu, mu, mu, maad. al. -- # Allan Kelly
      Message 2 of 3 , Apr 18, 2000
      • 0 Attachment
        Bram Moolenaar wrote:
        >
        > Allan Kelly wrote:
        >
        > > No I still see it. It only happens inside a KDE konsole (not in an xterm)
        > > AFAICT, and it only happens for vim, not for gvim or ex (see below).
        > [...]
        > > OK, so I have no aliases. Now start vim and immediately :q
        > >
        > > [root@chinstrap /root] % vim -u NONE -U NONE
        > > c[root@chinstrap /root] %
        >
        > This is a problem with a termcap entry.
        >
        > Try ":set termcap" and check the output entries for a trailing "c".
        > Especially t_ke.

        t_RV is the culprit.

        > Try setting t_RV to an empty string. If that helps, then your terminal
        > doesn't interpret it correctly. It should be removed from the
        > termcap/terminfo entry then.
        >
        > This might be caused by using $TERM set to "xterm" but not really using an
        > xterm. Vim uses its builtin termcap entries then. You can work around this
        > by setting t_RV to an empty string in your .vimrc file.

        That did it. Thanks very much, this was driving me mu, mu, mu, maad.

        al.

        --

        # Allan Kelly http://www.plotsearch.co.uk
        # (+44) (0)131 524 8500
        # allan.kelly@...... ..
        # /Software Engineer/i . . . . .
        # ------------------------------ * . . . . .
        # "If you are a Visual Basic programmer, * . . .
        # these details are none of your business." * . . .
        # Mr Bunny's Guide to Active X, by Carlton Egremont III * . .
        # ------------------------------ vi: set noet tw=80 sts=4 ts=8 : .
      Your message has been successfully submitted and would be delivered to recipients shortly.