Loading ...
Sorry, an error occurred while loading the content.

74910Re: Rgrep not working on vim 64-bit, win7

Expand Messages
  • lazureus
    Jan 14, 2014
    • 0 Attachment
      W dniu wtorek, 14 stycznia 2014 17:17:57 UTC+1 użytkownik yega...@... napisał:
      > Hi,
      >
      >
      >
      > On Tue, Jan 14, 2014 at 5:17 AM, lazureus <lazureus86@...> wrote:
      >
      > > W dniu wtorek, 14 stycznia 2014 11:03:04 UTC+1 użytkownik JohnBeckett napisał:
      >
      > >> It looks like the wiki has had the answer since March 2013:
      >
      > >>
      >
      > >> http://vim.wikia.com/wiki/Script:311
      >
      > >>
      >
      > >> That is linked in the top line at:
      >
      > >>
      >
      > >> http://www.vim.org/scripts/script.php?script_id=311
      >
      > >>
      >
      > >> I have not used the plugin, but what is written at the above
      >
      > >>
      >
      > >> looks exactly what is needed to fix the error quoted earlier.
      >
      > >>
      >
      > >> John
      >
      > >
      >
      > > I found the reason of the problems, the problem was that in my .vimrc I added settings as follows:
      >
      > >
      >
      > > let Grep_Shell_Quoute_Char = "'"
      >
      > > let Grep_Shell_Escape_Char = "'"
      >
      > >
      >
      > > This was causing that :Rgrep, right now everything is just fine. However I don't
      >
      > > understand why it causes problems, maybe you can explain me this?
      >
      > >
      >
      >
      >
      > You have set both the quote and escape characters to single quote (').
      >
      > For Unix, the shell escape character should be set to backslash. The plugin
      >
      > sets these variables by default to the correct values. You don't need to change
      >
      > this in your .vimrc file.
      >
      >
      >
      > - Yegappan

      I see, thanks a lot for your help, I really appreciate it.

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Show all 19 messages in this topic