Loading ...
Sorry, an error occurred while loading the content.

74329Re: [PATCH] Subpixel rendering artifacts in GUI mode

Expand Messages
  • Thomas Tuegel
    Dec 3, 2013
    • 0 Attachment
      On Thu, Nov 28, 2013 at 3:31 PM, <nocd5rd@...> wrote:
      > Hi Thomas,
      > I applied the above patch and tested at Windows XP.
      >
      > It seems to fix the issue at "main text area", except "command line area" and "completion popup menu".
      > Is the problem of "command line area" fixed at GTK?
      >
      > best regards,
      > Masamichi ABE

      I don't see the subpixel artifacts in the command line area using GTK
      at all. Can you give an example of some command which produces the
      artifacts on Windows?

      The patch changes 'screen_line()', which is responsible for actually
      rendering all text (if I understand correctly). So, this patch
      _should_ fix text rendering everywhere. If not, then I wonder if the
      Windows GUI renders those areas differently.

      Regards,
      Thomas Tuegel

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Show all 8 messages in this topic