Loading ...
Sorry, an error occurred while loading the content.

74288Re: Patch 7.4.109

Expand Messages
  • Marcin Szamotulski
    Nov 29, 2013
      On 11:59 Fri 29 Nov , Bram Moolenaar wrote:
      >
      > Marcin Szamotulski wrote:
      >
      > > On 18:54 Thu 28 Nov , Bram Moolenaar wrote:
      > > >
      > > > Patch 7.4.109
      > > > Problem: ColorScheme autocommand matches with the current buffer name.
      > > > Solution: Match with the colorscheme name. (Christian Brabandt)
      > > > Files: runtime/doc/autocmd.txt, src/fileio.c, src/syntax.c
      >
      > [...]
      >
      > > Hello,
      > >
      > > I am happy to see this patch. I was hoping the following autocommand
      > > will work:
      > >
      > > au ColorScheme colorscheme_name :set bg=dark
      > >
      > > but unfortunately one has to set the background once again in order to
      > > visually see a change (when switching from light background colorscheme).
      >
      > The autocommand triggers *after* loading the colorscheme. And usually
      > you need to set the background before loading the colorscheme for it to
      > take effect. You can load the same colorscheme again, if you don't mind
      > the flickering.

      I don't mind flickering. I have tried this autocommand:
      au ColorScheme blue_sky :set bg=dark|colo blue_sky

      and it was not working. I had to run the :colorscheme command manually.

      Best regards,
      Marcin

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Show all 6 messages in this topic