Loading ...
Sorry, an error occurred while loading the content.

71725Re: fix tests for DOS/Windows

Expand Messages
  • Bram Moolenaar
    Jul 1, 2013
      Ken Takata wrote:

      > 2013/06/20 The 16:03:03 UTC+9 Bram Moolenaar wrote:
      > > When running the tests reloading is not an option.
      > >
      > > Perhaps explicitly setting 'fenc' would work?
      >
      > No, it doesn't solve the problem. When Vim loads test17.in,
      > the binary part is already broken, because the default value of
      > 'encoding' is cp932 on my Windows environment.
      > To load the binary part properly:
      >
      > 1. 'enc' should be set to latin1 or utf-8.
      > 2. After setting 'enc' properly, test17.in should be reloaded with
      > 'fenc=latin1'. (E.g. use ':e ++enc=latin1')
      >
      > If reloading is not allowed, the binary part should be a separate file.
      > Here is a patch.

      Thanks. I suppose there is no other way than to use a separate file.

      We should use "latin1" encoding so that it works without the multi_byte
      feature.

      --
      With sufficient thrust, pigs fly just fine.
      -- RFC 1925

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Show all 11 messages in this topic