Loading ...
Sorry, an error occurred while loading the content.

68870Strange shell behaviour on Windows 7

Expand Messages
  • Paul Moore
    Mar 27 5:03 AM
    • 0 Attachment
      Something odd is happening for me on Windows 7 (64 bit). I have my own compiled copy of Vim, and when I run

      :%!sparkup

      I get "Shell returned 1" and the buffer is empty. Here, sparkup(.py) is a Python file - I have a .py file association and .py in my PATHEXT variable. The same command works fine when executed from a cmd.exe (or powershell) prompt.

      In messing around trying to work out what is going on, I find that setting 'shellxquote' to "( rather than its default of ( fixes the problem. And yet I see no reason why this should be necessary - other commands like tr a-z A-Z work fine, and if the vim default was wrong, I'm sure many more people than me would have had issues.

      I'm not sure what on earth I can do to get any further with this - obviously I can simply set shellxquote and ignore the problem, but I'm worried that there may be some underlying issue that I really should address.

      Paul

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Show all 2 messages in this topic