Loading ...
Sorry, an error occurred while loading the content.

68623Issue 119 in vim: Euro sign on win32

Expand Messages
  • vim@...
    Mar 8, 2013
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 119 by Go.Zu...@...: Euro sign on win32
      http://code.google.com/p/vim/issues/detail?id=119

      What steps will reproduce the problem?
      To insert a € sign in "Insert Mode", i use
      3 keypress sequence :
      1 <C-k> >>> Ctrl-K key combination
      2 = >>> = key
      3 e >>> e key

      What is the expected output?

      What do you see instead?
      The cursor go to the beginning of the line, when setting encoding=utf-8,
      and none char to output. By default, the encoding is encoding=latin1, when
      input the 3 keys: <C-k>=e sequence, I see the e character on the display.
      But on Linux system this work well.

      What version of the product are you using? On what operating system?
      :ver
      VIM - Vi IMproved 7.3 (2010 Aug 15, compiled Mar 8 2013 20:05:11)
      MS-Windows 32-bit console version
      Included patches: 1-854

      Please provide any additional information below.
      One char is the expected to output, the euro sign €.
      My options are:
      --- Options ---
      autoindent hlsearch modified
      scroll=19 showmatch t_vb=
      encoding=utf-8 ignorecase number
      scrolloff=3 smartcase
      helplang=fr incsearch ruler
      shiftwidth=3 ttyfast
      backspace=indent,eol,start
      fileencodings=ucs-bom,utf-8,default,latin1


      --
      You received this message because this project is configured to send all
      issue notifications to this address.
      You may adjust your notification preferences at:
      https://code.google.com/hosting/settings

      --
      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php

      ---
      You received this message because you are subscribed to the Google Groups "vim_dev" group.
      To unsubscribe from this group and stop receiving emails from it, send an email to vim_dev+unsubscribe@....
      For more options, visit https://groups.google.com/groups/opt_out.
    • Show all 9 messages in this topic