Loading ...
Sorry, an error occurred while loading the content.

67485Issue 97 in vim: Fix --enable-pythoninterp on systems where python is a symlink to python3. [code]

Expand Messages
  • vim@googlecode.com
    Dec 9, 2012
    • 0 Attachment
      Status: New
      Owner: ----
      Labels: Type-Defect Priority-Medium

      New issue 97 by l...@...: Fix --enable-pythoninterp on systems
      where python is a symlink to python3. [code]
      http://code.google.com/p/vim/issues/detail?id=97

      What steps will reproduce the problem?
      1. Link /usr/bin/python to /usr/bin/python3
      2. Run ./configure --enable-pythoninterp

      What is the expected output? What do you see instead?
      I expect the ./configure script to succeed, but it fails because
      the ./configure script does not expect a python3 to be symlinked
      to `python`.

      What version of the product are you using? On what operating system?
      This happens on the current (2012-12-09) tip, everywhere where
      `python` is a symlink to `python3`.

      Please provide any additional information below.
      I have attached an hg-bundle that fixes the ./configure script by
      using the `AC_PATH_PROGS` autoconf macro to prefer a `python2`
      binary over a `python` one.

      Attachments:
      configure-systems-with-python2.bundle 151 KB

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 7 messages in this topic