Loading ...
Sorry, an error occurred while loading the content.

67372Re: Netrw failure with latest Vim

Expand Messages
  • Charles E Campbell
    Dec 1, 2012
    • 0 Attachment
      Fran├žois Ingelrest wrote:
      > Hi all,
      >
      > I've updated Vim to 7.3.744 (features=big) and now netrw fails the
      > second time I try to open a file using :Explore
      >
      > 1. Start vim
      > 2. :E and open a file
      > 3. :E fails
      >
      > At step 3 I get a blank screen with no listing. This seems to be
      > caused by this line in my .vimrc:
      >
      > let g:netrw_liststyle=3
      >
      > If I comment this line, everything works as expected.
      >
      > This is on a Debian Squeeze with netrw v146.
      >
      I see this problem, too (on a Scientific Linux box).

      Note the following:

      1. start vim

      2. :Ex .

      3. Pick some file
      :ls!

      You'll see something like

      4u# - "NetrwTreeListing 1" line 17

      (the line number is showing the line number of the file you selected in
      the NetrwTreeListing buffer)
      So, the NetrwTreeListing buffer is unlisted, is an alternate buffer (for
      :e #), and the current line number is 17.

      4. :b 4
      The NetrwTreeListing buffer is now empty. This is what is
      happening, essentially, to netrw when it tries to bring up the
      NetrwTreeListing buffer.

      Unfortunately, I haven't been able to duplicate this loss of buffer with
      a simpler example as yet.

      Regards,
      Chip Campbell



      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 13 messages in this topic