Loading ...
Sorry, an error occurred while loading the content.

67219Re: Patch 7.3.715

Expand Messages
  • Ike Devolder
    Nov 22, 2012
      Op donderdag 22 november 2012 20:24:40 schreef u:
      > On Thu, Nov 22, 2012 at 03:08:14PM +0100, Ike Devolder wrote:
      > > On Thu, Nov 22, 2012 at 09:08:48AM +0100, Christian Brabandt wrote:
      > > > On Thu, November 22, 2012 08:47, Ike Devolder wrote:
      > > > [Patch 7.3.315]
      > > >
      > > > > Anyone else having issues with this patch ?
      > > > >
      > > > > In my day to day work i use vim in combination with syntastic to do
      > > > > some
      > > > > linting for me. Since this patch i have frequent segfaults when
      > > > > syntastic kicks in. It seems related to this patch, maybe not
      > > > > immediatly
      > > > > due to setloclist itself but something related with quickfix.
      > > > >
      > > > > I'm sorry but atm i have no idea where to search.
      > > > >
      > > > > For now i'm stuck on 7.3.714 since that version can keep me working
      > > > > all
      > > > > day long.
      > > > >
      > > > > some output:
      > > > > --- start terminal output ---
      > > > > vim
      > > > > Vim: fataal signaal gevangen SEGV
      > > > >
      > > > > Vim: Finished.
      > > > > Segmentatiefout
      > > > > --- end terminal output ---
      > > >
      > > > It would help, if you can craft a reproducible example. I have no idea,
      > > > what syntastic is doing.
      > > >
      > > > regards,
      > > > Christian
      > >
      > > When i'm back at home i'll try to find a way to reproduce this problem
      > > consistently. I've had segfaults in many occasions but I dont yet have a
      > > pattern to make sure the segfault happens.
      > >
      > > I'm also not sure the problem lies in the patch itself but it was the
      > > trigger.
      >
      > i attach a minimum configuration + testfile where i have consistent
      > segfaults on.
      >
      > within the archive you can find index.php, it has a syntax error, the
      > following steps lead to segfault:
      >
      > vim index.php
      > - :w (with the syntax error, syntastic kicks in)
      > - goto end of phpinfo() and add ; :w (error is gone)
      > - undo u
      > - :w -> segfault
      >
      > uname -a:
      > Linux 3.6.7 #1 SMP PREEMPT Sun Nov 18 09:53:58 CET 2012 x86_64 GNU/Linux
      > distribution Arch Linux
      >
      > configure:
      > ./configure --prefix=/usr --localstatedir=/var/lib/vim \
      > --mandir=/usr/share/man --with-compiledby=BlackEagle \
      > --with-features=huge --enable-gpm --enable-acl --with-x=no \
      > --disable-gui --enable-multibyte --enable-cscope \
      > --disable-netbeans --enable-perlinterp=dynamic \
      > --enable-pythoninterp=dynamic --enable-python3interp=dynamic \
      > --enable-rubyinterp=dynamic --enable-luainterp=dynamic
      >
      > now tested with version 7.3.725, first noticed with 7.3.718 and then
      > detected that the problem went away when going back to 7.3.714
      >
      > to be able to build ruby dynamic on my machine i also needed the patch
      > of Ken Takata in the 7.3.721 thread:
      > https://groups.google.com/forum/?fromgroups=#!topic/vim_dev/-pxkvVyWZdo
      >
      > thx for looking into this

      ok i forgot on pre-requisite: you must have php installed so the syntastic
      plugin can run php -l to get the syntax error showing.

      --Ike

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 16 messages in this topic