Loading ...
Sorry, an error occurred while loading the content.

67173Re: Build issue: Cannot find xpm.h

Expand Messages
  • Christian Brabandt
    Nov 20, 2012
    • 0 Attachment
      On Tue, November 20, 2012 17:21, David Fishburn wrote:
      > I use a batch file for building Vim.
      > Ran it last about 2 weeks ago.
      >
      > Just trying to test on of Bram's patches.
      >
      > I updated via:
      > C:\OpenSrc>"C:\Program Files\Mercurial\hg.exe" clone
      > https://vim.googlecode.com/hg/ vim
      >
      >
      > On Windows 7 (64-bit).
      > I get the following:
      > ...
      > cl -c /W3 /nologo -I. -Iproto -DHAVE_PATHDEF -DWIN32
      > -DFEAT_CSCOPE -D
      > FEAT_NETBEANS_INTG -DFEAT_XPM_W32 -DWINVER=0x0400
      > -D_WIN32_WINNT=0x0400
      > /Fo
      > .\ObjGOLYi386/ /Ox /GL -DNDEBUG /Zl /MT -DFEAT_OLE -DFEAT_GUI_W32
      > -DDYNAMIC_ICO
      > NV -DDYNAMIC_GETTEXT -DFEAT_PYTHON -DDYNAMIC_PYTHON
      > -DDYNAMIC_PYTHON_DLL=\"pyth
      > on27.dll\" -DFEAT_PERL -DDYNAMIC_PERL -DDYNAMIC_PERL_DLL=\"perl510.dll\"
      > -DFEAT_
      > BIG /Fd.\ObjGOLYi386/ /Zi -I
      > C:\download\OpenSrc\vim\XPM_support_for_Netbeans\xpm-4.2.0\include -I
      > C:\download\OpenSrc\vim\XPM_support_for_Netbeans\xpm-4.2.0\..
      > \include xpm_w32.c
      > xpm_w32.c
      > xpm_w32.c(31) : fatal error C1083: Cannot open include file: 'xpm.h': No
      > such file or directory
      > NMAKE : fatal error U1077: '"c:\Program Files (x86)\Microsoft Visual
      > Studio
      > 10.0\VC\BIN\cl.EXE"' : return code '0x2'
      > Stop.
      >
      >
      > So something changed in the last couple of weeks related to this?
      >
      > I read up on :h configure-netbeans
      >
      > On MS-Windows:
      > --------------
      >
      > The Win32 support is now in beta stage.
      >
      > To use XPM signs on Win32 (e.g. when using with NetBeans) you can compile
      > XPM by yourself or use precompiled libraries from
      > http://iamphet.nm.ru/misc/
      >
      >
      > Those are the XPM files I am using and they are from 2004.
      >
      > Any ideas?

      There were some patches, regarding an xpm header file. See the thread
      starting here:
      http://groups.google.com/group/vim_dev/msg/18797fd7a6870517

      See also patch 7.3.622, 7.3.639, 7.3.653 and 7.3.655

      regards,
      Christian

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 3 messages in this topic