Loading ...
Sorry, an error occurred while loading the content.

64648Re: status of tests in src/testdir?

Expand Messages
  • David Pope
    Apr 3 10:36 PM
    • 0 Attachment
      On Tue, Apr 3, 2012 at 2:31 AM, Nazri Ramliy <ayiehere@...> wrote: 
      The doc is (just a teeny bit) inaccurate.

      I'm the one who wrote that note, and also the one who submitted the
      patch for the :find, :sfind and :tabfind completion, bugs and all :)

      For completion, the "/**" path specification is supported. The doc
      should be patched like this:

      [elided] 

      Thanks very much for responding Nazri.  I rechecked my results on a clean(er) source tree and now the test runs flawlessly.  So that means the problem is with my win32 symlink patch, which means your automated test served its purpose perfectly. :)  Onward to debugging my code...

      (To answer your question, I'm building x64 target using VS2010.)

      Separately, in order to get three of the tests to complete, I had to change the following line in Make_dos.mak:

       fixff:
              -$(VIMPROG) -u dos.vim --noplugin "+argdo set ff=dos|upd" +q *.in *.ok
      -       -$(VIMPROG) -u dos.vim --noplugin "+argdo set ff=unix|upd" +q dotest.in
      +       -$(VIMPROG) -u dos.vim --noplugin "+argdo set ff=unix|upd" +q dotest.in test60.ok test71.ok test74.ok

      These three tests output in ff=unix, either explicitly (test 60) or implicitly (tests 71, 74), so the diff fails.  Do they run without modifications for you?

      ----
      David Pope

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 9 messages in this topic