Loading ...
Sorry, an error occurred while loading the content.

64330Re: [patch] fixed compilation warning in version.c with gcc-4.7

Expand Messages
  • Bram Moolenaar
    Mar 4, 2012
    • 0 Attachment
      Dominique Pelle wrote:

      > Compiling vim-7.3.462 with gcc-4.7.0 20120213 (experimental),
      > gives the following compilation warning:
      >
      > version.c:2189:14: warning: array subscript is above array bounds
      > [-Warray-bounds]
      >
      > Warning looks scary but in this case it is harmless.
      > Attached patch changes the code to avoid the warning.

      Thanks!

      --
      "The sun oozed over the horizon, shoved aside darkness, crept along the
      greensward, and, with sickly fingers, pushed through the castle window,
      revealing the pillaged princess, hand at throat, crown asunder, gaping
      in frenzied horror at the sated, sodden amphibian lying beside her,
      disbelieving the magnitude of the frog's deception, screaming madly,
      "You lied!"
      - Winner of the Bulwer-Lytton contest (San Jose State University),
      wherein one writes only the first line of a bad novel

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 2 messages in this topic