Loading ...
Sorry, an error occurred while loading the content.

61589Re: [PATCH]Fix bug: %s/get_foo/ /g inserts "et_foo" not "get_foo"

Expand Messages
  • Bram Moolenaar
    Jun 6 8:53 PM
    • 0 Attachment
      Tyru wrote:

      > Sorry, I should have said about more details.
      >
      > This problem occurs in the following circumstances:
      > - 'incsearch' is on
      > - "get_foo" is under the cursor
      > - the last character on the command-line is "g" like %s/get_foo//g
      > - cursor position is <cursor>: %s/get_foo/<cursor>/g
      > - type <C-r><C-w>
      >
      > The reason why this problem occurred is,
      > that Vim looks for the part of inserted cword
      > from the end of command-line.
      > So I fixed that looks for from the current position of the command-line.

      OK, now I see the problem. Thanks for the patch, I'll add it later.

      --
      hundred-and-one symptoms of being an internet addict:
      148. You find it easier to dial-up the National Weather Service
      Weather/your_town/now.html than to simply look out the window.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ an exciting new programming language -- http://www.Zimbu.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 7 messages in this topic