Loading ...
Sorry, an error occurred while loading the content.

58940Re: [PATCH] link.sh: do not reduce library if linker supports --as-needed

Expand Messages
  • Kirill A. Shutemov
    Aug 31, 2010
      On Wed, Aug 25, 2010 at 07:28:04AM -0400, James Vega wrote:
      > On Wed, Aug 25, 2010 at 12:20:56PM +0300, Kirill A. Shutemov wrote:
      > > On Mon, Aug 23, 2010 at 03:44:12PM +0300, Kirill A. Shutemov wrote:
      > > > link.sh tries to avoid overlinking in a hackish way.
      > > > At least GNU ld supports --as-needed which provides the same functionality
      > > > at linker level. Let's use it.
      > >
      > > Any comments?
      >
      > Simply as a data point, I've been building Debian's Vim packages with
      > -Wl,--as-needed for ~2.5 years now so I'd be interested in having this
      > functionality done automatically when the proper tools are present.

      Seems, nobody cares. Sad.

      --
      Kirill A. Shutemov

      --
      You received this message from the "vim_dev" maillist.
      Do not top-post! Type your reply below the text you are replying to.
      For more information, visit http://www.vim.org/maillist.php
    • Show all 9 messages in this topic