Loading ...
Sorry, an error occurred while loading the content.

52242Re: Drupal .module proper support (fwd)

Expand Messages
  • Bram Moolenaar
    Nov 1, 2008
    • 0 Attachment
      Alexis Wilke wrote:

      > I'm developing on Drupal now a days and find it annoying that gvim cannot
      > detect that the .module are PHP files. So I added a few lines of code to
      > my filetype.vim to paliate. I would imagine some other vi lovers will run
      > in this one too. We could also support the .install files I guess. Also
      > that I do not have much of a problem with.

      Makes sense.

      You use this statement:

      if getline(1) =~ '<\?php'

      That backslash should probably not be there, since this matches "php" by
      itself. This might work better:

      if getline(1) =~ '<?php'

      --
      hundred-and-one symptoms of being an internet addict:
      163. You go outside for the fresh air (at -30 degrees) but open the
      window first to hear new mail arrive.

      /// Bram Moolenaar -- Bram@... -- http://www.Moolenaar.net \\\
      /// sponsor Vim, vote for features -- http://www.Vim.org/sponsor/ \\\
      \\\ download, build and distribute -- http://www.A-A-P.org ///
      \\\ help me help AIDS victims -- http://ICCF-Holland.org ///

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_dev" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Show all 6 messages in this topic