Loading ...
Sorry, an error occurred while loading the content.

30633Re: SEGV related to vimrc

Expand Messages
  • Bram Moolenaar
    Jan 1, 2003
      Tomas Vasko wrote:

      > > > Yes, it does! Thank you very much. Sorry for posting this to -dev. I
      > > > was sure of having found a bug in vim.
      > >
      > > For gcc 3.2 we add the argument -fno-strength-reduce. Could you try
      > > adding that argument instead of reducing -O2 to -O?
      > >
      > > Also try running configure with patch 6.1.260 included. It checks for
      > > versions 3.1 and 3.2. Perhaps we need to add 3.2.1 to the list of
      > > version numbers now?
      >
      > I have just now upgraded my gcc to version:
      > gcc (GCC) 3.2.2 20021231 (Debian prerelease)
      >
      > vim included patches 1-267 configured with --with-features=normal and
      > compiled by this gcc version with -O2 and without -fno-strength-reduce
      > passed all the tests OK, so it seems that 3.2.2 works well, but test for
      > 3.2.1 should be added...

      Thanks for testing this. I'll make a patch to add 3.2.1 to the list of
      versions that require "-fno-strength-reduce". Hopefully we have caught
      all "bad" gcc versions then.

      --
      Women are probably the main cause of free software starvation.

      /// Bram Moolenaar -- Bram@... -- http://www.moolenaar.net \\\
      /// Creator of Vim - Vi IMproved -- http://www.vim.org \\\
      \\\ Project leader for A-A-P -- http://www.a-a-p.org ///
      \\\ Lord Of The Rings helps Uganda - http://iccf-holland.org/lotr.html ///
    • Show all 8 messages in this topic