Loading ...
Sorry, an error occurred while loading the content.
 

Vim auto indent -- cursor/file reposition to screen center

Expand Messages
  • Uday Kumar Reddy
    Hi, I have Vim 7.2.60 on Linux. I now notice this change when I indent a file with =G (auto indent from current position to end of the file): the file is
    Message 1 of 5 , Jan 1, 2009
      Hi,

      I have Vim 7.2.60 on Linux. I now notice this change when I indent a file with ' =G'  (auto indent from current position to end of the file): the file is repositioned so that the cursor is at the center of the screen. Earlier, this used to not happen. I find this extremely inconvenient; gives a feeling of being lost in the file -- your position changes, you see parts that weren't there before and lose parts that were in view. Is there a way to make it work the old way, i.e., the cursor and file stay at the same place on the screen?

      Thanks.


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---

    • Uday Kumar Reddy
      Hi, I have Vim 7.2.60 on Linux. I now notice this change when I indent a file with =G (auto indent from current position to end of the file): the file is
      Message 2 of 5 , Jan 1, 2009
        Hi,

        I have Vim 7.2.60 on Linux. I now notice this change when I indent a file with ' =G'  (auto indent from current position to end of the file): the file is repositioned so that the cursor is at the center of the screen. Earlier, this used to not happen. I find this extremely inconvenient; gives a feeling of being lost in the file -- your position changes, you see parts that weren't there before and lose parts that were in view. Is there a way to make it work the old way, i.e., the cursor and file stay at the same place on the screen?

        Thanks.



        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---

      • Dominique Pelle
        ... I can t reproduce it using Vim-7.2.76 on Linux. File is reindented and cursor position does not change for me. You probably have something in your
        Message 3 of 5 , Jan 2, 2009
          Uday Kumar Reddy wrote:

          > Hi,
          >
          > I have Vim 7.2.60 on Linux. I now notice this change when I indent a file
          > with ' =G' (auto indent from current position to end of the file): the file
          > is repositioned so that the cursor is at the center of the screen. Earlier,
          > this used to not happen. I find this extremely inconvenient; gives a feeling
          > of being lost in the file -- your position changes, you see parts that
          > weren't there before and lose parts that were in view. Is there a way to
          > make it work the old way, i.e., the cursor and file stay at the same place
          > on the screen?
          >
          > Thanks.


          I can't reproduce it using Vim-7.2.76 on Linux. File is reindented and
          cursor position does not change for me.

          You probably have something in your settings that triggers it. Can
          you reproduce it with vim -u NONE -U NONE? If not, then you can
          try to narrow down by commenting pieces in your ~/.vimrc and/or
          removing local plugins until you find what's causing it.

          -- Dominique

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • StarWing
          maybe you changed the option virtualedit ? try to set it empty: se ve= ... --~--~---------~--~----~------------~-------~--~----~ You received this message
          Message 4 of 5 , Jan 2, 2009
            maybe you changed the option 'virtualedit' ? try to set it empty:
            se ve=


            On 1月2日, 下午6时26分, "Dominique Pelle" <dominique.pe...@...> wrote:
            > Uday Kumar Reddy wrote:
            > > Hi,
            >
            > > I have Vim 7.2.60 on Linux. I now notice this change when I indent a file
            > > with ' =G' (auto indent from current position to end of the file): the file
            > > is repositioned so that the cursor is at the center of the screen. Earlier,
            > > this used to not happen. I find this extremely inconvenient; gives a feeling
            > > of being lost in the file -- your position changes, you see parts that
            > > weren't there before and lose parts that were in view. Is there a way to
            > > make it work the old way, i.e., the cursor and file stay at the same place
            > > on the screen?
            >
            > > Thanks.
            >
            > I can't reproduce it using Vim-7.2.76 on Linux. File is reindented and
            > cursor position does not change for me.
            >
            > You probably have something in your settings that triggers it. Can
            > you reproduce it with vim -u NONE -U NONE? If not, then you can
            > try to narrow down by commenting pieces in your ~/.vimrc and/or
            > removing local plugins until you find what's causing it.
            >
            > -- Dominique
            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • StarWing
            maybe you changed the option virtualedit ? try to set it empty: se ve= ... --~--~---------~--~----~------------~-------~--~----~ You received this message
            Message 5 of 5 , Jan 2, 2009
              maybe you changed the option 'virtualedit' ? try to set it empty:
              se ve=


              On 1月2日, 下午6时26分, "Dominique Pelle" <dominique.pe...@...> wrote:
              > Uday Kumar Reddy wrote:
              > > Hi,
              >
              > > I have Vim 7.2.60 on Linux. I now notice this change when I indent a file
              > > with ' =G' (auto indent from current position to end of the file): the file
              > > is repositioned so that the cursor is at the center of the screen. Earlier,
              > > this used to not happen. I find this extremely inconvenient; gives a feeling
              > > of being lost in the file -- your position changes, you see parts that
              > > weren't there before and lose parts that were in view. Is there a way to
              > > make it work the old way, i.e., the cursor and file stay at the same place
              > > on the screen?
              >
              > > Thanks.
              >
              > I can't reproduce it using Vim-7.2.76 on Linux. File is reindented and
              > cursor position does not change for me.
              >
              > You probably have something in your settings that triggers it. Can
              > you reproduce it with vim -u NONE -U NONE? If not, then you can
              > try to narrow down by commenting pieces in your ~/.vimrc and/or
              > removing local plugins until you find what's causing it.
              >
              > -- Dominique
              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            Your message has been successfully submitted and would be delivered to recipients shortly.