Loading ...
Sorry, an error occurred while loading the content.
 

Re: To many inter-character space when display Simplified Chinese (zh_CN)

Expand Messages
  • bill lam
    No idea, mine just look ok. BTW you forgot to give details such as os being used, fonts and a screenshot.-- regards,
    Message 1 of 9 , Dec 2, 2008
      No idea, mine just look ok. BTW you forgot to give details such as os
      being used, fonts and a screenshot.

      --
      regards,
      ====================================================
      GPG key 1024D/4434BAB3 2008-08-24
      gpg --keyserver subkeys.pgp.net --recv-keys 4434BAB3
      唐詩242 王建 新嫁娘
      三日入廚下 洗手作羹湯 未諳姑食性 先遣小姑嘗

      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    • Steven Woody
      ... OS is slackware 12.1; guifonts in gvim set to Lucida Sans Typewriter 12 , please find the attachment for the screenshot. And, after read you email, I went
      Message 2 of 9 , Dec 2, 2008
        On Tue, Dec 2, 2008 at 10:17 PM, bill lam <cbill.lam@...> wrote:
        > No idea, mine just look ok. BTW you forgot to give details such as os
        > being used, fonts and a screenshot.
        >
        > --
        > regards,

        OS is slackware 12.1; guifonts in gvim set to "Lucida Sans Typewriter
        12", please find the attachment for the screenshot.

        And, after read you email, I went to set the guifont to the Chinese
        font simsun (新宋体 14). The result was interesting:
        1. the extra inter-char space problem just disappeared;
        2. the chinese characters look not so good, they are too thin to my eyes;
        3. the English characters look urgly, please see my another
        screenshot attached.

        I am thinking why gvim can not handle fonts just as good as other
        programs such firefox where the Chinse and English both look good and
        acceptable.

        Thanks in advance.

        --~--~---------~--~----~------------~-------~--~----~
        You received this message from the "vim_use" maillist.
        For more information, visit http://www.vim.org/maillist.php
        -~----------~----~----~----~------~----~------~--~---
      • Dennis Benzinger
        Hi Steven! ... I don t know Chinese so I can t tell how the characters should look like but here are some tips for choosing a font: Did you use a monospaced
        Message 3 of 9 , Dec 2, 2008
          Hi Steven!

          Am 02.12.2008 17:51, Steven Woody schrieb:
          > [...]
          > I am thinking why gvim can not handle fonts just as good as other
          > programs such firefox where the Chinse and English both look good and
          > acceptable.
          > [...]

          I don't know Chinese so I can't tell how the characters should look like
          but here are some tips for choosing a font:

          Did you use a monospaced font? You should use one with GVim (:help E236)

          You can use :set guifont=* to get a dialog where you can choose a font
          and get a preview of it.

          Did you check which font is used by Firefox? Try setting the same font
          in GVim. Perhaps Firefox works with English and Chinese because it is
          using two different fonts. Then you'll have to choose if you want nice
          Chinese or nice English characters in GVim.


          HTH,
          Dennis Benzinger

          --~--~---------~--~----~------------~-------~--~----~
          You received this message from the "vim_use" maillist.
          For more information, visit http://www.vim.org/maillist.php
          -~----------~----~----~----~------~----~------~--~---
        • anhnmncb
          ... Which gvim version do you use? I have no problem with gtk2 version: here is relevent setting for me: if has( gui_gtk2 ) set guifont=Bitstream Vera Sans
          Message 4 of 9 , Dec 2, 2008
            On 2008-12-02, Steven Woody wrote:
            >
            > Hi,
            >
            > I am running gvim to display/edit Simplified Chinese text when locale
            > was set to zh_CN.gbk. There are many space between Chinese
            > characters, this looks so urgly. But this does not happened for other
            > font-config program such as Xemacs and firefox. Does anyone know
            > where can I find help for this issue?
            >
            > Thanks in advance.
            >
            Which gvim version do you use?

            I have no problem with gtk2 version: here is relevent setting for me:

            if has("gui_gtk2")
            set guifont=Bitstream\ Vera\ Sans\ Mono\ 12,Fixed\ 12
            set guifontwide=Microsoft\ Yahei\ 12,WenQuanYi\ Zen\ Hei\ 12
            endif

            You should adjust it for you.

            Hope it helpful :)


            --
            Regards,
            anhnmncb


            --~--~---------~--~----~------------~-------~--~----~
            You received this message from the "vim_use" maillist.
            For more information, visit http://www.vim.org/maillist.php
            -~----------~----~----~----~------~----~------~--~---
          • Steven Woody
            ... Yes, it does help! By set up the guifont and guifontwide independently, both Chinse and English looks good! My gvim is version 7.1 and my current setting
            Message 5 of 9 , Dec 2, 2008
              On Wed, Dec 3, 2008 at 7:49 AM, anhnmncb <anhnmncb@...> wrote:
              >
              > On 2008-12-02, Steven Woody wrote:
              >>
              >> Hi,
              >>
              >> I am running gvim to display/edit Simplified Chinese text when locale
              >> was set to zh_CN.gbk. There are many space between Chinese
              >> characters, this looks so urgly. But this does not happened for other
              >> font-config program such as Xemacs and firefox. Does anyone know
              >> where can I find help for this issue?
              >>
              >> Thanks in advance.
              >>
              > Which gvim version do you use?
              >
              > I have no problem with gtk2 version: here is relevent setting for me:
              >
              > if has("gui_gtk2")
              > set guifont=Bitstream\ Vera\ Sans\ Mono\ 12,Fixed\ 12
              > set guifontwide=Microsoft\ Yahei\ 12,WenQuanYi\ Zen\ Hei\ 12
              > endif
              >
              > You should adjust it for you.
              >
              > Hope it helpful :)
              >

              Yes, it does help! By set up the guifont and guifontwide
              independently, both Chinse and English looks good! My gvim is version
              7.1 and my current setting is

              set guifont=Lucisa\ Sans\ Typewriter\ 12
              set guifontwide=新宋体\ 14

              Thank you so much!

              --~--~---------~--~----~------------~-------~--~----~
              You received this message from the "vim_use" maillist.
              For more information, visit http://www.vim.org/maillist.php
              -~----------~----~----~----~------~----~------~--~---
            • Steven Woody
              On Wed, Dec 3, 2008 at 1:34 AM, Dennis Benzinger ... Though the problem have bee resolved, I still thank you Dennis. And, I like to tell you, I can not tell
              Message 6 of 9 , Dec 2, 2008
                On Wed, Dec 3, 2008 at 1:34 AM, Dennis Benzinger
                <Dennis.Benzinger@...> wrote:
                >
                > Hi Steven!
                >
                > Am 02.12.2008 17:51, Steven Woody schrieb:
                >> [...]
                >> I am thinking why gvim can not handle fonts just as good as other
                >> programs such firefox where the Chinse and English both look good and
                >> acceptable.
                >> [...]
                >
                > I don't know Chinese so I can't tell how the characters should look like
                > but here are some tips for choosing a font:
                >
                > Did you use a monospaced font? You should use one with GVim (:help E236)
                >
                > You can use :set guifont=* to get a dialog where you can choose a font
                > and get a preview of it.
                >
                > Did you check which font is used by Firefox? Try setting the same font
                > in GVim. Perhaps Firefox works with English and Chinese because it is
                > using two different fonts. Then you'll have to choose if you want nice
                > Chinese or nice English characters in GVim.
                >

                Though the problem have bee resolved, I still thank you Dennis. And,
                I like to tell you, I can not tell what font the firefox is using,
                because all it's font setting for Western and Chinese are all
                Serif/Sans Serif. It seems, that is font-config who is playing in the
                background to select fonts for firefox. But I don't know how this
                works. Would anyone tell me?

                Thanks.

                --~--~---------~--~----~------------~-------~--~----~
                You received this message from the "vim_use" maillist.
                For more information, visit http://www.vim.org/maillist.php
                -~----------~----~----~----~------~----~------~--~---
              • bill lam
                ... You may try adding this to your ~/.fonts.conf SimSun SimSun-18030 AR
                Message 7 of 9 , Dec 2, 2008
                  On Wed, 03 Dec 2008, Steven Woody wrote:
                  > Though the problem have bee resolved, I still thank you Dennis. And,
                  > I like to tell you, I can not tell what font the firefox is using,
                  > because all it's font setting for Western and Chinese are all
                  > Serif/Sans Serif. It seems, that is font-config who is playing in the
                  > background to select fonts for firefox. But I don't know how this
                  > works. Would anyone tell me?

                  You may try adding this to your ~/.fonts.conf
                  <match target="font">
                  <test name="family">
                  <string>SimSun</string>
                  <string>SimSun-18030</string>
                  <string>AR PL ShanHeiSun Uni</string>
                  <string>AR PL New Sung</string>
                  <string>MingLiU</string>
                  <string>PMingLiU</string>
                  </test>
                  <edit binding="strong" mode="prepend" name="family">
                  <string>Tahoma</string>
                  <string>Arial</string>
                  <string>Verdana</string>
                  <string>DejaVu Sans</string>
                  <string>Bitstream Vera Sans</string>
                  </edit>
                  </match>

                  This will hopeful replace ugly english glyphs with your more familiar
                  fonts. But I'm not sure this will work for you because apparently
                  gnome use another config file.

                  --
                  regards,
                  ====================================================
                  GPG key 1024D/4434BAB3 2008-08-24
                  gpg --keyserver subkeys.pgp.net --recv-keys 4434BAB3
                  唐詩188 杜甫 宿府
                  清秋幕府井梧寒 獨宿江城蠟炬殘 永夜角聲悲自語 中天月色好誰看
                  風塵荏苒音書絕 關塞蕭條行陸難 已忍伶俜十年事 強移棲息一枝安

                  --~--~---------~--~----~------------~-------~--~----~
                  You received this message from the "vim_use" maillist.
                  For more information, visit http://www.vim.org/maillist.php
                  -~----------~----~----~----~------~----~------~--~---
                • Tony Mechelynck
                  ... - Unlike Firefox, gvim uses a fixed-size character cell (which depends on the guifont , but is constant all over the screen). It uses exactly one cell for
                  Message 8 of 9 , Dec 3, 2008
                    On 02/12/08 03:16, Steven Woody wrote:
                    > Hi,
                    >
                    > I am running gvim to display/edit Simplified Chinese text when locale
                    > was set to zh_CN.gbk. There are many space between Chinese
                    > characters, this looks so urgly. But this does not happened for other
                    > font-config program such as Xemacs and firefox. Does anyone know
                    > where can I find help for this issue?
                    >
                    > Thanks in advance.
                    >
                    > -
                    > narke

                    - Unlike Firefox, gvim uses a fixed-size character cell (which depends
                    on the 'guifont', but is constant all over the screen). It uses exactly
                    one cell for each "narrow" glyph (including all non-CJK glyphs) and
                    exactly two cells for each "wide" glyph (including Chinese characters).
                    Some characters are defined in Unicode as "ambiguous-width", for these
                    the 'ambiwidth' option comes into play.

                    - The Lucida Sans Typewriter font is a Latin font, not a Chinese,
                    Japanese or Korean font; it includes no CJK glyphs. If you try to
                    display Chinese characters with 'guifont' set to it, gvim (with GTK2
                    GUI) will try to borrow the appropriate CJK glyphs from other fonts,
                    with the ugly result you notice. (Better than displaying a hollow
                    rectangle or a question mark, but, as you can see, far from perfect.)

                    - If the SimSun font's CJK glyphs are too thin for you, try another CJK
                    font; I'm not sure which ones are installed on your computer so I can't
                    give you definitive advice here. I used to like MingLiU when I was on
                    Windows, and FZFangSong here on Linux, but it is much a question of
                    taste and your taste is not necessarily the same as mine.

                    - To see exactly which fonts Firefox uses for which language, you may
                    need to open the "Advanced" fonts dialog, by means of a button on the
                    "ordinary" fonts-and-colours preferences page. (Exactly how these
                    dialogs are called varies somewhat between versions of Firefox.)

                    - See also http://vim.wikia.org/wiki/Setting_the_font_in_the_GUI


                    Best regards,
                    Tony.
                    --
                    "There are those who claim that magic is like the tide; that it swells
                    and fades over the surface of the earth, collecting in concentrated
                    pools here and there, almost disappearing from other spots, leaving
                    them parched for wonder. There are also those who believe that if you
                    stick your fingers up your nose and blow, it will increase your
                    intelligence."
                    -- The Teachings of Ebenezum, Volume VII

                    --~--~---------~--~----~------------~-------~--~----~
                    You received this message from the "vim_use" maillist.
                    For more information, visit http://www.vim.org/maillist.php
                    -~----------~----~----~----~------~----~------~--~---
                  Your message has been successfully submitted and would be delivered to recipients shortly.