Loading ...
Sorry, an error occurred while loading the content.
 

Re: bug? vim for freebsd doesn't know the cmd that set after login.

Expand Messages
  • anhnmncb
    ... Problem has resolved :) I think tcsh reads .cshrc no matter if is login shell or interactive shell. ...
    Message 1 of 10 , Nov 26, 2008
      On 2008-11-26, Tony Mechelynck wrote:
      >
      > On 25/11/08 02:52, anhnmncb wrote:
      > [...]
      >> I notice that when on linux, it hasn't such problem in bash, maybe it's
      >> a problem relative to tcsh? But I'm sorry I can't test it at this time
      >> :(
      >>
      >> I just want an env implemented in a particular shell in one particular
      >> screen window, so the ~/.login isn't what I need.
      > [...]
      >
      > I don't know about [t]csh, but bash determines which scripts to source
      > at startup according to whether or not it's a login shell and whether or
      > not it's an interactive shell. When Vim starts a bash shell, to handle a
      >:! command, it is (in the general case) neither a login shell nor an
      > interactive shell, and it inherits the environment from Vim, though some
      > settings may be modified before the :!command is run.

      Problem has resolved :) I think tcsh reads .cshrc no matter if is login shell
      or interactive shell.

      >
      >
      > Best regards,
      > Tony.


      --~--~---------~--~----~------------~-------~--~----~
      You received this message from the "vim_use" maillist.
      For more information, visit http://www.vim.org/maillist.php
      -~----------~----~----~----~------~----~------~--~---
    Your message has been successfully submitted and would be delivered to recipients shortly.